Subject: [OPSAWG] [Technical Errata Reported] RFC8520 (6295)

From: RFC Errata System <[email-masked]>
Date: Wed, 23 Sep 2020 13:09:02 -0700 (PDT)

The following errata report has been submitted for RFC8520,
"Manufacturer Usage Description Specification".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6295

--------------------------------------
Type: Technical
Reported by: Nick Lamb <[email-masked]>

Section: 4.1

Original Text
-------------
For example, if one saw the line "manufacturer" : "flobbidy.example.com",
then all Things that registered with a MUD URL that contained flobbity.example.com in its authority section would match.

Corrected Text
--------------
For example, if one saw the line "manufacturer" : "flobbity.example.com",
then all Things that registered with a MUD URL that contained flobbity.example.com in its authority section would match.

Notes
-----
Taken at face value it implies somehow a MUD Manager knows about a relationship between two different names flobbidy.example.com and flobbity.example.com in an unexplained way, the correction removes this confusion.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8520 (draft-ietf-opsawg-mud-25)
--------------------------------------
Title               : Manufacturer Usage Description Specification
Publication Date    : March 2019
Author(s)           : E. Lear, R. Droms, D. Romascanu
Category            : PROPOSED STANDARD
Source              : Operations and Management Area Working Group
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Wed, 23 Sep 2020 20:56:10 +0000

Looks like a straight typo and the correct outlined here makes sense to me.

Joe

> On Sep 23, 2020, at 16:09, RFC Errata System <[email-masked]> wrote:
>

---

From: Ralph Droms <[email-masked]>
Date: Wed, 23 Sep 2020 21:50:45 -0400

> On Sep 23, 2020, at 4:56 PM, Joe Clarke (jclarke) <[email-masked]> wrote:
> 

+1

- Ralph

---

From: Michael Richardson <[email-masked]>
Date: Thu, 24 Sep 2020 00:41:28 -0400

> Looks like a straight typo and the correct outlined here makes sense to

I agree.
I had to read if four times to see the one letter difference!

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Eliot Lear <[email-masked]>
Date: Thu, 24 Sep 2020 07:12:00 +0200

Agreed.  Thanks for spotting it.

> On 23 Sep 2020, at 22:56, Joe Clarke (jclarke) <[email-masked]> wrote:
>

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 24 Sep 2020 10:54:30 +0000

Thanks all for raising/confirming.

Now marked as verified.

Regards,
Rob

> -----Original Message-----
> From: Eliot Lear <[email-masked]>
> Sent: 24 September 2020 06:12
> To: Joe Clarke (jclarke) <[email-masked]>
> Cc: RFC Errata System <[email-masked]>; Ralph Droms
> <[email-masked]>; [email-masked]; [email-masked]; Rob Wilton
> (rwilton) <[email-masked]>; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Technical Errata Reported] RFC8520 (6295)
> 
> >> then all Things that registered with a MUD URL that contained
> flobbity.example.com in its authority section would match.
> >>
> >> Corrected Text
> >> --------------
> >> then all Things that registered with a MUD URL that contained
> flobbity.example.com in its authority section would match.
> >>
> >> Notes
> >> -----
> >> Taken at face value it implies somehow a MUD Manager knows about a
> relationship between two different names flobbidy.example.com and
> flobbity.example.com in an unexplained way, the correction removes this
> confusion.
> >>
> >> Instructions:
> >> -------------