Subject: [OPSAWG] Dhruv's comments (RE: CALL FOR ADOPTION: draft-bgbw-opsawg-vpn-common)

From: <[email-masked]>
Date: Thu, 3 Sep 2020 08:58:23 +0000

Hi Dhruv, 

Thank you for the comments. 

Please see inline. 

Cheers,
Med

> -----Message d'origine-----
> De : OPSAWG [mailto:[email-masked]] De la part de Dhruv Dhody
> Envoyé : mercredi 26 août 2020 16:48
> À : Joe Clarke (jclarke) <jclarke=[email-masked]>
> Cc : opsawg <[email-masked]>
> Objet : Re: [OPSAWG] CALL FOR ADOPTION: draft-bgbw-opsawg-vpn-common
> 
> Hi WG,
> 
> I support adoption. Just a few thoughts...
> 
> - This document has "Updates: 8782" in its header. Surely a mistake!

[Med] Yeah. Fixed now in draft-ietf-opsawg-vpn-common-00. 

> - This text
> 
>    To avoid the issues discussed above, this document defines a common
>    YANG module that is meant to be reused by various VPN-related
> modules
>    such as Layer 3 VPN Service Model (L3SM) [RFC8299], Layer 2 VPN
>    Service Model (L2SM) [RFC8466], Layer 3 VPN Network Model (L3NM)
>    [I-D.ietf-opsawg-l3sm-l3nm], and Layer 2 VPN Network Model (L2NM)
>    [I-D.ietf-opsawg-l2nm]: "ietf-vpn-common" (Section 4).
> 
> While it is clear how this common model can be used by work-in-
> progress L3NM and L2NM models, I am not sure about the published
> service model. Maybe you want to suggest that a future update of these
> service models MAY use this common model? If yes, better to be
> explicit.
> 

[Med] What about: 

OLD:
   To avoid the issues discussed above, this document defines a common
   YANG module that is meant to be reused by various VPN-related modules
   such as Layer 3 VPN Service Model (L3SM) [RFC8299], Layer 2 VPN
   Service Model (L2SM) [RFC8466], Layer 3 VPN Network Model (L3NM)
   [I-D.ietf-opsawg-l3sm-l3nm], and Layer 2 VPN Network Model (L2NM)
   [I-D.ietf-opsawg-l2nm]: "ietf-vpn-common" (Section 4).

   The "ietf-vpn-common" module includes a set of identities, types, and
   groupings that are meant to be reused by other VPN-related YANG
   modules independently of their layer (e.g., Layer 2, Layer 3) and the
   type of the module (e.g., network model, service model) including
   future revisions of existing models (e.g., L3SM [RFC8299] or L3SM
   [RFC8466]).

NEW:
   To avoid the issues discussed above, this document defines a common
   YANG module that is meant to be reused by various VPN-related modules
   such as Layer 3 VPN Network Model (L3NM) [I-D.ietf-opsawg-l3sm-l3nm] 
   and Layer 2 VPN Network Model (L2NM)[I-D.ietf-opsawg-l2nm]: 
   "ietf-vpn-common" (Section 4).

   The "ietf-vpn-common" module includes a set of identities, types, and
   groupings that are meant to be reused by other VPN-related YANG
   modules independently of their layer (e.g., Layer 2, Layer 3) and the
   type of the module (e.g., network model, service model) including
   future revisions of existing models (e.g., Layer 3 VPN Service Model 
   (L3SM) [RFC8299] or Layer 2 VPN Service Model (L2SM) [RFC8466]).

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 3 Sep 2020 14:39:05 +0530

Hi Med,

Thanks for considering my comments.

>    (L3SM) [RFC8299] or Layer 2 VPN Service Model (L2SM) [RFC8466]).

Would you also consider adding the word "possible" in front of "future
revisions of existing models" in the last sentence to highlight the fact
that no such revision is planned as of now.

Thanks!
Dhruv

---

From: <[email-masked]>
Date: Thu, 3 Sep 2020 09:34:30 +0000

Re-,

Sure.

Please expect the changes to be implemented -01.

Thank you.

Cheers,
Med

De : Dhruv Dhody [mailto:[email-masked]]
Envoyé : jeudi 3 septembre 2020 11:09
À : BOUCADAIR Mohamed TGI/OLN <[email-masked]>
Cc : opsawg <[email-masked]>
Objet : Re: Dhruv's comments (RE: [OPSAWG] CALL FOR ADOPTION: draft-bgbw-opsawg-vpn-common)

Hi Med,

[Med] What about:

OLD:

NEW:

Would you also consider adding the word "possible" in front of "future revisions of existing models" in the last sentence to highlight the fact that no such revision is planned as of now.

Thanks!
Dhruv