Subject: [OPSAWG] svc-common (RE: CALL FOR ADOPTION: draft-bgbw-opsawg-vpn-common

From: <[email-masked]>
Date: Thu, 3 Sep 2020 07:02:25 +0000

Hi Italo, 

I'm afraid that "svc-common" is too generic and does not reflect what we are planning to do in this draft: L2/L3 VPNs. I suggest we maintain the initial scope and name. 

Thank you. 

Cheers,
Med

> -----Message d'origine-----
> De : OPSAWG [mailto:[email-masked]] De la part de Italo Busi
> Envoyé : lundi 24 août 2020 11:57
> À : Joe Clarke (jclarke) <[email-masked]>; opsawg <[email-masked]>
> Objet : Re: [OPSAWG] CALL FOR ADOPTION: draft-bgbw-opsawg-vpn-common
> 
> I support the adoption of this draft as WG document
> 
> I think the scope of the draft/model can also be extended to be
> applicable to any service-type module and not being limited to only
> L2VPN and L3VPN. For example we can call it svc-common rather than
> vpn-common.
> 
> Regarding the approach, my preference is to include in the common
> module all the types/groupings which are common.
> 
> In order not to delay the progress of L3NM, it is possible to follow
> the same approach that has been followed in CCAMP WG with layer0-
> types: once L3NM is ready for WG LC, it is possible to move forward
> for WG LC only the common types/groupings which are needed by L3NM (as
> first revision of the common YANG module) and to move the
> types/groupings needed by other on-going work (e.g., L2NM) into a new
> draft which is intended to become a second revision of the common YANG
> module.
> 
> My 2 cents
> 
> Italo
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Italo Busi <[email-masked]>
Date: Wed, 23 Sep 2020 09:44:03 +0000

Hi Med,

When I look at the L2SM/L2NM, I can see some groupings/identities/types which are not really specific for L2VPN but have a broader applicability to other solutions/implementations of Ethernet services.

I therefore see some benefits in extending the potential scope of this module even if we can keep the scope of its initial revision limited/focused to what it is needed.

My 2 cents

Thanks, Italo

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]
> Sent: giovedì 3 settembre 2020 09:02
> To: Italo Busi <[email-masked]>; opsawg <[email-masked]>
> Subject: svc-common (RE: [OPSAWG] CALL FOR ADOPTION: draft-bgbw-
> opsawg-vpn-common
> 
> Hi Italo,
> 
> I'm afraid that "svc-common" is too generic and does not reflect what we are
> planning to do in this draft: L2/L3 VPNs. I suggest we maintain the initial scope
> and name.
> 
> Thank you.
> 
> Cheers,
> Med
> 
> > Envoyé : lundi 24 août 2020 11:57 À : Joe Clarke (jclarke)
> > <[email-masked]>; opsawg <[email-masked]> Objet : Re: [OPSAWG]
> > CALL FOR ADOPTION: draft-bgbw-opsawg-vpn-common
> >
> ________________________________________________________________
> _________________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites
> ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez
> le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les
> messages electroniques etant susceptibles d'alteration, Orange decline toute
> responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged
> information that may be protected by law; they should not be distributed,
> used or copied without authorisation.

---

From: <[email-masked]>
Date: Wed, 23 Sep 2020 11:56:55 +0000

Hi Italo, 

I agree that some might be reused by other non-VPN services, but I'm afraid that we can't claim that what we are defining is applicable to ** any ** service. 

If other modules see a benefit in reusing this common module, they can do so. It is up to these modules to discuss why they went with the approach. 

Thank you.

Cheers,
Med

> De : Italo Busi [mailto:[email-masked]]
> Envoyé : mercredi 23 septembre 2020 11:44
> À : BOUCADAIR Mohamed TGI/OLN <[email-masked]>; opsawg
> <[email-masked]>
> Objet : RE: svc-common (RE: [OPSAWG] CALL FOR ADOPTION: draft-bgbw-
> opsawg-vpn-common
> 
> Hi Med,
> 
> When I look at the L2SM/L2NM, I can see some
> groupings/identities/types which are not really specific for L2VPN
> but have a broader applicability to other solutions/implementations
> of Ethernet services.
> 
> I therefore see some benefits in extending the potential scope of
> this module even if we can keep the scope of its initial revision
> limited/focused to what it is needed.
> 
> My 2 cents
> 
> Thanks, Italo
> 
> > I'm afraid that "svc-common" is too generic and does not reflect
> what
> > we are planning to do in this draft: L2/L3 VPNs. I suggest we
> maintain
> > the initial scope and name.
> >
> > Thank you.
> >
> > Cheers,
> > Med
> >
> > > De : OPSAWG [mailto:[email-masked]] De la part de Italo
> > > Busi Envoyé : lundi 24 août 2020 11:57 À : Joe Clarke (jclarke)
> > > for WG LC only the common types/groupings which are needed by
> L3NM
> > > (as first revision of the common YANG module) and to move the
> > > types/groupings needed by other on-going work (e.g., L2NM) into
> a
> > > new draft which is intended to become a second revision of the
> > > common YANG module.
> > >
> > > My 2 cents
> > >
> > > Italo
> > >
> >
> >
> > confidentielles ou privilegiees et ne doivent donc pas etre
> diffuses,
> > exploites ou copies sans autorisation. Si vous avez recu ce
> message
> > par erreur, veuillez le signaler a l'expediteur et le detruire
> ainsi
> > que les pieces jointes. Les messages electroniques etant
> susceptibles
> > d'alteration, Orange decline toute responsabilite si ce message a
> ete altere, deforme ou falsifie. Merci.
> >
> > This message and its attachments may contain confidential or
> > privileged information that may be protected by law; they should
> not
> > be distributed, used or copied without authorisation.
> > If you have received this email in error, please notify the sender
> and
> > delete this message and its attachments.
> > As emails may be altered, Orange is not liable for messages that
> have
> > been modified, changed or falsified.
> > Thank you.