Subject: [OPSAWG] Éric Vyncke's No Objection on draft-ietf-opsawg-model-automation-framework-07: (with COMMENT)

From: Éric Vyncke via Datatracker <[email-masked]>
Date: Mon, 19 Oct 2020 05:45:52 -0700

Éric Vyncke has entered the following ballot position for
draft-ietf-opsawg-model-automation-framework-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-opsawg-model-automation-framework/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for the work put into this document.

Please find below a couple of non-blocking COMMENT points and nits. I hope that
this helps to improve the document,

Regards,

-éric

== COMMENTS ==

A generic comment: it hurts my eyes to see several occurrences of "NAT" as a
service in an IETF document in 2020...

Should there be a reference to
draft-claise-opsawg-service-assurance-architecture (albeit not yet an adopted
document) ?

There are a lot of detailed service creations with a good decomposition of all
the required steps; but, little is written on the importance of YANG models (as
opposed to any standard data exchange), so, the current title seems a little
misleading.

-- Abstract --
To be honest, I fail to understand why data models can be used to 'derive'
configuration information. Did the authors mean 'describe' or 'specify' ?

Later "This document describes an architecture" while the title of this
document if "framework" ? Slight semantic difference ;-)

And later "accommodate modules that", is it 'YANG modules' or 'data models' ?

-- Section 4 --
The complex figure 4 would benefit from some textual introduction referring to
the subsections. Also, the meaning of the arrow would gain if specified. E.g.,
why "Service Diagnosis" does not have a loop back to optimization or assurance ?

-- Section 4.2.2 --
If not mistaken, this is the first appearance of the notation "<intended>". Do
the angle brackets have a specific meaning?

-- Section 4.2.3 --
Suggestion to use the figure 4 wording as the title esp. since the wording of
MDT is not really used in the sub-section.

-- Section 6 --
Is it required/useful to have the 'standard YANG security considerations" in
this document that does not contain any YANG module?

-- Section 10.1 --
Most of the references should probably be informational only.

== NITS ==

Generic nit, I found the use of capitalized "Service Model" or "Network Models"
a little disturbing.

-- Section 1 --
"how different layer YANG data models" is rather difficult to parse, suggest to
rephrase it.

-- Section 4.4 --
Is it "service decomposing" or "service decomposition" ?

---

From: <[email-masked]>
Date: Tue, 20 Oct 2020 06:10:16 +0000

Hi Eric, 

Thank you for the comments. 

Please see inline.

Cheers,
Med

> -----Message d'origine-----
> De : OPSAWG [mailto:[email-masked]] De la part de Éric
> Vyncke via Datatracker
> Envoyé : lundi 19 octobre 2020 14:46
> À : The IESG <[email-masked]>
> Cc : [email-masked]; [email-masked]; draft-ietf-opsawg-
> [email-masked]
> Objet : [OPSAWG] Éric Vyncke's No Objection on draft-ietf-opsawg-
> model-automation-framework-07: (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to
> all email addresses included in the To and CC lines. (Feel free to
> cut this introductory paragraph, however.)
> 
> 
> Please find below a couple of non-blocking COMMENT points and nits.
> I hope that this helps to improve the document,
> 
> Regards,
> 
> -éric
> 
> == COMMENTS ==
> 
> A generic comment: it hurts my eyes 

[Med] It shouldn't :-)

to see several occurrences of
> "NAT" as a service in an IETF document in 2020...

[Med] Will double check. But, please note that from a YANG standpoint, the NAT module is not only about NAT44, but covers also NAT64, CLAT, SIIT, EAM, NPTv6. 

> draft-claise-opsawg-service-assurance-architecture (albeit not yet

[Med] We could consider adding it as another example under Section 5 if we had a volunteer to provide the text explaining the mapping with the arch in the document.  

> 
> There are a lot of detailed service creations with a good
> decomposition of all the required steps; but, little is written on
> the importance of YANG models (as opposed to any standard data
> exchange), so, the current title seems a little misleading.

[Med] The important of YANG is described in the intro, e.g., 

   o  Allow for vendor-agnostic interfaces to manage a service and the
      underlying network.

   o  Move from deployment schemes where vendor-specific network
      managers are required to a scheme where the entities that are
      responsible for orchestrating and controlling services and network
      resources provided by multi-vendor devices are unified.

   o  Ease data inheritance and reusability among the various
      architecture layers promoting thus a network-wise provisioning
      instead of device-specific configuration.

   o  Dynamically fed a decision-making process (e.g., Controllers,
      Orchestrators) with notifications that will trigger appropriate
      actions allowing thus to continuously adjust a network (and thus
      involved resources) to comply the intended service to deliver.

> configuration information. Did the authors mean 'describe' or

[Med] We meant "derive". Think about a service model (L3SM, for example), it does not specify the configuration that will be put into effect in a network, but will be used to derive a network model (L3NM), that will be used to derive the actual device configuration models. 

> Later "This document describes an architecture" while the title of
> this document if "framework" ? Slight semantic difference ;-)
> 

[Med] Will be fixed. 

> And later "accommodate modules that", is it 'YANG modules' or 'data

[Med] YANG modules. 

> 
> -- Section 4 --
> The complex figure 4 would benefit from some textual introduction
> referring to the subsections. Also, the meaning of the arrow would
> gain if specified. E.g., why "Service Diagnosis" does not have a
> loop back to optimization or assurance ?

[Med] Point Taken. Will add more text. 

> 
> -- Section 4.2.2 --
> If not mistaken, this is the first appearance of the notation
> "<intended>". Do the angle brackets have a specific meaning?

[Med] Yes, https://tools.ietf.org/html/rfc8342#section-5.1.4. We can add a pointer. 

> 
> -- Section 4.2.3 --
> Suggestion to use the figure 4 wording as the title esp. since the
> wording of MDT is not really used in the sub-section.

[Med] Fair point. Will be fixed. Thanks.

> 
> -- Section 6 --
> Is it required/useful to have the 'standard YANG security
> considerations" in this document that does not contain any YANG
> module?

[Med] The document is about manipulating YANG, hence the need to include the text. 

> Most of the references should probably be informational only.

[Med] Most of the RFCs that are cited there are required because of the security section. 

> Generic nit, I found the use of capitalized "Service Model" or

[Med] OK. 

> 
> -- Section 1 --
> "how different layer YANG data models" is rather difficult to parse,
> suggest to rephrase it.

[Med] Changed to " YANG data models at different layers "

> Is it "service decomposing" or "service decomposition" ?

[Med] Yes. Will be updated.  

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 20 Oct 2020 13:06:18 +0000

Bonjour Med,

Thank you for your reply and your actions that should improve the overall quality of the document.

I am still unclear about whether this overall document is YANG related as the focus appears to me more on a standard data model (where of course YANG can help). But, this is merely an academic-like non-blocking comment.

Regards

-éric

-----Original Message-----
From: "[email-masked]" <[email-masked]>
Date: Tuesday, 20 October 2020 at 08:10
To: Eric Vyncke <[email-masked]>, The IESG <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [OPSAWG] Éric Vyncke's No Objection on draft-ietf-opsawg-model-automation-framework-07: (with COMMENT)

    Hi Eric, 

    Please see inline.

    Cheers,
    Med

    [Med] It shouldn't :-)

    [Med] Will be fixed. 

    [Med] YANG modules. 

    [Med] OK.