Subject: [OPSAWG] TE Topology profile (FW: I-D Action: draft-busi-teas-te-topology-profiles-01.txt)

From: Italo Busi <[email-masked]>
Date: Mon, 22 Feb 2021 11:28:51 +0000

Dear TEAS, CCAMP, OPSAWG,

We would like to draw you attention to the following draft that we think it may be relevant for some on-going work on your WGs to address network scenarios being that are not classified as "Traffic Engineering" using a sub-set (profile) of the Traffic Engineering (TE) Topology YANG data model, defined in [RFC8795].

We would appreciate any feedbacks on this document.

The draft has been submitted to the TEAS WG which has been responsible for the development of RFC8795 so we would appreciate if you can send your comments at least to the TEAS WG mailing list.

Italo (on behalf of co-authors)

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: sabato 20 febbraio 2021 00:21
> To: [email-masked]
> Subject: I-D Action: draft-busi-teas-te-topology-profiles-01.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : Profiles for Traffic Engineering (TE) Topology Data Model
>         Authors         : Italo Busi
>                           Xufeng Liu
>                           Igor Bryskin
>                           Vishnu Pavan Beeram
>                           Tarek Saad
>                           Oscar Gonzalez de Dios
> 	Filename        : draft-busi-teas-te-topology-profiles-01.txt
> 	Pages           : 16
> 	Date            : 2021-02-19
> 
> Abstract:
>    This document describes how profiles of the Traffic Engineering (TE)
>    Topology Model, defined in RFC8795, can be used to address
>    applications beyond "Traffic Engineering".
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-busi-teas-te-topology-profiles/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-busi-teas-te-topology-profiles-01
> https://datatracker.ietf.org/doc/html/draft-busi-teas-te-topology-profiles-01
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-busi-teas-te-topology-profiles-01
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
>

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 23 Feb 2021 14:51:16 +0000

Hi Italo, authors,

I thinks this draft is extremely useful. 

There are at least two reasons that come to my mind:

1. Many times i heard concerns about the complexity of the TE topology model. It's true, it's a complex model, but it's possible to create profiles out of it and make it as simple as it is needed in a particular use case.
2. Another common objection is due to the fact that people are reluctant to use the TE topology for non TE use cases. We needed to have written somewhere that the TE topology, in addition to dealing with TE aspects, is also covering some network topology aspects there were left outside the scope of RFC8345.

Probably one solution would have been to rename the TE topology into "augmented topology" and specify that 90% of those augmentations where related to TE (to show that it was not 100% TE)...but this draft could work just fine.

Maybe just a minor comment on the title, it could try to cover both of the bullets above and be changed into something like: " Profiles for TE Topology Data Model and applicability to non TE use cases" . It can be improved...

Thanks
Daniele  

-----Original Message-----
From: CCAMP <[email-masked]> On Behalf Of Italo Busi
Sent: den 22 februari 2021 12:29
To: TEAS WG <[email-masked]>; CCAMP <[email-masked]>; opsawg <[email-masked]>
Subject: [CCAMP] TE Topology profile (FW: I-D Action: draft-busi-teas-te-topology-profiles-01.txt)

> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp