Subject: [OPSAWG] I-D Action: draft-ietf-opsawg-l3sm-l3nm-06.txt

From: [email-masked]
Date: Mon, 22 Feb 2021 00:24:21 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Operations and Management Area Working Group WG of the IETF.

        Title           : A Layer 3 VPN Network YANG Model
        Authors         : Samier Barguil
                          Oscar Gonzalez de Dios
                          Mohamed Boucadair
                          Luis Angel Munoz
                          Alejandro Aguado
	Filename        : draft-ietf-opsawg-l3sm-l3nm-06.txt
	Pages           : 124
	Date            : 2021-02-22

Abstract:
   This document defines a L3VPN Network YANG Model (L3NM) that can be
   used for the provisioning of Layer 3 Virtual Private Network (VPN)
   services within a service provider network.  The model provides a
   network-centric view of L3VPN services.

   L3NM is meant to be used by a network controller to derive the
   configuration information that will be sent to relevant network
   devices.  The model can also facilitate the communication between a
   service orchestrator and a network controller/orchestrator.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-opsawg-l3sm-l3nm/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-opsawg-l3sm-l3nm-06
https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-l3sm-l3nm-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-l3sm-l3nm-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Tue, 23 Feb 2021 13:55:49 +0000

Hi all, 

The main changes in the new version are as follows: 

* Generalize the concept of parent service: we used to have an option to bind it to L3SM, but now can bind it to any service request (e.g. L3SM, network slice, VPN+, ..)
* Generalize the concept of underlay transport: both abstract and technology-specific preferences can be manipulated in the module. This is inherited from the common module
* Add better clarity to the IP connection part 
* Add text to clarify the relationship with RFC8969
* Complete the security part of each routing protocol to rely on existing recommendations
* Add new attributes to prevent routing loops for multi-homed sites (SoO). Many thanks to Julian for raising this.    
* Complete the multicast part of the module (IGMP, MLD, PIM). 
* Add new text to address a comment from Rob about the full tree diagram
* Clarify how loopback interfaces can be created in the module
* Maximum routes can be tweaked not only based on the address family, but the protocol as well. 
* Align the examples with the updated structure + include examples with both IPv4 and IPv6

... and many many edits. 

FWIW, a list of closed issues can be tracked at: https://github.com/IETF-OPSAWG-WG/l3nm/issues?q=is%3Aissue+is%3Aclosed 

We do think that this version is now ready for the WGLC. 

Cheers,
Oscar & Med

> -----Message d'origine-----
> De : OPSAWG [mailto:[email-masked]] De la part de internet-
> [email-masked]
> Envoyé : lundi 22 février 2021 09:24
> À : [email-masked]
> Cc : [email-masked]
> Objet : [OPSAWG] I-D Action: draft-ietf-opsawg-l3sm-l3nm-06.txt
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.