Subject: [OPSAWG] [Fwd: Your thoughts on draft-richardson-mud-qrcode]

From: "RFC ISE (Adrian Farrel)" <[email-masked]>
Date: Mon, 15 Mar 2021 03:19:36 -0700

Hi OPSAWG chairs,

I wrote to you at the start of Janusary about draft-richardson-mud-qrcode/
 which is derived from draft-richardson-opsawg-securehomegateway-mud

My question was whether, in your opinion, this should be in the OPSAWG or
it is OK for it to be published in the Independent Stream.

I also wondered if you are aware of any history related to the document
that you could share with me.

I see from the mailing list that Michael has raised the draft on the list
a couple of times, but without any follow-up.

What I'd like to know (and the WG can contribute to this discussion) is
whether this is something that the WG would like to complete and publish
in the IETF stream.

Any thoughts?

Thanks,
Adrian
-- 
Adrian Farrel (Independent Stream Editor),
[email-masked]

---

From: Tianran Zhou <[email-masked]>
Date: Tue, 16 Mar 2021 07:03:15 +0000

Hi Adrian,

IMO, whether to apply ISE or WG adoption depends on the authors themselves.
If I recall right, we did not get the adoption request from the authors.
We welcome MUD related work, and we will consider from many aspects, like:
1. any conflict to existing solution
2. wg interests
...

But anyway, the WG mailing list could always be the place we can discuss about this technique.

Best,
Tianran
-----Original Message-----
From: RFC ISE (Adrian Farrel) [mailto:[email-masked]] 
Sent: Monday, March 15, 2021 6:20 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Fwd: Your thoughts on draft-richardson-mud-qrcode]

Hi OPSAWG chairs,

I wrote to you at the start of Janusary about draft-richardson-mud-qrcode/  which is derived from draft-richardson-opsawg-securehomegateway-mud

My question was whether, in your opinion, this should be in the OPSAWG or it is OK for it to be published in the Independent Stream.

I also wondered if you are aware of any history related to the document that you could share with me.

I see from the mailing list that Michael has raised the draft on the list a couple of times, but without any follow-up.

What I'd like to know (and the WG can contribute to this discussion) is whether this is something that the WG would like to complete and publish in the IETF stream.

Any thoughts?

Thanks,
Adrian
--
Adrian Farrel (Independent Stream Editor), [email-masked]

---

From: "RFC ISE (Adrian Farrel)" <[email-masked]>
Date: Tue, 16 Mar 2021 04:04:12 -0700

Thanks Tianran,

In my opinion, work that is in scope for an existing working group must
first be offered to that working group. If the working group has no
interest in pursuing it, that is OK and it can be brought to the
Independent Stream provided it does not conflict with ongoing work in the
working group.

Of course, I can form my own opinion on whether there is interest in the
working group, and I can make my own judgement about conflict, but it is
helpful if the working group chairs can give advice because they should
have a better understanding of what the working group thinks.

Best,
Adrian

Tianran Zhou wrote:
> I wrote to you at the start of Janusary about draft-richardson-mud-
> qrcode/ which is derived from draft-richardson-opsawg-
> securehomegateway-mud
>
> My question was whether, in your opinion, this should be in the OPSAWG
> or it is OK for it to be published in the Independent Stream.
>
> I see from the mailing list that Michael has raised the draft on the
> list a couple of times, but without any follow-up.
>
> whether this is something that the WG would like to complete and
> publish in the IETF stream.
>
> Any thoughts?
>
> Thanks,
> Adrian
> --

-- 
Adrian Farrel (ISE),
[email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Tue, 16 Mar 2021 16:16:38 -0400

> If I recall right, we did not get the adoption request from the

I actually did post back in 2020
  https://mailarchive.ietf.org/arch/msg/opsawg/w22FWi_D5586H_LK2UXtzXLhx88/

I got very little interest at all.

The document was then simplified, all the DPP integration was removed, and I
approached the Return Logistics Association (RLA.org) for a code that would
integrate into their system.

I think that the OPSAWG has very little available bandwidth for MUD related
things, and the mud-qrcode document is not where I would want to spend the
limited bandwidth of OPSAWG, since I think that there is very little for the
WG.   But, if the WG wants it, that's fine with me.

    > have a better understanding of what the working group thinks.

Unlike my other two MUD related documents, this document does not make any
changes at all to RFC8520.

The mud-acceptable-urls document an Update (Amends), for RFC8520, and needs
WG review.
The mud-iot-dns-considerations document is a BCP, and it is getting
cross-area review (and a dnsop presentation last week), and I have a number
of issues to deal with.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Eliot Lear <[email-masked]>
Date: Tue, 16 Mar 2021 21:28:54 +0100

I think it would benefit from opsawg review, and that a standard is appropriate in this instance.

Eliot

> On 16 Mar 2021, at 21:16, Michael Richardson <[email-masked]> wrote:
> 
> Signed PGP part
>

---

From: Tianran Zhou <[email-masked]>
Date: Wed, 17 Mar 2021 01:23:54 +0000

Hi Michael,

I am sorry for missing that mail.
Now we have IOTOPS for more bandwidth to discussion on MUD.
I think it would be a good idea to collect more interest in IOTOPS, and bring to OPSAWG.

Tianran

-----Original Message-----
From: OPSAWG [mailto:[email-masked]] On Behalf Of Michael Richardson
Sent: Wednesday, March 17, 2021 4:17 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [OPSAWG] [Fwd: Your thoughts on draft-richardson-mud-qrcode]

The document was then simplified, all the DPP integration was removed, and I approached the Return Logistics Association (RLA.org) for a code that would integrate into their system.

I think that the OPSAWG has very little available bandwidth for MUD related things, and the mud-qrcode document is not where I would want to spend the limited bandwidth of OPSAWG, since I think that there is very little for the
WG.   But, if the WG wants it, that's fine with me.

    > have a better understanding of what the working group thinks.

Unlike my other two MUD related documents, this document does not make any changes at all to RFC8520.

The mud-acceptable-urls document an Update (Amends), for RFC8520, and needs WG review.
The mud-iot-dns-considerations document is a BCP, and it is getting cross-area review (and a dnsop presentation last week), and I have a number of issues to deal with.

---

From: Michael Richardson <[email-masked]>
Date: Sat, 20 Mar 2021 16:52:25 -0400

> I think it would be a good idea to collect more interest in IOTOPS, and bring to OPSAWG.

I'm rather mystified by the meaning of this statement.
As WG chairs you are empowered to use your judgement, and you can run any
process you like to decide whether to adopt work, including, I like to
remind, doing it by fiat.  The "two week adoption call" is just a common process.

So, clearly you are suggesting some other process.
Perhaps you could explain to me what process you have envisioned here so that
I can follow it?

---

To those in the WGs, perhaps you could read:
  https://datatracker.ietf.org/doc/draft-richardson-mud-qrcode/

Editorial changes most welcome at https://github.com/CIRALabs/securehomegateway-mud/tree/ietf

I should note that there is almost no content in this document which the IETF
will have change control on. (I say almost, because I could say none, but I
might be wrong)

This is an application of a Reverse Logistics Association profile of the
MH10.8.2 Committee QR code control protocol to include an RFC8520 entry.

---

From: Tianran Zhou <[email-masked]>
Date: Mon, 22 Mar 2021 00:56:18 +0000

Hi Michael,

Sorry for not being clear.
My statement is on the following context from your previous mail.
"I got very little interest at all."
And
"I think that the OPSAWG has very little available bandwidth for MUD related things, and the mud-qrcode document is not where I would want to spend the limited bandwidth of OPSAWG, since I think that there is very little for the WG"

So my preliminary suggestion is
"I think it would be a good idea to collect more interest in IOTOPS, and bring to OPSAWG."

The chairs will discuss more about the next.

Cheers,
Tianran

-----Original Message-----
From: Michael Richardson [mailto:[email-masked]] 
Sent: Sunday, March 21, 2021 4:52 AM
To: Tianran Zhou <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [OPSAWG] [Fwd: Your thoughts on draft-richardson-mud-qrcode]

I'm rather mystified by the meaning of this statement.
As WG chairs you are empowered to use your judgement, and you can run any process you like to decide whether to adopt work, including, I like to remind, doing it by fiat.  The "two week adoption call" is just a common process.

So, clearly you are suggesting some other process.
Perhaps you could explain to me what process you have envisioned here so that I can follow it?

---

I should note that there is almost no content in this document which the IETF will have change control on. (I say almost, because I could say none, but I might be wrong)