Subject: [OPSAWG] Common/L2NM/L3NM work

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Fri, 12 Mar 2021 12:34:29 +0000

As mentioned in the 110 call, we want more author group updates
on-list.  As such, we ask that you summarize meetings including
decisions, draft text from decisions, and any relevant git issues that
the WG should be aware of.

Additionally, one thing was mentioned at the end of the Q&A where Oscar
said all modules needed to compile together.  Previously, Med had said
that they are independent enough to progress Common and L3NM separately
from L2NM.  I want to confirm that is indeed the case, and there are no
other interdependencies.

Joe

---

From: <[email-masked]>
Date: Fri, 12 Mar 2021 12:42:17 +0000

Re-,

Please see inline. 

Cheers,
Med

> -----Message d'origine-----
> De : OPSAWG [mailto:[email-masked]] De la part de Joe Clarke
> (jclarke)
> Envoyé : vendredi 12 mars 2021 13:34
> À : [email-masked]
> Objet : [OPSAWG] Common/L2NM/L3NM work
> 
> As mentioned in the 110 call, we want more author group updates on-
> list.  As such, we ask that you summarize meetings including
> decisions, draft text from decisions, and any relevant git issues
> that the WG should be aware of.
> 
> Additionally, one thing was mentioned at the end of the Q&A where
> Oscar said all modules needed to compile together.

[Med] I think what Oscar meant is that L2NM have a dependency on the common. Because the common was updated in the same repo as L3NM, it is simple to have L2NM under the same repo for to access the up to date common version. 

  Previously, Med
> had said that they are independent enough to progress Common and L3NM
> separately from L2NM.

[Med] I confirm. 

  I want to confirm that is indeed the case, and
> there are no other interdependencies.
> 
> Joe
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Oscar González de Dios <[email-masked]>
Date: Fri, 12 Mar 2021 12:42:24 +0000

Hi Joe,

L2NM and L3NM import the common VPN module. Hence, any change in the common impacts the other two. Thus, maintaining the 3 yang files together in the same repository for the CI tools was better to avoid inconsistencies. In our toolchain all the checks are done with the 3 at the same time.

As mentioned, the common module is stable, and the changes done now impact the  technology-specific matters. So, the L2 and L3 can evolve independently.

Best Regards,

Oscar

-----Mensaje original-----
De: OPSAWG <[email-masked]> En nombre de Joe Clarke (jclarke)
Enviado el: viernes, 12 de marzo de 2021 13:34
Para: [email-masked]
Asunto: [OPSAWG] Common/L2NM/L3NM work

As mentioned in the 110 call, we want more author group updates on-list.  As such, we ask that you summarize meetings including decisions, draft text from decisions, and any relevant git issues that the WG should be aware of.

Additionally, one thing was mentioned at the end of the Q&A where Oscar said all modules needed to compile together.  Previously, Med had said that they are independent enough to progress Common and L3NM separately from L2NM.  I want to confirm that is indeed the case, and there are no other interdependencies.

Joe

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição