Subject: Re: [OPSAWG] Requesting review & feedback - draft-mvmd-opsawg-ipfix-fwd-exceptions-02

From: <[email-masked]>
Date: Fri, 12 Mar 2021 12:31:23 +0000

Dear authors,

Speaking as a network operator, I welcome the effort in IPFIX to improve the drop cause declaration better.

As described, IE89 forwardingStatus covers the following categories

forwarded
dropped
consumed

I understood that the motivation of the draft is to increase the amount of code points for dropped from 6-bit (according to IANA, 16 code points currently used) to 32-bit and support the enterprise.

>From my perspective, it makes sense to support an enterprise bit for

forwarded
dropped
consumed

However, I miss a clear reason of the increase of size. I would appreciate if you could describe more drop causes which qualifies for the increase to 32-bit.

I would also to consider to include the existing code points from IE89 in forwardingExceptionCode as well to support a migration path. So a device does not need to export both.

Further please clarify the need of forwardingNexthopId over existing entities

IE15      ipNextHopIPv4Address
IE18      bgpNextHopIPv4Address
IE62      ipNextHopIPv6Address
IE63      bgpNextHopIPv6Address
IE47      mplsTopLabelIPv4Address

Best wishes
Thomas

From: OPSAWG <[email-masked]> On Behalf Of Venkata Chaitanya Munukutla
Sent: Monday, February 22, 2021 9:38 PM
To: [email-masked]
Subject: [OPSAWG] Requesting review & feedback - draft-mvmd-opsawg-ipfix-fwd-exceptions-02

WG,

We recently published a new version of the draft ( https://tools.ietf.org/html/draft-mvmd-opsawg-ipfix-fwd-exceptions-02<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-mvmd-opsawg-ipfix-fwd-exceptions-02&data=04%7C01%7CThomas.Graf%40swisscom.com%7Ca4f03da8f61048936eca08d8d771d4fc%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637496231201225710%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=qL61o9f4Px%2FeA1ffRXX1zwALEIlID6WDSy%2BlE2niDSY%3D&reserved=0> ) based on review comments & feedback from IETF 109.
Please do review this draft and let us know your feedback.

--
Title         : IP Flow Information Export (IPFIX) Information Elements Extension for Forwarding Exceptions.
Authors   : Chaitanya Munukutla
                    Shivam Vaid
                    Aditya Mahale
                    Devang Patel
Filename : draft-mvmd-opsawg-ipfix-fwd-exceptions-02
Last updated: 2021-02-04
Abstract  :
   This draft proposes couple of new Forwarding exceptions related
   Information Elements (IEs) and Templates for the IP Flow Information
   Export (IPFIX) protocol.  These new Information Elements and
   Exception Template can be used to export information about any
   forwarding errors in a network.  This essential information is
   adequate to correlate packet drops to any control plane entity and
   map it to an impacted service.  Once exceptions are correlated to a
   particular entity, an action can be assigned to mitigate such
   problems essentially enabling self-driving networks.
 --

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-mvmd-opsawg-ipfix-fwd-exceptions/<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-mvmd-opsawg-ipfix-fwd-exceptions%2F&data=04%7C01%7CThomas.Graf%40swisscom.com%7Ca4f03da8f61048936eca08d8d771d4fc%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637496231201225710%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=RG68bfLtbxSLNRrVlSNft9%2BuEt%2FsADdKyYUU51GSbfM%3D&reserved=0>

Side-by-side diff from version 00 for this draft is available at:
https://www.ietf.org/rfcdiff?url1=draft-mvmd-opsawg-ipfix-fwd-exceptions-00&url2=draft-mvmd-opsawg-ipfix-fwd-exceptions-02<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl1%3Ddraft-mvmd-opsawg-ipfix-fwd-exceptions-00%26url2%3Ddraft-mvmd-opsawg-ipfix-fwd-exceptions-02&data=04%7C01%7CThomas.Graf%40swisscom.com%7Ca4f03da8f61048936eca08d8d771d4fc%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637496231201235669%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=4XCq21S1oQ7B1%2FUgt1AO7FEEPCn3ID6oIC%2FnhwjUiB4%3D&reserved=0>

Regards,
Chaitanya.

Juniper Business Use Only

---

From: Benoit Claise <[email-masked]>
Date: Fri, 12 Mar 2021 16:49:33 +0100

Dear authors,

Next to Thomas's points, here is another one.
I see:

        5. Exception Templates

        This section presents a list of templates for reporting exceptions
        using newly proposed IEs in addition to few existing IEs.

I don't think it's a good idea to propose fixed templates in standards. 
IPFIX has been created with flexible templates in mind.
In other words, we don't want to relay the message that, in order to be 
compliant with the (future) RFC, we have to report the newly defined 
IPFIX information elements IN THE EXACT proposed templates.

Regards, Benoit

On 3/12/2021 1:31 PM, [email-masked] wrote:
>
> Dear authors,
>
> Speaking as a network operator, I welcome the effort in IPFIX to 
> improve the drop cause declaration better.
>
> I understood that the motivation of the draft is to increase the 
> amount of code points for dropped from 6-bit (according to IANA, 16 
> code points currently used) to 32-bit and support the enterprise.
>
> However, I miss a clear reason of the increase of size. I would 
> appreciate if you could describe more drop causes which qualifies for 
> the increase to 32-bit.
>
> I would also to consider to include the existing code points from IE89 
> in forwardingExceptionCode as well to support a migration path. So a 
> device does not need to export both.
>
> *From:*OPSAWG <[email-masked]> *On Behalf Of *Venkata 
> Chaitanya Munukutla
> *Sent:* Monday, February 22, 2021 9:38 PM
> *To:* [email-masked]
> *Subject:* [OPSAWG] Requesting review & feedback - 
> draft-mvmd-opsawg-ipfix-fwd-exceptions-02
>
> WG,
>
> We recently published a new version of the draft ( 
> https://tools.ietf.org/html/draft-mvmd-opsawg-ipfix-fwd-exceptions-02 
> <https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-mvmd-opsawg-ipfix-fwd-exceptions-02&data=04%7C01%7CThomas.Graf%40swisscom.com%7Ca4f03da8f61048936eca08d8d771d4fc%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637496231201225710%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=qL61o9f4Px%2FeA1ffRXX1zwALEIlID6WDSy%2BlE2niDSY%3D&reserved=0> 
> ) based on review comments & feedback from IETF 109.
>
> Title         : IP Flow Information Export (IPFIX) Information 
> Elements Extension for Forwarding Exceptions.
>
> https://datatracker.ietf.org/doc/draft-mvmd-opsawg-ipfix-fwd-exceptions/ 
> <https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-mvmd-opsawg-ipfix-fwd-exceptions%2F&data=04%7C01%7CThomas.Graf%40swisscom.com%7Ca4f03da8f61048936eca08d8d771d4fc%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637496231201225710%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=RG68bfLtbxSLNRrVlSNft9%2BuEt%2FsADdKyYUU51GSbfM%3D&reserved=0>
>
> https://www.ietf.org/rfcdiff?url1=draft-mvmd-opsawg-ipfix-fwd-exceptions-00&url2=draft-mvmd-opsawg-ipfix-fwd-exceptions-02 
> <https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl1%3Ddraft-mvmd-opsawg-ipfix-fwd-exceptions-00%26url2%3Ddraft-mvmd-opsawg-ipfix-fwd-exceptions-02&data=04%7C01%7CThomas.Graf%40swisscom.com%7Ca4f03da8f61048936eca08d8d771d4fc%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637496231201235669%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=4XCq21S1oQ7B1%2FUgt1AO7FEEPCn3ID6oIC%2FnhwjUiB4%3D&reserved=0>
>
> Regards,
>
> Chaitanya.
>
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: Venkata Naga Chaitanya Munukutla <[email-masked]>
Date: Mon, 15 Mar 2021 16:48:17 +0000

+Shivam, Aditya, Devang – other authors of the draft.

Thank you for reviewing the draft, Thomas! This is good feedback!
As suggested in the draft & during the WG discussion, this new information element expands the range for exception code since proprietary ASIC pipelines support many more exceptions & it is not trivial to normalize all of them and map to a normal range.
We’ll definitely consider adding support for forwarded & consumed categories for this new Information element.

forwardingNexthopID is not an IP address field. I am attaching a snippet from the draft explaining the field:

   In terms of a network device, next hop is the gateway to which packet
   should be forwarded corresponding to the path to final destination.
   A given router doesn't need to store the entire forwarding path
   information for a destination.  As long as it can identify the next
   hop to be used for forwarding to a destination, the end to end
   forwarding can happen.  This helps reduce size of forwarding table.
   The nexthop index uniquely identifies the egress path a packet would
   take to reach the destination.  This could include information about

   the outgoing interface, layer 2 address to be used, forwarding

   features configured for the packet path etc.

Please let us know if you have any further questions/suggestions.

Regards,
Chaitanya.

From: <[email-masked]>
Date: Friday, March 12, 2021 at 7:32 AM
To: <[email-masked]>, <[email-masked]>
Subject: RE: Requesting review & feedback - draft-mvmd-opsawg-ipfix-fwd-exceptions-02

Dear authors,

forwarded
dropped
consumed

forwarded
dropped
consumed

Best wishes
Thomas

WG,

Regards,
Chaitanya.

---

From: Venkata Naga Chaitanya Munukutla <[email-masked]>
Date: Mon, 15 Mar 2021 16:53:34 +0000

Thank you for reviewing the draft, Benoit!

Our intention is not to propose a fixed template for reporting exception data, but to provide a sample of what an IPFIX template would include while reporting dropped exceptions (including the new IEs).
We will definitely add a note in the draft suggesting that these are sample templates.

Please let us know if you have any other comments/suggestions.

Regards,
Chaitanya.

From: Benoit Claise <[email-masked]>
Date: Friday, March 12, 2021 at 10:49 AM
To: "[email-masked]" <[email-masked]>, Venkata Chaitanya Munukutla <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [OPSAWG] Requesting review & feedback - draft-mvmd-opsawg-ipfix-fwd-exceptions-02

[External Email. Be cautious of content]

Dear authors,

   using newly proposed IEs in addition to few existing IEs.
I don't think it's a good idea to propose fixed templates in standards. IPFIX has been created with flexible templates in mind.
In other words, we don't want to relay the message that, in order to be compliant with the (future) RFC, we have to report the newly defined IPFIX information elements IN THE EXACT proposed templates.

Regards, Benoit
On 3/12/2021 1:31 PM, [email-masked]<mailto:[email-masked]> wrote:
Dear authors,

forwarded
dropped
consumed

forwarded
dropped
consumed

Best wishes
Thomas

From: OPSAWG <[email-masked]><mailto:[email-masked]> On Behalf Of Venkata Chaitanya Munukutla
Sent: Monday, February 22, 2021 9:38 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [OPSAWG] Requesting review & feedback - draft-mvmd-opsawg-ipfix-fwd-exceptions-02

WG,

We recently published a new version of the draft ( https://tools.ietf.org/html/draft-mvmd-opsawg-ipfix-fwd-exceptions-02<https://urldefense.com/v3/__https:/eur03.safelinks.protection.outlook.com/?url=https*3A*2F*2Ftools.ietf.org*2Fhtml*2Fdraft-mvmd-opsawg-ipfix-fwd-exceptions-02&data=04*7C01*7CThomas.Graf*40swisscom.com*7Ca4f03da8f61048936eca08d8d771d4fc*7C364e5b87c1c7420d9beec35d19b557a1*7C1*7C0*7C637496231201225710*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=qL61o9f4Px*2FeA1ffRXX1zwALEIlID6WDSy*2BlE2niDSY*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!WeCxjkKWnEjBSnZHH_FIHjwdNUq9hEA26ZgGnv2doqEO2YNLlHwcVXan7BJ1lXCL$> ) based on review comments & feedback from IETF 109.
Please do review this draft and let us know your feedback.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-mvmd-opsawg-ipfix-fwd-exceptions/<https://urldefense.com/v3/__https:/eur03.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-mvmd-opsawg-ipfix-fwd-exceptions*2F&data=04*7C01*7CThomas.Graf*40swisscom.com*7Ca4f03da8f61048936eca08d8d771d4fc*7C364e5b87c1c7420d9beec35d19b557a1*7C1*7C0*7C637496231201225710*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=RG68bfLtbxSLNRrVlSNft9*2BuEt*2FsADdKyYUU51GSbfM*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!WeCxjkKWnEjBSnZHH_FIHjwdNUq9hEA26ZgGnv2doqEO2YNLlHwcVXan7A7MKOxT$>

Side-by-side diff from version 00 for this draft is available at:
https://www.ietf.org/rfcdiff?url1=draft-mvmd-opsawg-ipfix-fwd-exceptions-00&url2=draft-mvmd-opsawg-ipfix-fwd-exceptions-02<https://urldefense.com/v3/__https:/eur03.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Frfcdiff*3Furl1*3Ddraft-mvmd-opsawg-ipfix-fwd-exceptions-00*26url2*3Ddraft-mvmd-opsawg-ipfix-fwd-exceptions-02&data=04*7C01*7CThomas.Graf*40swisscom.com*7Ca4f03da8f61048936eca08d8d771d4fc*7C364e5b87c1c7420d9beec35d19b557a1*7C1*7C0*7C637496231201235669*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=4XCq21S1oQ7B1*2FUgt1AO7FEEPCn3ID6oIC*2FnhwjUiB4*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!WeCxjkKWnEjBSnZHH_FIHjwdNUq9hEA26ZgGnv2doqEO2YNLlHwcVXan7F9v0w3k$>

Regards,
Chaitanya.

OPSAWG mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/opsawg<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/opsawg__;!!NEt6yMaO-gk!WeCxjkKWnEjBSnZHH_FIHjwdNUq9hEA26ZgGnv2doqEO2YNLlHwcVXan7Ke78PbQ$>