Subject: [OPSAWG] FW: New Version Notification for draft-tgraf-ipfix-mpls-sr-label-type-07.txt

From: <[email-masked]>
Date: Wed, 24 Mar 2021 05:25:23 +0000

Dear OPSAWG,

As discussed at IETF 110. draft-tgraf-ipfix-mpls-sr-label-type has received a review from Benoit Claise and been updated to -07 version accordingly. Many thanks Benoit!

I am looking forward for adoption.

Best wishes
Thomas

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Wednesday, March 24, 2021 6:11 AM
To: Graf Thomas, INI-NET-TCZ-ZH1 <[email-masked]>
Subject: New Version Notification for draft-tgraf-ipfix-mpls-sr-label-type-07.txt

A new version of I-D, draft-tgraf-ipfix-mpls-sr-label-type-07.txt
has been successfully submitted by Thomas Graf and posted to the IETF repository.

Name:		draft-tgraf-ipfix-mpls-sr-label-type
Revision:	07
Title:		Export of MPLS Segment Routing Label Type Information in IP Flow Information Export (IPFIX)
Document date:	2021-03-24
Group:		Individual Submission
Pages:		6
URL:            https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-tgraf-ipfix-mpls-sr-label-type-07.txt&amp;data=04%7C01%7CThomas.Graf%40swisscom.com%7C0e25812c1e9743fcdd4708d8ee832fa7%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637521594492563807%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=sBjtPcTp5Z34yKZiB1BOl5%2FBLpgcH3tdR6cnPss3dd4%3D&amp;reserved=0
Status:         https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-tgraf-ipfix-mpls-sr-label-type%2F&amp;data=04%7C01%7CThomas.Graf%40swisscom.com%7C0e25812c1e9743fcdd4708d8ee832fa7%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637521594492563807%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=Bxaf5YiQBxvUUKWZMSsQClkxfCcWbeIV2L1INq4t1JQ%3D&amp;reserved=0
Htmlized:       https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-tgraf-ipfix-mpls-sr-label-type&amp;data=04%7C01%7CThomas.Graf%40swisscom.com%7C0e25812c1e9743fcdd4708d8ee832fa7%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637521594492563807%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=%2BkJKWPCEK1JstdqNCs16WUc3a7s9LllZjOQtjlXZAr4%3D&amp;reserved=0
Htmlized:       https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-tgraf-ipfix-mpls-sr-label-type-07&amp;data=04%7C01%7CThomas.Graf%40swisscom.com%7C0e25812c1e9743fcdd4708d8ee832fa7%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637521594492563807%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=ZZm6jKAQm9QqUtkEydWq37hsEKhiKPdzoq9BEkbjkwI%3D&amp;reserved=0
Diff:           https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-tgraf-ipfix-mpls-sr-label-type-07&amp;data=04%7C01%7CThomas.Graf%40swisscom.com%7C0e25812c1e9743fcdd4708d8ee832fa7%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637521594492563807%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=QfBavKuXOVIxOux1jPvz4edc%2F%2B0HzLInn6cdCmBCCBg%3D&amp;reserved=0

Abstract:
   This document introduces additional code points in the
   mplsTopLabelType Information Element for IS-IS, OSPFv2, OSPFv3 and
   BGP MPLS Segment Routing (SR) extensions to enable Segment Routing
   label protocol type information in IP Flow Information Export
   (IPFIX).

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Benoit Claise <[email-masked]>
Date: Wed, 24 Mar 2021 08:35:33 +0100

Hi Rob,

During the OPSAWG meeting, you asked me about 
draft-tgraf-ipfix-mpls-sr-label-type
     https://datatracker.ietf.org/doc/minutes-110-opsawg/

    Rob: this registry allows anyone to add them.
    Benoit: still worth publishing a doc to explain background.  Benoit will review.
    Thomas: First went directly to IANA.  IANA requested an official document.

    Rob: adopting this is the right thing to do.
    Joe: Benoit is on the hook to review.

So I did review the document and the new version is the outcome of it.

Considering that:
- This document has some value. Even if a document is not required to 
request IANA IPFIX Information Elements, documenting how multiple IPFIX 
IEs work together is a beneficial
- The IPFIX doctors (Paul Aitken and Andrew Feren) reviewed the document
- IANA (Michelle Coton) reviewed the document. Btw, they found a mistake 
in the IANA registry
- I now reviewed the document

I believe that:
- The document is ready today, even for WG LC IMO
- Since most key IFPIX players reviewed the document, you might not 
receive more additional reviews (that's somehow typical from OPSAWG, 
which consists of diverse OPS documents)
- Going through the normal WG process (call for adoption, call for 
reviews, ... ) might produce silence and give the wrong impression that 
nobody cares, except Thomas :-)

Therefore, I suggest to expedite the document processing, either within 
the WG by adopting and WG LC'ing the document today, or via AD sponsor.
Indeed, waiting some more will not provide any benefits IMO ... on the 
contrary.

Regards, Benoit

-------- Forwarded Message --------
Subject: 	FW: New Version Notification for 
draft-tgraf-ipfix-mpls-sr-label-type-07.txt
Date: 	Wed, 24 Mar 2021 05:25:23 +0000
From: 	[email-masked]
To: 	[email-masked]
CC: 	[email-masked]

Dear OPSAWG,

As discussed at IETF 110. draft-tgraf-ipfix-mpls-sr-label-type has 
received a review from Benoit Claise and been updated to -07 version 
accordingly. Many thanks Benoit!

Best wishes
Thomas

-----Original Message-----
From: [email-masked] <[email-masked]> Sent: 
Wednesday, March 24, 2021 6:11 AM
To: Graf Thomas, INI-NET-TCZ-ZH1 <[email-masked]>
Subject: New Version Notification for 
draft-tgraf-ipfix-mpls-sr-label-type-07.txt

A new version of I-D, draft-tgraf-ipfix-mpls-sr-label-type-07.txt
has been successfully submitted by Thomas Graf and posted to the IETF 
repository.

Name: draft-tgraf-ipfix-mpls-sr-label-type
Revision: 07
Title: Export of MPLS Segment Routing Label Type Information in IP Flow 
Information Export (IPFIX)
Document date: 2021-03-24
Group: Individual Submission
Pages: 6
URL: 
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-tgraf-ipfix-mpls-sr-label-type-07.txt&amp;data=04%7C01%7CThomas.Graf%40swisscom.com%7C0e25812c1e9743fcdd4708d8ee832fa7%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637521594492563807%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=sBjtPcTp5Z34yKZiB1BOl5%2FBLpgcH3tdR6cnPss3dd4%3D&amp;reserved=0
Status: 
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-tgraf-ipfix-mpls-sr-label-type%2F&amp;data=04%7C01%7CThomas.Graf%40swisscom.com%7C0e25812c1e9743fcdd4708d8ee832fa7%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637521594492563807%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=Bxaf5YiQBxvUUKWZMSsQClkxfCcWbeIV2L1INq4t1JQ%3D&amp;reserved=0
Htmlized: 
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-tgraf-ipfix-mpls-sr-label-type&amp;data=04%7C01%7CThomas.Graf%40swisscom.com%7C0e25812c1e9743fcdd4708d8ee832fa7%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637521594492563807%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=%2BkJKWPCEK1JstdqNCs16WUc3a7s9LllZjOQtjlXZAr4%3D&amp;reserved=0
Htmlized: 
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-tgraf-ipfix-mpls-sr-label-type-07&amp;data=04%7C01%7CThomas.Graf%40swisscom.com%7C0e25812c1e9743fcdd4708d8ee832fa7%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637521594492563807%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=ZZm6jKAQm9QqUtkEydWq37hsEKhiKPdzoq9BEkbjkwI%3D&amp;reserved=0
Diff: 
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-tgraf-ipfix-mpls-sr-label-type-07&amp;data=04%7C01%7CThomas.Graf%40swisscom.com%7C0e25812c1e9743fcdd4708d8ee832fa7%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637521594492563807%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=QfBavKuXOVIxOux1jPvz4edc%2F%2B0HzLInn6cdCmBCCBg%3D&amp;reserved=0

Abstract:

Please note that it may take a couple of minutes from the time of 
submission until the htmlized version and diff are available at 
tools.ietf.org.

The IETF Secretariat

---

From: Tianran Zhou <[email-masked]>
Date: Wed, 24 Mar 2021 09:25:04 +0000

Hi Benoit,

Thanks for your review comments.
I count your message as supportive in the adoption call.
:)

Cheers,
Tianran

From: OPSAWG [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Wednesday, March 24, 2021 3:36 PM
To: [email-masked]
Cc: [email-masked]
Subject: [OPSAWG] New Version Notification for draft-tgraf-ipfix-mpls-sr-label-type-07.txt

Hi Rob,

During the OPSAWG meeting, you asked me about draft-tgraf-ipfix-mpls-sr-label-type
    https://datatracker.ietf.org/doc/minutes-110-opsawg/

Considering that:
- This document has some value. Even if a document is not required to request IANA IPFIX Information Elements, documenting how multiple IPFIX IEs work together is a beneficial
- The IPFIX doctors (Paul Aitken and Andrew Feren) reviewed the document
- IANA (Michelle Coton) reviewed the document. Btw, they found a mistake in the IANA registry
- I now reviewed the document

I believe that:
- The document is ready today, even for WG LC IMO
- Since most key IFPIX players reviewed the document, you might not receive more additional reviews (that's somehow typical from OPSAWG, which consists of diverse OPS documents)
- Going through the normal WG process (call for adoption, call for reviews, ... ) might produce silence and give the wrong impression that nobody cares, except Thomas :-)

Therefore, I suggest to expedite the document processing, either within the WG by adopting and WG LC'ing the document today, or via AD sponsor.
Indeed, waiting some more will not provide any benefits IMO ... on the contrary.

Regards, Benoit

-------- Forwarded Message --------
Subject:

FW: New Version Notification for draft-tgraf-ipfix-mpls-sr-label-type-07.txt

Date:

Wed, 24 Mar 2021 05:25:23 +0000

From:

[email-masked]<mailto:[email-masked]>

To:

[email-masked]<mailto:[email-masked]>

CC:

[email-masked]<mailto:[email-masked]>

Dear OPSAWG,

Best wishes
Thomas

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]> Sent: Wednesday, March 24, 2021 6:11 AM
To: Graf Thomas, INI-NET-TCZ-ZH1 <[email-masked]><mailto:[email-masked]>
Subject: New Version Notification for draft-tgraf-ipfix-mpls-sr-label-type-07.txt

Abstract:

The IETF Secretariat