Subject: [OPSAWG] 🔔 WG Adoption Call for draft-claise-opsawg-service-assurance-yang-07

From: Henk Birkholz <[email-masked]>
Date: Tue, 27 Apr 2021 20:01:39 +0200

Dear OPSAWG members,

this starts a call for Working Group Adoption for

> https://datatracker.ietf.org/doc/html/draft-claise-opsawg-service-assurance-yang-07

ending on Tuesday, May 18th.

As a reminder, this I-D describes YANG modules intended to facilitate 
the aggregation of an assurance graph about the health of services and 
sub-services in a system of interconnected network devices. To achieve 
that, the I-D defines modules for graph updates about (sub-)services and 
corresponding health and symptom knowledge acquired via assurance telemetry.

Please reply with your support and especially any substantive comments 
you may have.

For the OPSAWG co-chairs,

Henk

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 29 Apr 2021 06:02:18 +0000

Without any hat, I support the adoption of this document by OPSAWG.

Having worked for 2 years on a very similar project/proof of concept, the YANG module approach is indeed correct and represent well the use cases.

Regards

-éric

-----Original Message-----
From: OPSAWG <[email-masked]> on behalf of Henk Birkholz <[email-masked]>
Date: Tuesday, 27 April 2021 at 20:02
To: opsawg <[email-masked]>
Subject: [OPSAWG] 🔔 WG Adoption Call for draft-claise-opsawg-service-assurance-yang-07

    Dear OPSAWG members,

    Henk

    _______________________________________________
    OPSAWG mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/opsawg

---

From: "maqiufang (A)" <[email-masked]>
Date: Thu, 29 Apr 2021 12:46:26 +0000

Hi,all
I support the adoption of this draft.

Needless to say, real-time monitoring and making sure that the network indeed complies with the desired service intent is the key to IBN.

Thanks to the authors for this work.

Best Regards,
Qiufang Ma

-----Original Message-----
From: OPSAWG [mailto:[email-masked]] On Behalf Of Henk Birkholz
Sent: Wednesday, April 28, 2021 2:02 AM
To: opsawg <[email-masked]>
Subject: [OPSAWG] 🔔 WG Adoption Call for draft-claise-opsawg-service-assurance-yang-07

Dear OPSAWG members,

As a reminder, this I-D describes YANG modules intended to facilitate the aggregation of an assurance graph about the health of services and sub-services in a system of interconnected network devices. To achieve that, the I-D defines modules for graph updates about (sub-)services and corresponding health and symptom knowledge acquired via assurance telemetry.

Please reply with your support and especially any substantive comments you may have.

Henk

---

From: Vladimir Vassilev <[email-masked]>
Date: Fri, 30 Apr 2021 11:32:28 +0200

IMO there is need for a standard YANG model allowing configuration and 
monitoring of services. In practical terms (taking the case where the 
model is implemented on the device side) service managers like systemd 
can be mapped to and managed according to a standard YANG model which 
potentially can be provided by this draft.

I am aware that configuration of the services is currently not in the 
scope but I would like to propose the model to be enhanced in this 
direction. IMO the model should at least allow for external augmentation 
for such purpose if the configuration model functionality is not 
considered to be in scope. The configuration part of the model can be 
made dependent on feature for implementations that prefer other means to 
configure the services and use the model only for monitoring.

/Vladimir

On 27/04/2021 20.01, Henk Birkholz wrote:
> that, the I-D defines modules for graph updates about (sub-)services 
> and corresponding health and symptom knowledge acquired via assurance 
> telemetry.
>