Subject: Re: [OPSAWG] Benjamin Kaduk's No Objection on draft-ietf-opsawg-tacacs-yang-10: (with COMMENT)

From: "Wubo (lana)" <[email-masked]>
Date: Thu, 22 Apr 2021 08:09:20 +0000

Hi Benjamin,

Thank you for the comments. Regarding the standards-track issue, I hope the IETF process can provide more guidance. For the rest, please see inline.

Best regards,
Bo

-----邮件原件-----
发件人: Benjamin Kaduk via Datatracker [mailto:[email-masked]] 
发送时间: 2021年4月22日 13:16
收件人: The IESG <[email-masked]>
抄送: [email-masked]; [email-masked]; [email-masked]; Joe Clarke <[email-masked]>; [email-masked]
主题: Benjamin Kaduk's No Objection on draft-ietf-opsawg-tacacs-yang-10: (with COMMENT)

Benjamin Kaduk has entered the following ballot position for
draft-ietf-opsawg-tacacs-yang-10: No Objection

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-opsawg-tacacs-yang/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I have very little to add that was not already mentioned by my colleagues (but I agree with Roman and Francesca that a compelling case for standards-track has not been visibly made).  These are basically nit-level comments.

Section 3

   authorization, and accounting servers.  Authentication is used to
   validate a user's username and password, authorization allows the
   user to access and execute commands at various command levels

I think that RFC 8907 uses the term "privilege level" for what is being referred to as "command level" here.
[Bo] Thanks for pointing this out. I will fix this.

Section 4

        leaf timeout {
          type uint16 {
            range "1..300";
          }

How was the maximum of 300 seconds chosen?
[Bo] This 5 minutes value comes from common practice. If you have other concerns, I will change the range to "1..max".

---

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 25 Apr 2021 10:44:38 -0700

Hi Bo,

> https://datatracker.ietf.org/doc/draft-ietf-opsawg-tacacs-yang/

I don't have any concerns, and thank you for the explanation.
If you want, you could perhaps say something in the description about
"timeout values larger than 300 seconds have not been useful in existing
deployments", but I'm not entirely sure that a statement of that nature
would fit very well with the overall tone of the document.  Please don't
feel obligated to add it just on my account.

-Ben