Subject: Re: [OPSAWG] LxNM Desing Team -- Minutes

From: SAMIER BARGUIL GIRALDO <[email-masked]>
Date: Fri, 9 Apr 2021 07:51:25 +0000

Dear OPSAWG,

The notes of the last desing meeting:

LXNM Desing Team Meeting
________________________________
<https://codimd.ietf.org/#Date>Date:

08-04-2021

<https://codimd.ietf.org/#Assistants>Assistants

  *   Roque Gagliano
  *   Raul Arco
  *   Mohamed Boucadair
  *   Luis Angel Muñoz
  *   Victor Lopez
  *   Oscar Gonzalez de dios
  *   Samier Barrguil

<https://codimd.ietf.org/#Agenda>Agenda

  *   Review the implementation section.
  *   Review of the open issues.

<https://codimd.ietf.org/#Discussion>Discussion

  *   Roque ask about the possibility to add cisco as part of the implementation section in the L3NM and the L2NM.
  *   In this moment the draft has pointers to the implementation<https://github.com/IETF-OPSAWG-WG/lxnm/tree/master/Implementattion> support of each vendor.
  *   VPN common has been submited this morning.
  *   Review the comments done by Druvh in the issue<https://github.com/IETF-OPSAWG-WG/lxnm/issues/263>

<https://codimd.ietf.org/#Action-Points>Action Points

  *   Check the status of the implementation sections. @Oscar
  *   Check the new issues and It’s solutions opened by Roque. @Med and @Samier
  *   Check the status of the document for the last-call review. @all

Regards,

Samier Barguil
Transport & IP Networks | GCTIO - Technology | CIT Centro Integrado de Transporte |

Móvil +57 3017026430

Móvil +34 665416074

E-mail [email-masked]

E-mail [email-masked]

________________________________
De: SAMIER BARGUIL GIRALDO
Enviado: jueves, 25 de marzo de 2021 19:57
Para: [email-masked] <[email-masked]>
Cc: Oscar González de Dios <[email-masked]>
Asunto: LxNM Desing Team -- Minutes

LXNM Desing Team Meeting
Date:

25-03-2021

<https://codimd.ietf.org/#Assistants0>Assistants

  *   Bo Wu
  *   Qin Wu
  *   Luis Muñoz
  *   Raul Arco
  *   Oscar Gonzalez de dios
  *   Samier Barrguil

<https://codimd.ietf.org/#Agenda0>Agenda

  *   Review of the open issues owned and opened by Qin Wu.
  *   Review the ESI issue

<https://codimd.ietf.org/#Discussion0>Discussion

  *   Issue 201<https://github.com/IETF-OPSAWG-WG/lxnm/issues/224>. Fast re-route i the L2NM.
     *   There are two scenarios sing and dual homing.
     *   Both requires the configuration of FRR in the PEs.
     *   Enable FRR for MAC routes between the local and remote end.
     *   Option #1: In both cases the global configuration of FRR applies.
     *   Option #2: Configure the FRR as part of the Far-End Configuration.
     *   How it is done today at device level

Cisco: By default, no backup next hop address is set for FRR.

Huawei: Sample configuration delivered by Qin.

Huawei: EVPN VPWS configuration Example（Interface+EVPL instance+EVPN instance）

Nokia: Raul is going to check if this is something supported in Nokia at service level or control plane.
<https://codimd.ietf.org/#Action-Points>Action Points

  *   Add samples on the text how the Single Active and Active/Active scenarios are covered by the model. @RaulArco
  *   Move the Ethernet Segment Identifier at VPN Network Access level. @Samier
  *   Add new issues to the GitHub based on expert review @Qin Wu<mailto:[email-masked]>

Regards,

Samier Barguil
Transport & IP Networks | GCTIO - Technology | CIT Centro Integrado de Transporte |

Móvil +57 3017026430

Móvil +34 665416074

E-mail [email-masked]

E-mail [email-masked]

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: SAMIER BARGUIL GIRALDO <[email-masked]>
Date: Fri, 16 Apr 2021 08:28:18 +0000

Dear OPSAWG,
The notes of the last desing meeting:
LxNM Design Team Meeting
________________________________
<https://codimd.ietf.org/#Date-15-04-2021>Date: 15-04-2021
<https://codimd.ietf.org/#Participants>Participants

     *   Roque Gagliano
     *   Luis Angel Muñoz
     *   Sergio Belloti
     *   Raul Arco
     *   Mohamed Boucadair
     *   Victor Lopez
     *   Oscar Gonzalez de dios
     *   Samier Barrguil

     *   Review latest changes<https://tinyurl.com/l3nm-latest> to the L3NM to address the WGLC comments.

     *   Check issue #269<https://github.com/IETF-OPSAWG-WG/lxnm/issues/269>

        *   Review if this is something vendor specific.
        *   Not clear the usability of this parameters in the NBI.
        *   Roque explained that the use case is for the Inter-domain connectivy for PE-CE connectivity.
        *   Nokia does not require this kind of configuration.
        *   Multi-hop EBGP connection against the CE.
     *   Check issue #266<https://github.com/IETF-OPSAWG-WG/lxnm/issues/266>

        *   Agree to add the pointer of a virtual interface to terminate the customer services.
     *   Check issue #273<https://github.com/IETF-OPSAWG-WG/lxnm/issues/273>

        *   RIP and NTP activation. Part of the Network infrastructure configuration. This was a last minute comment.
        *   For the NTP we need to include the rationale/paramters + add athentication.
     *   Check issue #275<https://github.com/IETF-OPSAWG-WG/lxnm/issues/275>

        *   no-prepend-global-asin the model there is no such thing as “global as”. There are local-autonompus-system at vpn-node level and vpn-network-access level. There is mandatory to check how to enable this functionality when the AS at “vpn-node” level is different from the Local AS of the VPN network access.
     *   Check the issue [#266](https://github.com/IETF-OPSAWG-WG/lxnm/issues/266

     *   Close issue #266<https://github.com/IETF-OPSAWG-WG/lxnm/issues/266>.
     *   For issue #273<https://github.com/IETF-OPSAWG-WG/lxnm/issues/273> add the authentication support.
     *   For issue #275<https://github.com/IETF-OPSAWG-WG/lxnm/issues/275> check how to relate the global AS and local AS in the model.
     *   The updated version of the L3NM will be submitted early next week

Regards,

Samier Barguil

Móvil +57 3017026430

Móvil +34 665416074

________________________________
De: SAMIER BARGUIL GIRALDO <[email-masked]>
Enviado: viernes, 9 de abril de 2021 9:51
Para: [email-masked] <[email-masked]>
Cc: Oscar González de Dios <[email-masked]>
Asunto: RE: LxNM Desing Team -- Minutes

LXNM Desing Team Meeting

08-04-2021

  *   Roque Gagliano
  *   Raul Arco
  *   Mohamed Boucadair
  *   Luis Angel Muñoz
  *   Victor Lopez
  *   Oscar Gonzalez de dios
  *   Samier Barrguil

Regards,

Samier Barguil

Móvil +57 3017026430

Móvil +34 665416074

LXNM Desing Team Meeting
Date:

25-03-2021

  *   Bo Wu
  *   Qin Wu
  *   Luis Muñoz
  *   Raul Arco
  *   Oscar Gonzalez de dios
  *   Samier Barrguil

Regards,

Samier Barguil

Móvil +57 3017026430

Móvil +34 665416074

---

From: SAMIER BARGUIL GIRALDO <[email-masked]>
Date: Fri, 30 Apr 2021 09:48:18 +0000

Dear OPSAWG,

The notes of the last design meeting:
Date: 29-04-2021
<https://codimd.ietf.org/#Participants>Participants

     *   Raul Arco
     *   Sergio Belloti
     *   Luis Angel Muñoz
     *   Erez Segev
     *   Mohamed Boucadair
     *   Victor Lopez
     *   Oscar Gonzalez de dios
     *   Samier Barguil

     *   Possible Scenarios for the EVPN and the L2NM.
     *   Review the open pull request on the repo.
     *   @Raul has prepared three possible scenarios.

     *   The draft expires next week. @Med has prepared a new version to submit.

     *   Review the open pull request on the repo.
– #289<https://github.com/IETF-OPSAWG-WG/lxnm/pull/289>: Add VRRP virtual address.
     *   Review the latest open issues in the repo.
        *   – #288<https://github.com/IETF-OPSAWG-WG/lxnm/issues/288>: VPN-ID under EVPN-BGP. It is a leaf reference to the service, and the mapping is 1:1, so we agree to remove it.
        *   – #287<https://github.com/IETF-OPSAWG-WG/lxnm/issues/287>: Extranets VPNs.
        *   – #286<https://github.com/IETF-OPSAWG-WG/lxnm/issues/286>: Redundancy information. Med has grouped all the redundancy related attributes in a shared container.
        *   – #283<https://github.com/IETF-OPSAWG-WG/lxnm/issues/283>: Factorization of data nodes.
     *   Review the possible EVPN implementation scenarios studied by Raul.

     *   @Med would like the review of #289<https://github.com/IETF-OPSAWG-WG/lxnm/pull/289> and accept the changes.
     *   The work is required to evaluate possible redundancy scenarios #286<https://github.com/IETF-OPSAWG-WG/lxnm/pull/286>.
     *   Update the service-VPN-id by parent-service-id to provide more clarity about its difference with the VPN-id.

Samier Barguil