Subject: Re: [OPSAWG] Source attribution in MUD files (RFC 8520)

From: Carsten Bormann <[email-masked]>
Date: Fri, 4 Jun 2021 08:56:02 +0200

On 2021-05-22, at 03:00, Hassan Habibi Gharakheili <[email-masked]> wrote:
> 
> If I understood correctly, the two statements (you mentioned below) are expected to be included in every published MUD profile. Right?
> 
> That makes sense to me -- happy to help.

Please do — even if you can’t put this into the files before the detailed YANG syntax is agreed, please put up a LICENSE file or some such now so that we can use your files in our curated repo.

Grüße, Carsten

---

From: Hassan Habibi Gharakheili <[email-masked]>
Date: Fri, 4 Jun 2021 08:41:11 +0000

Sure. We are happy to put up a LICENSE file in our repository (https://iotanalytics.unsw.edu.au/mudprofiles).  It would be great if you could provide us with a simple template of such license, or we should develop one?

Once we put up the license, we can also augment the “systeminfo” field of every MUD profile with the URL of the license.

For example,
·         systeminfo: "lifxbulb",
becomes something like this:
·         systeminfo: "lifxbulb (https://iotanalytics.unsw.edu.au/mud/license.txt)",
Your thoughts?

Regards,
Hassan

From: Carsten Bormann <[email-masked]>
Date: Friday, 4 June 2021 at 5:04 pm
To: Hassan Habibi Gharakheili <[email-masked]>
Cc: Eliot Lear <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: [OPSAWG] Source attribution in MUD files (RFC 8520)

Grüße, Carsten

---

From: Eliot Lear <[email-masked]>
Date: Fri, 4 Jun 2021 10:49:04 +0200

Hassan, why not trying out one of the SPDX licensing tags, a'la:

"|SPDX-License-Identifier: |0BSD".

See https://spdx.org/licenses/ and pick one you like.

On 04.06.21 10:41, Hassan Habibi Gharakheili wrote:
>
> Sure. We are happy to put up a LICENSE file in our repository 
> (https://iotanalytics.unsw.edu.au/mudprofiles 
> <https://iotanalytics.unsw.edu.au/mudprofiles>). It would be great if 
> you could provide us with a simple template of such license, or we 
> should develop one?
>
> Once we put up the license, we can also augment the “systeminfo” field 
> of every MUD profile with the URL of the license.
>
> For example,
>
> ·*systeminfo*: "lifxbulb",
>
> ·*systeminfo*: "lifxbulb 
> (https://iotanalytics.unsw.edu.au/mud/license.txt)",
>
> Your thoughts?
>
> Regards,
>
> Hassan
>
> *From: *Carsten Bormann <[email-masked]>
> *Date: *Friday, 4 June 2021 at 5:04 pm
> *To: *Hassan Habibi Gharakheili <[email-masked]>
> *Cc: *Eliot Lear <[email-masked]>, [email-masked] <[email-masked]>
> *Subject: *Re: [OPSAWG] Source attribution in MUD files (RFC 8520)
>
> > If I understood correctly, the two statements (you mentioned below) 
> are expected to be included in every published MUD profile. Right?
> >
> Please do — even if you can’t put this into the files before the 
> detailed YANG syntax is agreed, please put up a LICENSE file or some 
> such now so that we can use your files in our curated repo.
>
> Grüße, Carsten
>

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 4 Jun 2021 11:18:52 +0200

> Sure. We are happy to put up a LICENSE file in our repository (https://iotanalytics.unsw.edu.au/mudprofiles).  It would be great if you could provide us with a simple template of such license, or w…

Licenses are like crypto algorithms: They are better developed by specialized individuals and heavily cross-checked before being employed.  I would go for OSI-approved licenses only.
 
> ·         systeminfo: "lifxbulb (https://iotanalytics.unsw.edu.au/mud/license.txt)",

3.7.  systeminfo

   This is a textual UTF-8 description of the Thing to be connected.
   The intent is for administrators to be able to see a brief
   displayable description of the Thing.  It SHOULD NOT exceed 60
   characters worth of display space.

I don’t think the admins want to be bothered with this in the place where they expect info about the Thing.

That’s exactly why I suggested adding something to MUD.

For now, as Eliot said, an SPDX-Identifier is the easiest way to reference a license.  Choose between heavily used and sufficiently permissive licenses, e.g., 0BSD, MIT, BSD-3-Clause.  Licenses that require the copier to copy the copyright as well are currently a bit icky, as that copyright cannot be reasonably put into the MUD file yet.  0BSD and especially MIT-0 look quite good from this perspective.

https://spdx.org/licenses/

TL;DR:
Just copy the text at https://spdx.org/licenses/MIT-0.html (after filling in the variables) and place it (the whole text) on https://iotanalytics.unsw.edu.au/mudprofiles for now.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 4 Jun 2021 12:10:05 +0200

Great!

The only other thing I could suggest is adding the line:
SPDX-License-Identifier: MIT-0

Between the word “license” and the copyright line.

Grüße, Carsten

> On 4. Jun 2021, at 12:00, Hassan Habibi Gharakheili <[email-masked]> wrote:
> 
> Done.
> Please check: https://iotanalytics.unsw.edu.au/mudprofiles <https://iotanalytics.unsw.edu.au/mudprofiles>
>  
> Regards,
> Hassan
>  
> From: Carsten Bormann <[email-masked] <mailto:[email-masked]>>
> Date: Friday, 4 June 2021 at 7:19 pm
> To: Hassan Habibi Gharakheili <[email-masked] <mailto:[email-masked]>>
> Cc: Eliot Lear <[email-masked] <mailto:[email-masked]>>, [email-masked] <mailto:[email-masked]> <[email-masked] <mailto:[email-masked]>>, Ayyoob Ahamed Hamza <[email-masked] <mailto:[email-masked]>>
> On 2021-06-04, at 10:41, Hassan Habibi Gharakheili <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> > Sure. We are happy to put up a LICENSE file in our repository (https://iotanalytics.unsw.edu.au/mudprofiles <https://iotanalytics.unsw.edu.au/mudprofiles>).  It would be great if you could provide us with a simple template of such license, or we should develop one?
> 
> > ·         systeminfo: "lifxbulb (https://iotanalytics.unsw.edu.au/mud/license.txt <https://iotanalytics.unsw.edu.au/mud/license.txt>)",
> > Your thoughts?
> 
> 3.7.  systeminfo
> 
> https://spdx.org/licenses/ <https://spdx.org/licenses/>
> 
> TL;DR:
> Just copy the text at https://spdx.org/licenses/MIT-0.html <https://spdx.org/licenses/MIT-0.html> (after filling in the variables) and place it (the whole text) on https://iotanalytics.unsw.edu.au/mudprofiles <https://iotanalytics.unsw.edu.au/mudprofiles> for now.
> 
> Grüße, Carsten
> 
> 
> >  
> > Regards,
> > Hassan
> >  
> >  
> > From: Carsten Bormann <[email-masked] <mailto:[email-masked]>>
> > To: Hassan Habibi Gharakheili <[email-masked] <mailto:[email-masked]>>
> > Cc: Eliot Lear <[email-masked] <mailto:[email-masked]>>, [email-masked] <mailto:[email-masked]> <[email-masked] <mailto:[email-masked]>>
> > On 2021-05-22, at 03:00, Hassan Habibi Gharakheili <[email-masked] <mailto:[email-masked]>> wrote:
> > >

---

From: Hassan Habibi Gharakheili <[email-masked]>
Date: Fri, 4 Jun 2021 10:00:02 +0000

Done.
Please check: https://iotanalytics.unsw.edu.au/mudprofiles

Regards,
Hassan

Cc: Eliot Lear <[email-masked]>, [email-masked] <[email-masked]>, Ayyoob Ahamed Hamza <[email-masked]>

3.7.  systeminfo

TL;DR:

Grüße, Carsten

---

From: Hassan Habibi Gharakheili <[email-masked]>
Date: Fri, 4 Jun 2021 22:17:02 +0000

We have now added that suggested line (SPDX-License-Identifier: MIT-0).
Please check: https://iotanalytics.unsw.edu.au/mudprofiles

Regards,
Hassan

Date: Friday, 4 June 2021 at 8:10 pm

Grüße, Carsten

On 4. Jun 2021, at 12:00, Hassan Habibi Gharakheili <[email-masked]<mailto:[email-masked]>> wrote:

Done.

Regards,
Hassan

From: Carsten Bormann <[email-masked]<mailto:[email-masked]>>
Date: Friday, 4 June 2021 at 7:19 pm
To: Hassan Habibi Gharakheili <[email-masked]<mailto:[email-masked]>>
Cc: Eliot Lear <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Ayyoob Ahamed Hamza <[email-masked]<mailto:[email-masked]>>
Subject: Re: [OPSAWG] Source attribution in MUD files (RFC 8520)

3.7.  systeminfo

TL;DR:

Grüße, Carsten

>
> Regards,
> Hassan
>
>
> From: Carsten Bormann <[email-masked]<mailto:[email-masked]>>
> To: Hassan Habibi Gharakheili <[email-masked]<mailto:[email-masked]>>
> Cc: Eliot Lear <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
> On 2021-05-22, at 03:00, Hassan Habibi Gharakheili <[email-masked]<mailto:[email-masked]>> wrote:
> >