Subject: [OPSAWG] Alvaro Retana's Abstain on draft-ietf-opsawg-l3sm-l3nm-11: (with COMMENT)

From: Alvaro Retana via Datatracker <[email-masked]>
Date: Wed, 22 Sep 2021 08:54:06 -0700

Alvaro Retana has entered the following ballot position for
draft-ietf-opsawg-l3sm-l3nm-11: Abstain

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/blog/handling-iesg-ballot-positions/
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-opsawg-l3sm-l3nm/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I understand that L3NM is not a device model and that, as such, it is not
intended to include every possible parameter.

However, not leveraging existing work has resulted in inconsistencies: from
using different names to changing implementation expectations.  I believe that
this result impacts the implementation-specific work needed to derive
device-specific actions (using existing models) and potentially reduces the
value of using this network model.

Many WGs in the routing area work on related technology, including bess, idr,
lsr, pim, bfd, rtgwg, and teas. However, I found no evidence in the archives
that any of these WGs were consulted or asked to review this work.

Both points (lack of reuse and lack of review) have been mentioned in the
mailing list, so I assume they have been considered.  This fact and the
existence of multiple implementations lead me to ABSTAIN.

---

From: <[email-masked]>
Date: Wed, 22 Sep 2021 16:12:21 +0000

Hi Alvaro, 

One comment about the interoperability point: many implementers (Nokia, Huawei, Juniper, Cisco, Infinera, Ribbon, ..) were involved in this work and have reported their implementations. No issues were reported by them. 

Given the complex nature of the functionalities touched in the L3NM, there might be some name mismatches vs those present in the device model. We have indicated that we will fix these to ease the mapping with the device modules. If you have identified some not already discussed in the list, please share them and will take them into account. 

We will do check on our side to find mismatches that we missed. 

Thank you. 

Cheers,
Med

> -----Message d'origine-----
> De : Alvaro Retana via Datatracker [mailto:[email-masked]]
> Envoyé : mercredi 22 septembre 2021 17:54
> À : The IESG <[email-masked]>
> Cc : [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Objet : Alvaro Retana's Abstain on draft-ietf-opsawg-l3sm-l3nm-11: (with
> COMMENT)
> 
> I understand that L3NM is not a device model and that, as such, it is
> not intended to include every possible parameter.
> 
> However, not leveraging existing work has resulted in inconsistencies:
> from using different names to changing implementation expectations.  I
> believe that this result impacts the implementation-specific work needed
> to derive device-specific actions (using existing models) and
> potentially reduces the value of using this network model.
> 
> Many WGs in the routing area work on related technology, including bess,
> idr, lsr, pim, bfd, rtgwg, and teas. However, I found no evidence in the
> archives that any of these WGs were consulted or asked to review this
> work.
> 
> Both points (lack of reuse and lack of review) have been mentioned in
> the mailing list, so I assume they have been considered.  This fact and
> the existence of multiple implementations lead me to ABSTAIN.
> 
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.