Subject: [OPSAWG] Zaheduzzaman Sarker's Discuss on draft-ietf-opsawg-vpn-common-10: (with DISCUSS and COMMENT)

From: Zaheduzzaman Sarker via Datatracker <[email-masked]>
Date: Tue, 21 Sep 2021 08:21:43 -0700

Zaheduzzaman Sarker has entered the following ballot position for
draft-ietf-opsawg-vpn-common-10: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/blog/handling-iesg-ballot-positions/
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-opsawg-vpn-common/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

I would like to discuss the extensibility of the model as described in section
3 regarding 'qos-classification-policy' when UDP is used as substrate. See more
in my comments bellow.

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks to the authors for working on this specifications and addressing TSVART
review comments. Thanks Wesley Eddy for your TSVART reviews.

Comments -

* In this specification, UDP match criteria is described and claimed that the
model can be augmented to include more L4 transport protocols. QUIC (RFC9000)
is a new L4 transport protocol and uses UDP as substrate. For such L4 transport
protocols, it might be ambiguous to apply qos classification policy based on
what is defined here. In case of QUIC, it needs to identify from other UDP
traffic that is traversing the network. Read more on QUIC traffic
identification here (
https://quicwg.org/ops-drafts/draft-ietf-quic-manageability.html#name-identifying-quic-traffic).

I think this specification should consider such potential substrate usage of L4
protocols (specially UDP) and hint on the potential augmentations (there might
be several ways to do that) or scope it down to not support such cases.

* May be the commented text in the section 4 for protocol identifiers should be
updated to reflect what is describes in the section 3 for "underlay-transport".
Section 3 talks about underlay transports and how they are set.

---

From: <[email-masked]>
Date: Wed, 22 Sep 2021 06:08:50 +0000

Hi Zahed, 

Thank you for the review. 

Please see inline. 

Cheers,
Med

> -----Message d'origine-----
> De : Zaheduzzaman Sarker via Datatracker [mailto:[email-masked]]
> Envoyé : mardi 21 septembre 2021 17:22
> À : The IESG <[email-masked]>
> Cc : [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Objet : Zaheduzzaman Sarker's Discuss on draft-ietf-opsawg-vpn-common-
> 10: (with DISCUSS and COMMENT)
> 
> 3 regarding 'qos-classification-policy' when UDP is used as substrate.
> See more in my comments bellow.
> 

[[Med]] Good point. I added this NEW text:

         Some transport protocols use existing protocols (e.g., TCP or
         UDP) as substrate.  The match criteria for such protocols may
         rely upon the 'protocol' under 'l3', TCP/UDP match criteria
         shown in Figure 4, part of the TCP/UDP payload, or a
         combination thereof.  This version of the module does not
         support such advanced match criteria.  Future revisions of the
         module may consider adding match criteria based on the
         transport protocol payload (e.g., by means of a bitmask match).

Do we need to say more? Thanks.

> Thanks to the authors for working on this specifications and addressing
> TSVART review comments. Thanks Wesley Eddy for your TSVART reviews.
> 
> Comments -
> 
> * In this specification, UDP match criteria is described and claimed
> that the model can be augmented to include more L4 transport protocols.
> QUIC (RFC9000) is a new L4 transport protocol and uses UDP as substrate.
> For such L4 transport protocols, it might be ambiguous to apply qos
> classification policy based on what is defined here. In case of QUIC, it
> needs to identify from other UDP traffic that is traversing the network.
> Read more on QUIC traffic identification here ( https://quicwg.org/ops-
> drafts/draft-ietf-quic-manageability.html#name-identifying-quic-
> traffic).
> 
> I think this specification should consider such potential substrate
> usage of L4 protocols (specially UDP) and hint on the potential
> augmentations (there might be several ways to do that) or scope it down
> to not support such cases.
> 

[[Med]] I guess this is covered by the NEW text above.

> * May be the commented text in the section 4 for protocol identifiers
> should be updated to reflect what is describes in the section 3 for
> "underlay-transport".

[Med]] Good catch. Fixed. Please check https://github.com/IETF-OPSAWG-WG/lxnm/commit/b071ca3b8a9dec654b537ecf9c0116d2adf02aca 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Thu, 23 Sep 2021 13:09:51 +0000

Hi Zahed, 

FWIW, a new version that resolves your DISCUSS is available online: https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-vpn-common-11. 

Cheers, 
Med

> De : OPSAWG [mailto:[email-masked]] De la part de
> [email-masked]
> Envoyé : mercredi 22 septembre 2021 08:09
> À : Zaheduzzaman Sarker <[email-masked]>; The IESG
> <[email-masked]>
> Cc : [email-masked]; [email-masked]; opsawg-
> [email-masked]
> Objet : Re: [OPSAWG] Zaheduzzaman Sarker's Discuss on draft-ietf-opsawg-
> vpn-common-10: (with DISCUSS and COMMENT)
> 
> Hi Zahed,
> 
> > Envoyé : mardi 21 septembre 2021 17:22 À : The IESG <[email-masked]>
> Cc
> > : [email-masked]; [email-masked];
> > [email-masked]; [email-masked]; [email-masked] Objet :
> > Zaheduzzaman Sarker's Discuss on draft-ietf-opsawg-vpn-common-
> > email addresses included in the To and CC lines. (Feel free to cut
> > this introductory paragraph, however.)
> >
> >
> > Thanks to the authors for working on this specifications and
> > addressing TSVART review comments. Thanks Wesley Eddy for your TSVART
> reviews.
> >
> > Comments -
> >
> > classification policy based on what is defined here. In case of QUIC,
> > it needs to identify from other UDP traffic that is traversing the
> network.
> > augmentations (there might be several ways to do that) or scope it
> > down to not support such cases.
> >
> 
> [Med]] Good catch. Fixed. Please check https://github.com/IETF-OPSAWG-
> WG/lxnm/commit/b071ca3b8a9dec654b537ecf9c0116d2adf02aca
> 
> 
> ________________________________________________________________________
> _________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
> exploites ou copies sans autorisation. Si vous avez recu ce message par
> erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les
> pieces jointes. Les messages electroniques etant susceptibles
> d'alteration, Orange decline toute responsabilite si ce message a ete
> altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged
> information that may be protected by law; they should not be
> distributed, used or copied without authorisation.
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Thu, 23 Sep 2021 14:19:14 +0000

Thanks Med for addressing the discuss points. I have now balloted NO OBJECTION.

BR
Zahed

On 2021-09-23, 15:10, "[email-masked]" <[email-masked]> wrote:

    Hi Zahed, 

    Cheers, 
    Med

    > > Read more on QUIC traffic identification here (
    > > https://protect2.fireeye.com/v1/url?k=f8f8a948-a763904d-f8f8e9d3-86959e472243-f06271c8273d5cdf&q=1&e=9ef66833-f37f-4252-baf9-2fa674946a2d&u=https%3A%2F%2Fquicwg.org%2Fops-
    > [Med]] Good catch. Fixed. Please check https://protect2.fireeye.com/v1/url?k=117d6386-4ee65a83-117d231d-86959e472243-178a805f659f3123&q=1&e=9ef66833-f37f-4252-baf9-2fa674946a2d&u=https%3A%2F%2Fgithub.com%2FIETF-OPSAWG-