Subject: Re: [OPSAWG] Last Call: <draft-ietf-opsawg-l3sm-l3nm-10.txt> (A Layer 3 VPN Network YANG Model) to Proposed Standard

From: <[email-masked]>
Date: Tue, 7 Sep 2021 12:34:38 +0000

Hi Julian, 

Thanks for the comments. 

Please see inline. 

Cheers,
Med

> -----Message d'origine-----
> De : last-call [mailto:[email-masked]] De la part de
> Julian Lucek
> Envoyé : vendredi 6 août 2021 16:06
> À : [email-masked]; [email-masked]
> Objet : [Last-Call] [OPSAWG] Last Call: <draft-ietf-opsawg-l3sm-
> l3nm-10.txt> (A Layer 3 VPN Network YANG Model) to Proposed Standard
> 
> I have the following comments:
> 
> 1/ In the BFD section, the ability to invoke a profile should be
> moved up a level, i.e. provide a choice between (i) specifying
> values for the parameters listed and (ii) invoking a profile
> 
>    |  +--rw bfd {vpn-common:bfd}?
>    |     +--rw desired-min-tx-interval?   uint32
>    |     +--rw required-min-rx-interval?   uint32
>    |     +--rw detection-multiplier?      uint8
>    |     +--rw (holdtime)?
>    |     |  +--:(fixed)
>    |     |  |  +--rw fixed-value?    uint32
>    |     |  +--:(profile)
>    |     |  |  +--rw profile-name?   leafref
> 

[Med] We initially went with this structure to ease the mapping with the L3SM (8299). The assumption is that the profile can include other parameters. I agree this is not clean and it is better to have the profile specified out of this specific parameter.

Rather than having a choice between a profile and a set of parameters, I suggest to go with the following: 
...
|     +--rw holdtime?                   uint32
|     +--rw profile?                    leafref
...

With that, a provider can call a profile in addition to a set of customized parameters. Of course, only a profile can be called if needed. 

> 2/ vpn-network-access is missing the ability to invoke a lag-
> interface, including listing which are the member-links. (However
> the L2-NM model has this feature, this could be reused in the L3-NM)

[Med] We do actually have a discussion as part of the L2NM whether LAG matters (link members, in particular) should be defined independently of the service (and thus removed from the model or at least moved up in the structure). Will need to think further about this one. 

> 
> 3/ Example A.1 invokes the vpn-instance-profile at the vpn-network-
> access level (as well as the node level). But the vpn-instance-
> profile in the example does not contain any parameters that pertain
> to a vpn-network-access. In any case, it would be good to have a
> revamped example to show how profiles defined or invoked at
> different levels interact with or override each other. For example,
> a situation in which the route-target is the same across all vpn-
> nodes, but each vpn-node has a unique route-distinguisher. Or a
> situation in which maximum-routes (among other parameters) is
> specified in a profile that is defined at the service level. That
> profile is invoked on all of the nodes, but the maximum-routes
> parameters is overridden on some nodes, at the node-level or at the
> vpn-network-access level.

[Med] Sure. Added a simplified example in a new appendix.  

> 
> Finally, many thanks to the authors for this very comprehensive and
> valuable piece of work.
> 

[Med] Thank you for the various reviews and inputs. 

> Julian
> 
> --
> last-call mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/last-call

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Mon, 27 Sep 2021 13:16:34 +0000

Hi Julian, 

Following-up on the LAG point.  

The current model supports managing the LAG outside of the L3NM (as other interface management). In this approach, a pointer to a LAG interface can be provided under interface-id of vpn-network-access. 

However, I understand that you would like one step further and control directly the creation of a LAG interface in the L3NM itself in same way that we control the creation of loopbacks. Would adding these data nodes under connection address your need? 

                       |  +--rw lag-interface
                       |          {vpn-common:lag-interface}?
                       |     +--rw lag-interface-id?   string
                       |     +--rw member-link-list
                       |     |  +--rw member-link* [name]
                       |     |     +--rw name      string

Thank you. 

Cheers,
Med

> [email-masked]
> Envoyé : mardi 7 septembre 2021 14:35
> À : 'Julian Lucek' <jlucek=[email-masked]>; last-
> [email-masked]; [email-masked]
> Objet : Re: [Last-Call] [OPSAWG] Last Call: <draft-ietf-opsawg-l3sm-
> > Julian Lucek Envoyé : vendredi 6 août 2021 16:06 À :
> > [email-masked]; [email-masked] Objet : [Last-Call] [OPSAWG] Last
> > Call: <draft-ietf-opsawg-l3sm- l3nm-10.txt> (A Layer 3 VPN Network
> > YANG Model) to Proposed Standard
> >
...
> > interface, including listing which are the member-links. (However the
> > L2-NM model has this feature, this could be reused in the L3-NM)
> 
> [Med] We do actually have a discussion as part of the L2NM whether LAG
> matters (link members, in particular) should be defined independently of
> the service (and thus removed from the model or at least moved up in the
> structure). Will need to think further about this one.
>

---

From: Julian Lucek <[email-masked]>
Date: Mon, 27 Sep 2021 13:55:12 +0000

Hi Mohamed

Yes, that would be perfect

Cheers

Julian

On 27/09/2021, 14:16, "[email-masked]" <[email-masked]> wrote:

    [External Email. Be cautious of content]

    Hi Julian,

                           |  +--rw lag-interface

    Thank you.

    Cheers,
    Med

    ...

Juniper Business Use Only

---

From: <[email-masked]>
Date: Mon, 27 Sep 2021 15:14:14 +0000

Re-,

Great. Thanks. 

The change is now implemented in the draft as you can see in this diff: 
https://www.ietf.org/rfcdiff?url1=draft-ietf-opsawg-l3sm-l3nm-12&url2=draft-ietf-opsawg-l3sm-l3nm-13

Cheers,
Med

> De : Julian Lucek [mailto:[email-masked]]
> Envoyé : lundi 27 septembre 2021 15:55
> À : BOUCADAIR Mohamed INNOV/NET <[email-masked]>;
> [email-masked]
> Objet : Re: [OPSAWG] Last Call: <draft-ietf-opsawg-l3sm-l3nm-10.txt> (A
> Layer 3 VPN Network YANG Model) to Proposed Standard
> 
> Hi Mohamed
> 
>     The current model supports managing the LAG outside of the L3NM (as
> other interface management). In this approach, a pointer to a LAG
> interface can be provided under interface-id of vpn-network-access.
> 
>     However, I understand that you would like one step further and
> control directly the creation of a LAG interface in the L3NM itself in
> same way that we control the creation of loopbacks. Would adding these
> data nodes under connection address your need?
> 
>                            |  +--rw lag-interface
> ________________________________________________________________________
> _________________________________________________
> 
>     Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
>     pas etre diffuses, exploites ou copies sans autorisation. Si vous
> avez recu ce message par erreur, veuillez le signaler
>     a l'expediteur et le detruire ainsi que les pieces jointes. Les
> messages electroniques etant susceptibles d'alteration,
>     This message and its attachments may contain confidential or
> privileged information that may be protected by law;
>     If you have received this email in error, please notify the sender
> and delete this message and its attachments.
>     As emails may be altered, Orange is not liable for messages that
> have been modified, changed or falsified.
>     Thank you.
> 
> 
>