Subject: [OPSAWG] WG LC: L2NM document: draft-ietf-opsawg-l2nm

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Thu, 16 Sep 2021 15:59:01 +0000

Hello, WG.  We would like to kick off a WG LC for the
draft-ietf-opsawg-l2nm draft.  As you review it, I would encourage
looking back at draft-ietf-opsawg-vpn-common to make sure everything
lines up well.  We'd like to give two weeks for review, with LC closing
on October 1.

@Adrian Farrel you were gracious enough to act as shepherd for the L3NM
and vpn-common drafts.  Would you be willing to shepherd this one as well?

https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-l2nm

Thanks.

Joe

---

From: tom petch <[email-masked]>
Date: Fri, 17 Sep 2021 08:34:11 +0000

From: OPSAWG <[email-masked]> on behalf of Joe Clarke (jclarke) <jclarke=[email-masked]>
Sent: 16 September 2021 16:59

<tp>

By which time vpn-common will be well past the IESG Telechat  on 23 September and it will be too late for serious comment:-(

Tom Petch

Thanks.

Joe

_______________________________________________
OPSAWG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/opsawg

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Fri, 17 Sep 2021 17:17:29 +0000

> By which time vpn-common will be well past the IESG Telechat  on 23 September and it will be too late for serious comment:-(

I had thought Rob was holding these to send them together for this
reason.  I've been out, though.  Rob, did that change?

Joe

---

From: tom petch <[email-masked]>
Date: Sat, 18 Sep 2021 11:14:49 +0000

From: Joe Clarke (jclarke) <[email-masked]>
Sent: 17 September 2021 18:17

<tp>
My recollection was that 'common' was held for l3nm to progress but not that it would be held for l2nm.  As l2nm seems to be progressing, then it would seem prudent to me to hold 'common'.  I take the information about the IESG for 'common', September 23,  from the datatracker.

Tom Petch 
Joe

---

From: <[email-masked]>
Date: Tue, 28 Sep 2021 09:04:12 +0000

Hi all, 

We received a comment from Moti (cced) asking to extend the ES structure to allow listing its members. This allows, for example, retrieving the members independently of an L2NM service.

The proposed change would be as follows: 

OLD:
        |  +--rw ethernet-segment* [name]
        |     +--rw name                                 string
        |     +--rw esi-type?                            identityref
        |     +--rw (esi-choice)?
        |     |  .
        |     +--rw esi-redundancy-mode?                 identityref
        |     +--rw df-election
        |     |  .
        |     +--rw split-horizon-filtering?             boolean
        |     +--rw pbb
        |     |   +--rw backbone-src-mac?   yang:mac-address

NEW:
        |  +--rw ethernet-segment* [name]
        |     +--rw name                                 string
        |     +--rw esi-type?                            identityref
        |     +--rw (esi-choice)?
        |     |  .
        |     +--rw esi-redundancy-mode?                 identityref
        |     +--rw df-election
        |     |  .
        |     +--rw split-horizon-filtering?             boolean
        |     +--rw pbb
        |     |   +--rw backbone-src-mac?   yang:mac-address
  ****  |     +--rw member* [node-id, interface-id] 
  ****  |        +--rw node-id            string                        
  ****  |        +--rw interface-id       string                  

Are there any objections to this proposed change? 

Cheers,
Med

> -----Message d'origine-----
> De : OPSAWG <[email-masked]> De la part de Joe Clarke (jclarke)
> Envoyé : jeudi 16 septembre 2021 17:59
> À : [email-masked]
> Objet : [OPSAWG] WG LC: L2NM document: draft-ietf-opsawg-l2nm
> 
> Hello, WG.  We would like to kick off a WG LC for the draft-ietf-opsawg-
> l2nm draft.  As you review it, I would encourage looking back at draft-
> ietf-opsawg-vpn-common to make sure everything lines up well.  We'd like
> to give two weeks for review, with LC closing on October 1.
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Thu, 30 Sep 2021 08:31:00 +0000

Hi all, 

As part of WGLC, we also reflected some of the comments raised during the IESG review of L3NM/common in the L3NM to save us some cycles. This is more about clarification, fixing nits, adding sub-section for better readability, etc. The changes can be tracked at: https://github.com/IETF-OPSAWG-WG/lxnm/tree/master/I-D-L2NM, fwiw. 

Comments are still more than welcome. 

Cheers,
Med