Subject: [OPSAWG] Zaheduzzaman Sarker's Discuss on draft-ietf-opsawg-l3sm-l3nm-11: (with DISCUSS and COMMENT)

From: Zaheduzzaman Sarker via Datatracker <[email-masked]>
Date: Wed, 22 Sep 2021 01:16:15 -0700

Zaheduzzaman Sarker has entered the following ballot position for
draft-ietf-opsawg-l3sm-l3nm-11: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/blog/handling-iesg-ballot-positions/
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-opsawg-l3sm-l3nm/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

This specification refers to ietf-opsawg-vpn-common for qos related matching,
hence I am raising similar discussion as I had for ietf-opsawg-vpn-common (see
here https://datatracker.ietf.org/doc/draft-ietf-opsawg-vpn-common/).

This specification specifies qos classification based on L4 criteria and
describes the procedure for TCP and UDP. It is possible that new L4 protocols
(for example QUIC) use UDP as substrate hence can create ambiguity based of the
procedure described in the specification.

This specification should consider such potential substrate usage of L4
protocols (specially UDP) and hint on the potential augmentations (there might
be several ways to do that) or scope it down to not support such cases.

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks to the authors for their efforts in the specification.

Additional comment(s)-

* I think if would be good if this specification also discusses the implication
of wrong classification (e.g. for qos) based on the model specified here (no
particular suggestion from me where but may be in security considerations).

---

From: <[email-masked]>
Date: Wed, 22 Sep 2021 10:05:07 +0000

Re-, 

Please see inline. 

Cheers,
Med

> -----Message d'origine-----
> De : Zaheduzzaman Sarker via Datatracker [mailto:[email-masked]]
> Envoyé : mercredi 22 septembre 2021 10:16
> À : The IESG <[email-masked]>
> Cc : [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Objet : Zaheduzzaman Sarker's Discuss on draft-ietf-opsawg-l3sm-l3nm-11:
> (with DISCUSS and COMMENT)
> 
> This specification refers to ietf-opsawg-vpn-common for qos related
> matching, hence I am raising similar discussion as I had for ietf-
> opsawg-vpn-common (see here https://datatracker.ietf.org/doc/draft-ietf-
> opsawg-vpn-common/).
> 
> describes the procedure for TCP and UDP. It is possible that new L4
> protocols (for example QUIC) use UDP as substrate hence can create
> ambiguity based of the procedure described in the specification.
> 
> protocols (specially UDP) and hint on the potential augmentations (there
> might be several ways to do that) or scope it down to not support such
> cases.

[[Med]] Added this NEW text to echo the proposal in the common module: 

         As discussed in [I-D.ietf-opsawg-vpn-common], some transport
         protocols use existing protocols (e.g., TCP or UDP) as
         substrate.  The match criteria for such protocols may rely upon
         the 'protocol' under 'l3', TCP/UDP match criteria shown in
         Figure 26, part of the TCP/UDP payload, or a combination
         thereof.  This version of the module does not support such
         advanced match criteria.  Future revisions of the VPN common
         module or augmentations to the L3NM may consider adding match
         criteria based on the transport protocol payload (e.g., by
         means of a bitmask match).

> * I think if would be good if this specification also discusses the
> implication of wrong classification (e.g. for qos) based on the model
> specified here (no particular suggestion from me where but may be in
> security considerations).
> 

[[Med]] I think this is already covered by this part in the draft: 

      In addition,
      an attacker may modify the attributes of a running service (e.g.,
      QoS, bandwidth, routing protocols), leading to malfunctioning of
      the service and therefore to SLA violations.

Please let me know if there is more to say here. Thanks. 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Mon, 27 Sep 2021 09:20:03 +0000

Hi Zahed, 

The proposed changes to address your DISCUSS are now implemented in a new revision:

URL:            https://www.ietf.org/archive/id/draft-ietf-opsawg-l3sm-l3nm-12.txt 
Status:         https://datatracker.ietf.org/doc/draft-ietf-opsawg-l3sm-l3nm/ 
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-l3sm-l3nm 
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-l3sm-l3nm-12

Please me know if you still have any comment. Thanks. 

Cheers,
Med

> De : [email-masked] [mailto:[email-masked]]
> Envoyé : mercredi 22 septembre 2021 12:05
> À : Zaheduzzaman Sarker <[email-masked]>; The IESG
> <[email-masked]>
> [email-masked]; [email-masked]
> Objet : RE: Zaheduzzaman Sarker's Discuss on draft-ietf-opsawg-l3sm-
> l3nm-11: (with DISCUSS and COMMENT)
> 
> Re-,
> 
> Please see inline.
> 
> Cheers,
> Med
> 
> > Envoyé : mercredi 22 septembre 2021 10:16 À : The IESG <[email-masked]>
> > [email-masked]; [email-masked]; [email-masked] Objet :
> > Zaheduzzaman Sarker's Discuss on draft-ietf-opsawg-l3sm-l3nm-11:
> > email addresses included in the To and CC lines. (Feel free to cut
> > this introductory paragraph, however.)
> >
> >
> > opsawg-vpn-common (see here
> > https://datatracker.ietf.org/doc/draft-ietf-
> > opsawg-vpn-common/).
> >
> > This specification specifies qos classification based on L4 criteria
> > and describes the procedure for TCP and UDP. It is possible that new
> > L4 protocols (for example QUIC) use UDP as substrate hence can create
> > This specification should consider such potential substrate usage of
> > L4 protocols (specially UDP) and hint on the potential augmentations
> > (there might be several ways to do that) or scope it down to not
> > support such cases.
> 
> ________________________________________________________________________
> _________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
> exploites ou copies sans autorisation. Si vous avez recu ce message par
> erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les
> pieces jointes. Les messages electroniques etant susceptibles
> d'alteration, Orange decline toute responsabilite si ce message a ete
> altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged
> information that may be protected by law; they should not be
> distributed, used or copied without authorisation.

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Mon, 27 Sep 2021 09:26:50 +0000

Hi Med, 

This looks good to me.

I think I forgot to reply to your response to one of my earlier comments. Copying that here for convenience -

    > Please let me know if there is more to say here. Thanks.

This might be fine, however, I was talking about the case where the configuration is correct but due to ambiguity the classification is wrong. The end result might be same i.e. SLA violation, but reason could be different.

BR
Zahed

On 2021-09-27, 11:20, "[email-masked]" <[email-masked]> wrote:

    Hi Zahed, 

    Cheers,
    Med

---

From: <[email-masked]>
Date: Mon, 27 Sep 2021 11:23:25 +0000

Re-,

Great, thanks. 

For this one:

> This might be fine, however, I was talking about the case where the
> configuration is correct but due to ambiguity the classification is
> wrong. The end result might be same i.e. SLA violation, but reason could
> be different.

I agree that the reason is different, but what is key IMO to record is the implication: SLA violation. That's why I do still think that the existing text is sufficient. 

Like any other read-write data nodes, misconfiguration (including ambiguous classification) may happen, but we don't need to say that explicitly for every parameter.

Thank you. 

Cheers,
Med

> De : Zaheduzzaman Sarker [mailto:[email-masked]]
> Envoyé : lundi 27 septembre 2021 11:27
> À : BOUCADAIR Mohamed INNOV/NET <[email-masked]>
> [email-masked]; [email-masked]; The IESG <[email-masked]>
> Objet : Re: Zaheduzzaman Sarker's Discuss on draft-ietf-opsawg-l3sm-
> I think I forgot to reply to your response to one of my earlier
> comments. Copying that here for convenience -
> 
>     > > Additional comment(s)-
>     > >
> This might be fine, however, I was talking about the case where the
> configuration is correct but due to ambiguity the classification is
> wrong. The end result might be same i.e. SLA violation, but reason could
> be different.
> 
> BR
> Zahed
> 
>     > If you have received this email in error, please notify the sender
> and
>     > delete this message and its attachments.
>     > As emails may be altered, Orange is not liable for messages that
> have
>     > been modified, changed or falsified.
>     > Thank you.
> 
> 
> 
> confidentielles ou privilegiees et ne doivent donc
>     pas etre diffuses, exploites ou copies sans autorisation. Si vous
> avez recu ce message par erreur, veuillez le signaler
>     a l'expediteur et le detruire ainsi que les pieces jointes. Les
> messages electroniques etant susceptibles d'alteration,
>     This message and its attachments may contain confidential or
> privileged information that may be protected by law;
>     If you have received this email in error, please notify the sender
> and delete this message and its attachments.
>     As emails may be altered, Orange is not liable for messages that
> have been modified, changed or falsified.
>     Thank you.
>

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Mon, 27 Sep 2021 11:51:34 +0000

I get you point, Med. 

Thanks for addressing my comments,  I will clear my discuss.

BR
Zahed

On 2021-09-27, 13:23, "[email-masked]" <[email-masked]> wrote:

    Re-,

    Great, thanks. 

    Thank you. 

    Cheers,
    Med

    > privileged