Subject: Re: [OPSAWG] New Version Notification for draft-palmero-opsawg-dmlmo-00.txt

From: Shwetha Bhandari <[email-masked]>
Date: Wed, 22 Sep 2021 13:12:32 +0530

Hi Marisol,

I have read the draft draft-palmero-opsawg-dmlmo-00 and have the following
questions/suggestions on the scope and use cases:

1. Does the scope include lifecycle management and operations for an
application that can be managed by the application vendor i.e. Software as
a Service(SaaS) application? In other words can the asset referred to in
the document be a cloud hosted software asset? If yes, that's great! I
think there is no standard to collect metrics that will help in asset
management and billing in the SaaS space and this work would be interesting
to SaaS applications.

2. Related to this an interesting use case that would be added to the
document is to support Billing based on the usage and consumption of the
SaaS application. To support this use-case for software/SaaS application
assets can the metric collection be made extensible to cover application
specific metrics? for e.g. A data analytics application may be interested
in metrics related to amount of data analyzed, number of requests triggered
for analysis, concurrent user sessions that trigger the request etc. These
metrics could be used for billing the consumers of the SaaS application.

3. Would you be interested in contributions if the above use cases and
asset type can be supported to extend the information model?

Thanks,
Shwetha

On 8/24/2021 11:29 AM, Marisol Palmero Amador (mpalmero) wrote:
> Dear OPSA WG,
>
> We've just posted a new draft that introduces a data model for lifecycle management and operations:
> https://www.ietf.org/archive/id/draft-palmero-opsawg-dmlmo-00.txt
>
>
> We don't yet have data models that deal with data concerning adoption and usability, licensing, supported features and capabilities, enabled features and capabilities, etc. of a hardware or software, physical or virtual component.
> We hope that the new draft can help fill this gap.
>
> We greatly appreciate your thoughts and comments.
>
> Many thanks,
> Marisol
>
>
> Marisol Palmero
> CCIE #5122 | Technical Leader EMEAR | Cisco Customer Experience CTO | P: +34.91.201.2643 | M: +34.629.634.595
>
>
>
> On 23/08/2021, 22:04, "[email-masked]" <&quot;[email-masked]&quot;> <[email-masked]> <&lt;[email-masked]&gt;> wrote:
>
>
>      A new version of I-D, draft-palmero-opsawg-dmlmo-00.txt
>      has been successfully submitted by Marisol Palmero and posted to the
>      IETF repository.
>
>      Name:		draft-palmero-opsawg-dmlmo
>      Revision:	00
>      Title:		Data Model for Lifecycle Management and Operations
>      Document date:	2021-08-23
>      Group:		Individual Submission
>      Pages:		48
>      URL:            https://www.ietf.org/archive/id/draft-palmero-opsawg-dmlmo-00.txt
>      Status:         https://datatracker.ietf.org/doc/draft-palmero-opsawg-dmlmo/
>      Htmlized:       https://datatracker.ietf.org/doc/html/draft-palmero-opsawg-dmlmo
>
>
>      Abstract:
>         This document motivates and specifies a data model for lifecycle
>         management and operations.  It describes the motivation and
>         requirements to collect asset-centric metrics including but not
>         limited to asset adoption and usability, licensing, supported
>         features and capabilities, enabled features and capabilities, etc.;
>         with the primary objective to measure and improve the overall user
>         experience along the lifecycle journey, from technical requirements
>         and technology selection through advocacy and renewal, including the
>         end of life of an asset.
>
>
>
>
>      The IETF Secretariat
>
>
>
>
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: "Marisol Palmero Amador (mpalmero)" <[email-masked]>
Date: Mon, 27 Sep 2021 16:35:38 +0000

Many thanks Shwetha for getting back on the draft.

To answer your points:

  1.  Yes! Software application, hosted in cloud, also responses to a form of Asset as part of the draft.
  2.  It will be good  to hear more on your proposal, lifecycle in SaaS is part of our scope.
  3.  Yes, we are open to discussions around extending such use case for  future revisions.

If you are fine, Ill set up a call to follow up on your email below

Many thanks,
Marisol

Marisol Palmero

From: Shwetha Bhandari <[email-masked]>
Date: Wednesday, 22 September 2021 at 09:42
To: "[email-masked]" <[email-masked]>, Marisol Palmero <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [OPSAWG] New Version Notification for draft-palmero-opsawg-dmlmo-00.txt

Hi Marisol,

I have read the draft draft-palmero-opsawg-dmlmo-00 and have the following questions/suggestions on the scope and use cases:

1. Does the scope include lifecycle management and operations for an application that can be managed by the application vendor i.e. Software as a Service(SaaS) application? In other words can the asset referred to in the document be a cloud hosted software asset? If yes, that's great! I think there is no standard to collect metrics that will help in asset management and billing in the SaaS space and this work would be interesting to SaaS applications.

2. Related to this an interesting use case that would be added to the document is to support Billing based on the usage and consumption of the SaaS application. To support this use-case for software/SaaS application assets can the metric collection be made extensible to cover application specific metrics? for e.g. A data analytics application may be interested in metrics related to amount of data analyzed, number of requests triggered for analysis, concurrent user sessions that trigger the request etc. These metrics could be used for billing the consumers of the SaaS application.

3. Would you be interested in contributions if the above use cases and asset type can be supported to extend the information model?

Thanks,
Shwetha

> On 23/08/2021, 22:04, "[email-masked]"<mailto:&quot;[email-masked]&quot;> <[email-masked]><mailto:&lt;[email-masked]&gt;> wrote:

> [email-masked]<mailto:[email-masked]>