Subject: Re: [OPSAWG] 🔔 WG Adoption Call for draft-gharris-opsawg-pcap-02

From: Qin Wu <[email-masked]>
Date: Tue, 26 Oct 2021 09:12:28 +0000

-----邮件原件-----
发件人: Carsten Bormann [mailto:[email-masked]] 
发送时间: 2021年10月26日 15:18
收件人: Guy Harris <[email-masked]>
抄送: Qin Wu <[email-masked]>; [email-masked]
主题: Re: [OPSAWG] 🔔 WG Adoption Call for draft-gharris-opsawg-pcap-02

On 26. Oct 2021, at 09:00, Guy Harris <[email-masked]> wrote:
> 
> I would vote for "both should point to a common location" so that neither the pcap nor the pcapng spec says "there is *the* list of link-layer types" - it points to a registry, and as more types are added to the registry, more specs can be published define them.

Indeed, and running such a registry is exactly what IANA is good at.

One way to do this would be to jump-start the process by a short document establishing this registry, with a defined registration policy.
(We’d probably need to be able to point out candidates for the designated experts that will implement this policy to make this approach palatable to IESG.)

[Qin] Good proposal, agree with this.

---

From: Michael Richardson <[email-masked]>
Date: Tue, 26 Oct 2021 09:58:57 -0400

<#secure method=pgpmime mode=sign>

Qin Wu <[email-masked]> wrote:
    cabo> One way to do this would be to jump-start the process by a short
    cabo> document establishing this registry, with a defined registration
    cabo> policy.

    > [Qin] Good proposal, agree with this.

So the proposal, in order to avoid having to adopt pcap as an Information
document, is to adopt a third document, which is a subset of the current pcap
document.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: "RFC ISE (Adrian Farrel)" <[email-masked]>
Date: Tue, 26 Oct 2021 14:19:34 -0000

PMFJI (and also for top-posting on a random email in the thread)

If your intention is to have an IANA registry, then please note that the
Independent Stream has a strong aversion to publishing documents that
create registries (see RFC 8726).

I leave it to the WG to decide whether a registry is needed if the sole
purpose of the document is to describe an existing implementation (wide or
otherwise).

Cheers,
Adrian (as ISE)

Michael Richardson wrote:
> Michael Richardson <[email-masked]>   . o O ( IPv6 IÃ¸T consulting
> )
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>