Subject: Re: [OPSAWG] WG LC: L2NM document: draft-ietf-opsawg-l2nm

From: <[email-masked]>
Date: Fri, 1 Oct 2021 08:02:43 +0000

Hi Julian, 

Thank you for the comments. 

Please see inline.

Cheers,
Med

> -----Message d'origine-----
> De : OPSAWG <[email-masked]> De la part de Julian Lucek
> Envoyé : jeudi 30 septembre 2021 17:00
> À : [email-masked]
> Objet : Re: [OPSAWG] WG LC: L2NM document: draft-ietf-opsawg-l2nm
> 
> A couple of comments:
> 
> 1/ "evpn-type" seems redundant, as the allowed types are already covered
> by "vpn-type". But if there is a reason to have it, also need "mpls-evpn"
> as an allowed evpn-type.

[Med] Good point. I think we can remove the evpn-type identity ae we have the "when" statement to check that the vpn-type is of form of an *-evpn. Updated the evpn-type to be a leafref. 

> 
> 2/ There is a container called "status" (imported from vpn-common).
> "Status" is a yang keyword, so it causes problems with yang editors and
> yang tools. Would be better to call it something else.

[Med] I'm not aware of any authoritative text that forbids this. Please note that "status" is used in the many YANG module (e.g., RFC8344). 

I know that I have accepted a similar comment for "type" in the past, but I'm hesitating to touch the common module at this stage. Thanks

> 
> The model is very useful, many thanks to the authors.
> 
> Julian
> 
> 
> 
> ------
> Hello, WG.  We would like to kick off a WG LC for the draft-ietf-opsawg-
> l2nm draft.  As you review it, I would encourage looking back at draft-
> ietf-opsawg-vpn-common to make sure everything lines up well.  We'd like
> to give two weeks for review, with LC closing on October 1.
> 
> @Adrian Farrel you were gracious enough to act as shepherd for the L3NM
> and vpn-common drafts.  Would you be willing to shepherd this one as well?
> 
> https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-l2nm
> 
> Thanks.
> 
> Joe
> 
> 
> 
> Juniper Business Use Only
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Mon, 4 Oct 2021 14:45:40 +0000

WG LC has closed on this document.  There have been a few comments by
both opsawg members and others (after the extended sweep of RTG).  The
authors have not yet addressed the comments in a published draft but
have proposed changes.

Adrian Farrel has graciously agreed to act as shepherd of this document.

I will mark the status as done with LC and awaiting write-up and a
revised I-D.  Thanks to the WG for commenting and to the contributors
for acking the IPR poll.  There has been no IPR cited for this work thus
far.

Joe

On 9/16/21 12:00, Joe Clarke (jclarke) wrote:
> Hello, WG.  We would like to kick off a WG LC for the
> draft-ietf-opsawg-l2nm draft.  As you review it, I would encourage
> looking back at draft-ietf-opsawg-vpn-common to make sure everything
> lines up well.  We'd like to give two weeks for review, with LC closing
> on October 1.
>