Subject: [OPSAWG] I-D Action: draft-ietf-opsawg-l2nm-07.txt

From: [email-masked]
Date: Fri, 01 Oct 2021 02:55:02 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Operations and Management Area Working Group WG of the IETF.

        Title           : A Layer 2 VPN Network YANG Model
        Authors         : Samier Barguil
                          Oscar Gonzalez de Dios
                          Mohamed Boucadair
                          Luis Angel Munoz
	Filename        : draft-ietf-opsawg-l2nm-07.txt
	Pages           : 150
	Date            : 2021-10-01

Abstract:
   This document defines an L2VPN Network YANG Model (L2NM) that can be
   used to manage the provisioning of Layer 2 Virtual Private Network
   (VPN) services within a network (e.g., service provider network).
   The L2NM complements the Layer 2 Service Model (L2SM) by providing a
   network-centric view of the service that is internal to a service
   providers.  As such, the L2NM is meant to be used by a network
   controller to derive the configuration information that will be sent
   to relevant network devices.

   Also, the document defines the initial versions of two IANA-
   maintained modules that defines a set of identities of BGP Layer 2
   encapsulation types and pseudowire types.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-opsawg-l2nm/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-l2nm-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-l2nm-07

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Fri, 1 Oct 2021 10:04:47 +0000

Hi all,

This version integrates the WGLC comments we received so far, mainly:
* add ES members as suggested by Moti
* fix the redundant evpn-type as catched by Julian. 

Also, we made other changes to echo the IESG comments received against vpn-common and L3VPN, mainly:
* update the security section to cover profile and ES related considerations. 
* add some subsections + position trees before the description text for better readability

We also fixed some nits, add more references when we thought it was missing, fix LACP container, and some examples.

If you have already started to review -06 but didn't manage to finish it, please just proceed with that version and circulate these comments. You don't to bother yourself to check whether these comments were addressed in -07. We will be doing that check for you.

Cheers,
Med

> -----Message d'origine-----
> De : I-D-Announce <[email-masked]> De la part de internet-
> [email-masked]
> Envoyé : vendredi 1 octobre 2021 11:55
> À : [email-masked]
> Cc : [email-masked]
> Objet : I-D Action: draft-ietf-opsawg-l2nm-07.txt
> 
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Moti Morgenstern <[email-masked]>
Date: Sun, 3 Oct 2021 10:00:31 +0000

Hi all,

Typos I noticed in revision -07:
*       Caption of Figure 34 - correct the word "Auto-Assignement"
*       Last paragraph of 6.6.2.1 - correct the word "Nighbour" to "Neighbor"
*       Chapter 6.7 'global-parameters-profile' - correct "overriden" to "overridden"
*       Just before Figure 21 - correct "take precendence over the one inlcudes"
*       identity lacp-active - Description clause - correct the word "establishement"
*       identity lacp-passive - Description clause - correct the word "endopoint"

Regards,
Moti

-----Original Message-----
From: OPSAWG <[email-masked]> On Behalf Of [email-masked]
Sent: Friday, October 1, 2021 1:05 PM
To: [email-masked]
Cc: [email-masked]
Subject: [EXTERNAL] Re: [OPSAWG] I-D Action: draft-ietf-opsawg-l2nm-07.txt

Hi all,

Cheers,
Med

> De : I-D-Announce <[email-masked]<mailto:[email-masked]>> De la part de
> internet- [email-masked]<mailto:[email-masked]> Envoyé : vendredi 1 octobre 2021 11:55 À :
> [email-masked]<mailto:[email-masked]> Cc : [email-masked]<mailto:[email-masked]> Objet : I-D Action:
> draft-ietf-opsawg-l2nm-07.txt
>
>
> https://clicktime.symantec.com/3QNCe4ZsFfUaLPXkwHepEGp6H2?u=https%3A%2
> F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-opsawg-l2nm%2F
>
> https://clicktime.symantec.com/3XzgY3DqPMHq3sQZCmhcXb46H2?u=https%3A%2
> F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-opsawg-l2nm-07
>
> https://clicktime.symantec.com/3E13kLJUqXiCC9sNGJR7EyW6H2?u=https%3A%2
> F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-opsawg-l2nm-07
>
>
> [email-masked]<mailto:[email-masked]>
> https://clicktime.symantec.com/3Tiwrjbm2k542mZUMeShnqe6H2?u=https%3A%2
> F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fi-d-announce
> Internet-Draft directories:
> https://clicktime.symantec.com/3Qe6h5ttJiRonkefg2XuzWs6H2?u=http%3A%2F
> %2Fwww.ietf.org%2Fshadow.html or

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

_______________________________________________
OPSAWG mailing list
[email-masked]<mailto:[email-masked]>
https://clicktime.symantec.com/3EztnMiGfuSmDpQ385X8dXn6H2?u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fopsawg

Notice: This e-mail together with any attachments may contain information of Ribbon Communications Inc. and its Affiliates that is confidential and/or proprietary for the sole use of the intended recipient. Any review, disclosure, reliance or distribution by others or forwarding without express permission is strictly prohibited. If you are not the intended recipient, please notify the sender immediately and then delete all copies, including any attachments.

Notice: This e-mail together with any attachments may contain information of Ribbon Communications Inc. and its Affiliates that is confidential and/or proprietary for the sole use of the intended recipient. Any review, disclosure, reliance or distribution by others or forwarding without express permission is strictly prohibited. If you are not the intended recipient, please notify the sender immediately and then delete all copies, including any attachments.

---

From: <[email-masked]>
Date: Mon, 4 Oct 2021 05:23:45 +0000

Hi Moti,

Thank you for catching these nits. Fixed at: https://github.com/IETF-OPSAWG-WG/lxnm/commit/7e6a2389a7bd4672a6b70935ea1c38ea8ed75acd

Cheers,
Med

De : Moti Morgenstern <[email-masked]>
Envoyé : dimanche 3 octobre 2021 12:01
À : BOUCADAIR Mohamed INNOV/NET <[email-masked]>; [email-masked]
Cc : [email-masked]
Objet : RE: I-D Action: draft-ietf-opsawg-l2nm-07.txt

Hi all,

Typos I noticed in revision -07:
·         Caption of Figure 34 - correct the word "Auto-Assignement"
·         Last paragraph of 6.6.2.1 - correct the word "Nighbour" to "Neighbor"
·         Chapter 6.7 'global-parameters-profile' - correct "overriden" to "overridden"
·         Just before Figure 21 - correct "take precendence over the one inlcudes"
·         identity lacp-active - Description clause - correct the word "establishement"
·         identity lacp-passive - Description clause - correct the word "endopoint"

Regards,
Moti

-----Original Message-----
From: OPSAWG <[email-masked]<mailto:[email-masked]>> On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Friday, October 1, 2021 1:05 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [EXTERNAL] Re: [OPSAWG] I-D Action: draft-ietf-opsawg-l2nm-07.txt

Hi all,

Cheers,
Med

> https://clicktime.symantec.com/3QNCe4ZsFfUaLPXkwHepEGp6H2?u=https%3A%2<https://clicktime.symantec.com/3QNCe4ZsFfUaLPXkwHepEGp6H2?u=https%3A%252>
> https://clicktime.symantec.com/3XzgY3DqPMHq3sQZCmhcXb46H2?u=https%3A%2<https://clicktime.symantec.com/3XzgY3DqPMHq3sQZCmhcXb46H2?u=https%3A%252>
> https://clicktime.symantec.com/3E13kLJUqXiCC9sNGJR7EyW6H2?u=https%3A%2<https://clicktime.symantec.com/3E13kLJUqXiCC9sNGJR7EyW6H2?u=https%3A%252>
> https://clicktime.symantec.com/3Tiwrjbm2k542mZUMeShnqe6H2?u=https%3A%2<https://clicktime.symantec.com/3Tiwrjbm2k542mZUMeShnqe6H2?u=https%3A%252>