Subject: Re: [OPSAWG] New Version Notification for draft-palmero-opsawg-dmlmo-00.txt

From: Camilo Cardona <[email-masked]>
Date: Wed, 6 Oct 2021 19:08:19 -0500

Hello opsawg,

I gave a read to draft-palmero-opsawg-dmlmo-01, and discussed it with Marisol on a call, but I thought I could share my main remarks here:

1. One of the basic use cases of the draft is to find information about features and licenses (e.g. which feature(s) are enabled by a license, which license(s) I need for a feature, etc). However, I cannot find a way of “linking” licenses to features in the model. The model does link licenses to assets, but I think there is a need for a direct relation between license and features. 

2. In the text, there is a bit of ambiguity of what the yang model covers, and what should be provided by vendors. In the use cases from 4.3 to 4.6, you need the most recent data from vendors to run the analysis that each point describes. Are we going to structure that data too? It seems this is out of the scope of the draft, and that is fine... but I did wonder that when I was reading since I was expecting that data to appear later in the models.

3. As always in drafts with yang models, we are missing some concrete examples.

Besides that, the purpose of the draft is clear to me, and I wish it were this easy to retrieve this data in a standard way. 

Thanks,
Camilo C

> On 6 Oct 2021, at 19:00, Juan Camilo Cardona Restrepo <[email-masked]> wrote:
> 
> Dear OPSA WG,
>  
> We've just posted a new draft that introduces a data model for lifecycle management and operations:
> https://www.ietf.org/archive/id/draft-palmero-opsawg-dmlmo-00.txt <https://www.ietf.org/archive/id/draft-palmero-opsawg-dmlmo-00.txt>
> 
> 
> We don't yet have data models that deal with data concerning adoption and usability, licensing, supported features and capabilities, enabled features and capabilities, etc. of a hardware or software, physical or virtual component. 
> We hope that the new draft can help fill this gap.
>  
> We greatly appreciate your thoughts and comments.
>  
> Many thanks, 
> Marisol
> 
> 
> Marisol Palmero
> CCIE #5122 | Technical Leader EMEAR | Cisco Customer Experience CTO | P: +34.91.201.2643 | M: +34.629.634.595 
>  
>  
> 
> On 23/08/2021, 22:04, "[email-masked]" <mailto:&quot;[email-masked]&quot;> <[email-masked]> <mailto:&lt;[email-masked]&gt;> wrote:
> 
>     
>     A new version of I-D, draft-palmero-opsawg-dmlmo-00.txt
>     has been successfully submitted by Marisol Palmero and posted to the
>     IETF repository.
>     
>     Name:		draft-palmero-opsawg-dmlmo
>     Revision:	00
>     Title:		Data Model for Lifecycle Management and Operations
>     Document date:	2021-08-23
>     Group:		Individual Submission
>     Pages:		48
>     URL:            https://www.ietf.org/archive/id/draft-palmero-opsawg-dmlmo-00.txt <https://www.ietf.org/archive/id/draft-palmero-opsawg-dmlmo-00.txt>
>     Status:         https://datatracker.ietf.org/doc/draft-palmero-opsawg-dmlmo/ <https://datatracker.ietf.org/doc/draft-palmero-opsawg-dmlmo/>
>     Htmlized:       https://datatracker.ietf.org/doc/html/draft-palmero-opsawg-dmlmo <https://datatracker.ietf.org/doc/html/draft-palmero-opsawg-dmlmo>
>     
>     
>     Abstract:
>        This document motivates and specifies a data model for lifecycle
>        management and operations.  It describes the motivation and
>        requirements to collect asset-centric metrics including but not
>        limited to asset adoption and usability, licensing, supported
>        features and capabilities, enabled features and capabilities, etc.;
>        with the primary objective to measure and improve the overall user
>        experience along the lifecycle journey, from technical requirements
>        and technology selection through advocacy and renewal, including the
>        end of life of an asset.
>     
>                                                                                       
>     
>     
>     The IETF Secretariat
>     
>

---

From: "Marisol Palmero Amador (mpalmero)" <[email-masked]>
Date: Fri, 8 Oct 2021 10:38:17 +0000

Many thanks Camilo for your comments,

answering your points.

  1.  You are correct, we will run a new iteration through the young modules and add the direct link between license module and feature, as individual features within assets can be licensed.
  2.  You are also correct here. It is considered that some attributes will need to be feed directly from the vendors, i.e. reading from a catalog. It is mentioned in one of the Use cases:
   The Software Conformance use case uses data that might not be
   provided by the asset itself.  Data needs to be provided and
   maintained also by the asset developers, through e.g., asset catalog
   information.  Similar logic applies to a feature catalog, where the
   asset developer maintains the data and updates it adequately based on
   existing bugs, security advisories, etc.

  1.  Point taken, we are also looking to add more concrete example for next revisions.

Looking forward to your continued collaboration,

Marisol P

From: Camilo Cardona <[email-masked]>
Date: Thursday, 7 October 2021 at 02:08
To: "[email-masked]" <[email-masked]>
Cc: Marisol Palmero <[email-masked]>
Subject: Re: [OPSAWG] New Version Notification for draft-palmero-opsawg-dmlmo-00.txt

Hello opsawg,

Thanks,
Camilo C

On 6 Oct 2021, at 19:00, Juan Camilo Cardona Restrepo <[email-masked]<mailto:[email-masked]>> wrote:

Dear OPSA WG,

https://www.ietf.org/archive/id/draft-palmero-opsawg-dmlmo-00.txt

Many thanks,

Marisol

Marisol Palmero

On 23/08/2021, 22:04, "[email-masked]"<mailto:&quot;[email-masked]&quot;> <[email-masked]><mailto:&lt;[email-masked]&gt;> wrote:

    IETF repository.

    Revision:    00

    Pages:               48

    URL:            https://www.ietf.org/archive/id/draft-palmero-opsawg-dmlmo-00.txt

    Status:         https://datatracker.ietf.org/doc/draft-palmero-opsawg-dmlmo/

    Htmlized:       https://datatracker.ietf.org/doc/html/draft-palmero-opsawg-dmlmo

    Abstract:

       end of life of an asset.

    The IETF Secretariat