Subject: [OPSAWG] I-D Action: draft-ietf-opsawg-l2nm-08.txt

From: [email-masked]
Date: Mon, 11 Oct 2021 07:50:42 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Operations and Management Area Working Group WG of the IETF.

        Title           : A Layer 2 VPN Network YANG Model
        Authors         : Samier Barguil
                          Oscar Gonzalez de Dios
                          Mohamed Boucadair
                          Luis Angel Munoz
	Filename        : draft-ietf-opsawg-l2nm-08.txt
	Pages           : 154
	Date            : 2021-10-11

Abstract:
   This document defines an L2VPN Network YANG Model (L2NM) that can be
   used to manage the provisioning of Layer 2 Virtual Private Network
   (VPN) services within a network (e.g., service provider network).
   The L2NM complements the Layer 2 Service Model (L2SM) by providing a
   network-centric view of the service that is internal to a service
   providers.  The L2NM is particularly meant to be used by a network
   controller to derive the configuration information that will be sent
   to relevant network devices.

   Also, the document defines the initial versions of two IANA-
   maintained modules that defines a set of identities of BGP Layer 2
   encapsulation types and pseudowire types.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-opsawg-l2nm/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-l2nm-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-l2nm-08

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Mon, 11 Oct 2021 15:01:45 +0000

Hi Adrian, all,

This version takes into account the directorate early reviews received so far, mainly:

* move ethernet segment to a separate module + move the ES section upper in the ToC
* update the examples to reflect the updated modules 
* make some edits to better align the introduction with the document structure

Looking forward to receiving the Shepherd review.

Cheers,
Med

> -----Message d'origine-----
> De : OPSAWG <[email-masked]> De la part de internet-
> [email-masked]
> Envoyé : lundi 11 octobre 2021 16:51
> À : [email-masked]
> Cc : [email-masked]
> Objet : [OPSAWG] I-D Action: draft-ietf-opsawg-l2nm-08.txt
> 
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Moti Morgenstern <[email-masked]>
Date: Tue, 12 Oct 2021 05:13:10 +0000

Hi,

With respect to the newly added 'units' clause for parameters in the Service Bandwidth Subtree: 
CIR, EIR and PIR are measured in bits-per-second (bps). However, CBS, EBS and PBS do not express rate (so they are not 'per second'). They define the buffer-size available for temporarily exceeding the corresponding CIR, EIR or PIR. Therefore, the 'units' of CBS, EBS and PBS should be simply 'bytes'. 

Regards,
Moti

-----Original Message-----
From: OPSAWG <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, October 11, 2021 6:02 PM
To: [email-masked]; [email-masked]
Subject: [EXTERNAL] Re: [OPSAWG] I-D Action: draft-ietf-opsawg-l2nm-08.txt

Hi Adrian, all,

Cheers,
Med

> [email-masked] Envoyé : lundi 11 octobre 2021 16:51 À : 
> [email-masked] Cc : [email-masked] Objet : [OPSAWG] I-D 
> Action: draft-ietf-opsawg-l2nm-08.txt
> 
> 
> https://clicktime.symantec.com/3Mpofd8PAC7czZ2FU3arBkj6H2?u=https%3A%2
> F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-opsawg-l2nm%2F
> 
> https://clicktime.symantec.com/3TmZBB9213S1ji8xBwbJtET6H2?u=https%3A%2
> F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-opsawg-l2nm-08
> 
> https://clicktime.symantec.com/3QnPWzaJ3XbHfKRYspKbnzX6H2?u=https%3A%2
> F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-opsawg-l2nm-08
> 
> 
> https://clicktime.symantec.com/38iDJzFUM8R6eNfdGmqVWWf6H2?u=https%3A%2
> F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fopsawg

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

_______________________________________________
OPSAWG mailing list
[email-masked]
https://clicktime.symantec.com/38iDJzFUM8R6eNfdGmqVWWf6H2?u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fopsawg

Notice: This e-mail together with any attachments may contain information of Ribbon Communications Inc. and its Affiliates that is confidential and/or proprietary for the sole use of the intended recipient. Any review, disclosure, reliance or distribution by others or forwarding without express permission is strictly prohibited. If you are not the intended recipient, please notify the sender immediately and then delete all copies, including any attachments.

Notice: This e-mail together with any attachments may contain information of Ribbon Communications Inc. and its Affiliates that is confidential and/or proprietary for the sole use of the intended recipient. Any review, disclosure, reliance or distribution by others or forwarding without express permission is strictly prohibited. If you are not the intended recipient, please notify the sender immediately and then delete all copies, including any attachments.

---

From: <[email-masked]>
Date: Tue, 12 Oct 2021 06:45:28 +0000

Hi Moti, 

You are right. This will be fixed in the next iteration when we will cover the review from Adrian. Thanks.

Cheers,
Med

> De : Moti Morgenstern <[email-masked]>
> Envoyé : mardi 12 octobre 2021 07:13
> À : BOUCADAIR Mohamed INNOV/NET <[email-masked]>;
> [email-masked]
> Objet : RE: [OPSAWG] I-D Action: draft-ietf-opsawg-l2nm-08.txt
> 
> Hi,
> 
> CIR, EIR and PIR are measured in bits-per-second (bps). However, CBS, EBS
> and PBS do not express rate (so they are not 'per second'). They define
> the buffer-size available for temporarily exceeding the corresponding CIR,
> EIR or PIR. Therefore, the 'units' of CBS, EBS and PBS should be simply
> 'bytes'.
> 
> Regards,
> Moti
> 
> __________________________________________________________________________
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
> exploites ou copies sans autorisation. Si vous avez recu ce message par
> erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les
> pieces jointes. Les messages electroniques etant susceptibles
> d'alteration, Orange decline toute responsabilite si ce message a ete
> altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged
> information that may be protected by law; they should not be distributed,
> used or copied without authorisation.
> https://clicktime.symantec.com/38iDJzFUM8R6eNfdGmqVWWf6H2?u=https%3A%2F%2F
> www.ietf.org%2Fmailman%2Flistinfo%2Fopsawg
> 
> Notice: This e-mail together with any attachments may contain information
> of Ribbon Communications Inc. and its Affiliates that is confidential
> and/or proprietary for the sole use of the intended recipient. Any review,
> disclosure, reliance or distribution by others or forwarding without
> express permission is strictly prohibited. If you are not the intended
> recipient, please notify the sender immediately and then delete all
> copies, including any attachments.
> 
> Notice: This e-mail together with any attachments may contain information
> of Ribbon Communications Inc. and its Affiliates that is confidential
> and/or proprietary for the sole use of the intended recipient. Any review,
> disclosure, reliance or distribution by others or forwarding without
> express permission is strictly prohibited. If you are not the intended
> recipient, please notify the sender immediately and then delete all
> copies, including any attachments.