Subject: Re: [OPSAWG] A question on the use of "direction" in draft-ietf-opsawg-yang-vpn-service-pm

From: "Wubo (lana)" <[email-masked]>
Date: Thu, 4 Nov 2021 12:13:58 +0000

Hi Greg,

Thanks for the comments. Please see inline.

Thanks,
Bo

发件人: Greg Mirsky [mailto:[email-masked]]
发送时间: 2021年11月4日 4:03
收件人: opsawg <[email-masked]>; [email-masked]
主题: A question on the use of "direction" in draft-ietf-opsawg-yang-vpn-service-pm

Dear Authors,
thank you for your work on this model. I read the document and have one question and a single suggestion for your consideration:

  *   I find the description of the "direction" somewhat confusing. Can you give an example when the "direction" is set to "two-way". In that case, how that affects the reported performance metrics. I can imagine that in some cases, a performance metric calculated using a round-trip measured value. In that case, it is helpful to indicate the source of the metric as RT/2 vs. one-way.
[Bo] Thanks. This makes sense.  Instead of “direction” definition, I suggest to directly define “ two-way-delay”, so when the “pm-source” uses two-way measurement, it is easier to read.
I may suggest changing default values for percentiles. Based on the feedback we've received, the STAMP YANG model uses p95, p99, and p99.9 as default values for low, middle, and high percentile respectively.
[Bo] Thanks for the suggestion. Looking at STAMP YANG, I can’t find the description on this. Could you elaborate on why these values are defined?
Regards,
Greg

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 5 Nov 2021 13:37:45 -0700

Hi Bo,
thank you for carefully considering my notes. Please find my follow-up
notes in-lined below under the GIM>> tag.

Regards,
Greg

On Thu, Nov 4, 2021 at 5:14 AM Wubo (lana) <[email-masked]> wrote:

> *发件人:* Greg Mirsky [mailto:[email-masked]]
> *发送时间:* 2021年11月4日 4:03
> *收件人:* opsawg <[email-masked]>;
> [email-masked]
> *主题:* A question on the use of "direction" in
> draft-ietf-opsawg-yang-vpn-service-pm
>
>
>
> Dear Authors,
>
> thank you for your work on this model. I read the document and have one
> question and a single suggestion for your consideration:
>
>    - I find the description of the "direction" somewhat confusing. Can
>    you give an example when the "direction" is set to "two-way". In that case,
>    how that affects the reported performance metrics. I can imagine that in
>    some cases, a performance metric calculated using a round-trip measured
>    value. In that case, it is helpful to indicate the source of the metric as
>    RT/2 vs. one-way.
>
> *[Bo] Thanks. This makes sense.  Instead of “direction” definition, I
> suggest to directly define “ two-way-delay”, so when the “pm-source” uses
> two-way measurement, it is easier to read.*
>
GIM>> I am not sure that would be useful. If all reportable performance
metrics are for an ordered pair of measurement points, then, as I see it, a
metric is always unidirectional, i.e., one-way. I agree that it may be
obtained using a one-way or two-way measurement method. What seems
important to indicate, is whether the reported metric is using or based on
a one-way measurement or calculated using a round-trip measurement. I agree
that re-naming the "direction" definition is helpful and I might propose it
changed to "source", which is "one-way" or "round-trip".

> I may suggest changing default values for percentiles. Based on the
> feedback we've received, the STAMP YANG model uses p95, p99, and p99.9 as
> default values for low, middle, and high percentile respectively.
>
> *[Bo] Thanks for the suggestion. Looking at STAMP YANG, I can’t find the
> description on this. Could you elaborate on why these values are defined?*
>
GIM>> As I recall it, we had comments on the IPPM WG mailing list and at a
meeting in the course of presenting the work. I also used feedback received
in discussing IP Services SOAM at MEF.

Regards,