Subject: [OPSAWG] Erik Kline's No Objection on draft-ietf-opsawg-ntf-12: (with COMMENT)

From: Erik Kline via Datatracker <[email-masked]>
Date: Wed, 01 Dec 2021 14:08:24 -0800

Erik Kline has entered the following ballot position for
draft-ietf-opsawg-ntf-12: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/blog/handling-iesg-ballot-positions/
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-opsawg-ntf/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

[S3.1; question]

* Figure 2: Is PCAP a possible Data Encoding for the Forwarding Plane?

* Figure 2: Should "plain text" be replaced by something like
  "proprietary"?

  I suspect the intent was to communicate that custom/bespoke encodings
  may still be quite common.

---

From: Haoyu Song <[email-masked]>
Date: Wed, 1 Dec 2021 22:45:24 +0000

Hi Erik,

Thank you very much for the review! Please find my inline response. 

Best regards,
Haoyu

-----Original Message-----
From: Erik Kline via Datatracker <[email-masked]> 
Sent: Wednesday, December 1, 2021 2:08 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Erik Kline's No Objection on draft-ietf-opsawg-ntf-12: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Please refer to https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fblog%2Fhandling-iesg-ballot-positions%2F&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C9556f448ab40405bf01208d9b51718fa%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637739933072244321%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=LzuHrDHHDtKfXNEaFcLtndgvhcNyBQZFDqhPbJoSTw8%3D&amp;reserved=0
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-opsawg-ntf%2F&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C9556f448ab40405bf01208d9b51718fa%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637739933072244321%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=v5fCrIfFbL5yrV73M5QKNx0MXMKIJ3rgHS8PDwQtQCw%3D&amp;reserved=0

[S3.1; question]

[HS] We consider PCAP a format in host software. This document mainly concerns about the forwarding plane of network devices in which we haven't seen PCAP is used for data encoding.

[HS] It's possible to have proprietary encoding but since we advocate for standard implementations, we don't list it here. "Plain text" means no special encoding of the data is applied.

[HS] Yes, understood. We explained that we don't intend to provide an exhaustive list for each case but  a few examples only.