Subject: Re: [OPSAWG] I-D Action: draft-ietf-opsawg-sap-00.txt (Bo's comment)

From: <[email-masked]>
Date: Fri, 11 Feb 2022 13:38:31 +0000

Hi Bo, 

A candidate version that takes into account your comment can be seen at: https://github.com/IETF-OPSAWG-WG/lxnm/blob/master/I-D-sap/draft-ietf-opsawg-sap.txt  

As a reminder, your previous comment was: 

==
I have one clarification comment. The introduction says that the SAP model can be used together with the service model to derive the interconnection points in a multi-domain scenario. Are the interconnection points are also SAPs?
==

Interconnection points are also SAPs. We have now a more clean approach with a new data node "interface-role" that is used to indicate whether a SAP is for UNI or NNI. This new attribute is also useful if specific augmentations are needed in the future for NNIs. 

We have already an example that show how that attribute is used for the uni case, but we are also considering inter-AS VPNs to illustrate the nni specific part. We may be adding an example in -01 or in -02. 

Thank you. 

Cheers,
Med

> -----Message d'origine-----
> De : OPSAWG <[email-masked]> De la part de
> [email-masked]
> Envoyé : mardi 25 janvier 2022 13:20
> À : [email-masked]
> Cc : [email-masked]
> Objet : Re: [OPSAWG] I-D Action: draft-ietf-opsawg-sap-00.txt
> 
> Hi all,
> 
> This version does not address any of the comments raised during the call
> for adoption. We are planning to do so in the coming weeks.
> 
> The comments raised by Benoît, Daniel, Dhruv, and Bo are recorded at:
> https://github.com/IETF-OPSAWG-WG/lxnm/issues?q=label%3AI-D.sap
> 
> Please use that repo to flag your issues. Thanks.
> 
> Cheers,
> Med
> 
> > -----Message d'origine-----
> > De : I-D-Announce <[email-masked]> De la part de
> > [email-masked] Envoyé : mardi 25 janvier 2022 13:02 À :
> > [email-masked] Cc : [email-masked] Objet : I-D Action:
> > draft-ietf-opsawg-sap-00.txt
> >
> >
> > A New Internet-Draft is available from the on-line Internet-Drafts
> > directories.
> > This draft is a work item of the Operations and Management Area
> > Working Group WG of the IETF.
> >
> >         Title           : A Network YANG Model for Service Attachment
> > Points
> >         Authors         : Oscar Gonzalez de Dios
> >                           Samier Barguil
> >                           Qin Wu
> >                           Mohamed Boucadair
> >                           Victor Lopez
> > 	Filename        : draft-ietf-opsawg-sap-00.txt
> > 	Pages           : 21
> > 	Date            : 2022-01-25
> >
> > Abstract:
> >    This document defines a YANG data model for representing an
> abstract
> >    view of the provider network topology containing the points from
> >    which its services can be attached (e.g., basic connectivity, VPN,
> >    network slices).  The data model augments the 'ietf-network' data
> >    model by adding the concept of service attachment points (SAPs).
> The
> >    service attachment points are the points to which network services
> >    (such as L3VPN or L2VPN) can be attached.  The customer endpoint of
> >    an attachment circuits are not covered in the SAP network topology.
> >
> >
> > The IETF datatracker status page for this draft is:
> > https://datatracker.ietf.org/doc/draft-ietf-opsawg-sap/
> >
> > There is also an htmlized version available at:
> > https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-sap-00
> >
> >
> > Internet-Drafts are also available by rsync at
> > rsync.ietf.org::internet- drafts
> >
> >
> > _______________________________________________
> > I-D-Announce mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/i-d-announce
> > Internet-Draft directories: http://www.ietf.org/shadow.html or
> > ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> ________________________________________________________________________
> _________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
> exploites ou copies sans autorisation. Si vous avez recu ce message par
> erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les
> pieces jointes. Les messages electroniques etant susceptibles
> d'alteration, Orange decline toute responsabilite si ce message a ete
> altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged
> information that may be protected by law; they should not be
> distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender and
> delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that have
> been modified, changed or falsified.
> Thank you.
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Wubo (lana)" <[email-masked]>
Date: Fri, 18 Feb 2022 09:45:56 +0000

Hi Med,

Thanks for taking my comments into consideration. This new node helps to identity the SAP type.

Best regards,
Bo

> -----邮件原件-----
> 发件人: [email-masked]
> [mailto:[email-masked]]
> 发送时间: 2022年2月11日 21:39
> 收件人: Wubo (lana) <[email-masked]>
> 抄送: [email-masked]
> 主题: RE: I-D Action: draft-ietf-opsawg-sap-00.txt (Bo's comment)
> 
> Hi Bo,
> 
> A candidate version that takes into account your comment can be seen at:
> https://github.com/IETF-OPSAWG-WG/lxnm/blob/master/I-D-sap/draft-ietf-ops
> awg-sap.txt
> 
> I have one clarification comment. The introduction says that the SAP model can
> be used together with the service model to derive the interconnection points in
> a multi-domain scenario. Are the interconnection points are also SAPs?
> ==
> 
> Interconnection points are also SAPs. We have now a more clean approach with
> a new data node "interface-role" that is used to indicate whether a SAP is for
> UNI or NNI. This new attribute is also useful if specific augmentations are
> needed in the future for NNIs.
> 
> We have already an example that show how that attribute is used for the uni
> case, but we are also considering inter-AS VPNs to illustrate the nni specific
> part. We may be adding an example in -01 or in -02.
> 
> Thank you.
> 
> Cheers,
> Med
> 
> > [email-masked] Envoyé : mardi 25 janvier 2022 13:20 À :
> > [email-masked] Cc : [email-masked] Objet : Re:
> > [OPSAWG] I-D Action: draft-ietf-opsawg-sap-00.txt
> >
> > Hi all,
> >
> > This version does not address any of the comments raised during the
> > call for adoption. We are planning to do so in the coming weeks.
> >
> ________________________________________________________________
> ______
> > __ _________________________________________________
> >
> > exploites ou copies sans autorisation. Si vous avez recu ce message
> > par erreur, veuillez le signaler a l'expediteur et le detruire ainsi
> > que les pieces jointes. Les messages electroniques etant susceptibles
> > This message and its attachments may contain confidential or
> > privileged information that may be protected by law; they should not
> > be distributed, used or copied without authorisation.
> ________________________________________________________________
> _________________________________________________________
> 
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou
> copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le
> signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration, Orange decline toute
> responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> information that may be protected by law; they should not be distributed, used
> or copied without authorisation.