Subject: [OPSAWG] I-D Action: draft-ietf-opsawg-sap-01.txt

From: [email-masked]
Date: Fri, 18 Feb 2022 05:44:39 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Operations and Management Area Working Group WG of the IETF.

        Title           : A Network YANG Model for Service Attachment Points (SAPs)
        Authors         : Mohamed Boucadair
                          Oscar Gonzalez de Dios
                          Samier Barguil
                          Qin Wu
                          Victor Lopez
	Filename        : draft-ietf-opsawg-sap-01.txt
	Pages           : 35
	Date            : 2022-02-18

Abstract:
   This document defines a YANG data model for representing an abstract
   view of the provider network topology that contains the points from
   which its services can be attached (e.g., basic connectivity, VPN,
   network slices).  Also, the model can be used to retrieve the points
   where the services are actually being delivered to customers
   (including peer networks).

   This document augments the 'ietf-network' data model by adding the
   concept of Service Attachment Points (SAPs).  The Service Attachment
   Points are the network reference points to which network services,
   such as Layer 3 Virtual Private Network (L3VPN) or Layer 2 Virtual
   Private Network (L2VPN), can be attached.  Both User-Network
   Interface (UNI) and Network-to-Network Interface (NNI) are supported
   in the SAP data model.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-opsawg-sap/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-sap-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-sap-01

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: <[email-masked]>
Date: Fri, 18 Feb 2022 14:02:36 +0000

Hi all, 

This is a major revision that addresses all the issues we identified so far, including those raised by the WG participants (see the full list of closed issues at https://github.com/IETF-OPSAWG-WG/lxnm/issues?q=is%3Aissue+label%3AI-D.sap+is%3Aclosed). 

The main changes are as follows:

* Almost a complete rewrite of all sections for better readability
* Revise the structure of the module so that: 
 - per-service SAP topology can be maintained. Appropriate filters can be used for that purpose 
 - Clarify the Applicability of SAPs for both UNI and NNI. A dedicated data node is defined for that purpose. 
 - Clarify how SAPs can be linked to the physical topology
 - Separate the SAP status vs service status as a SAP may be bound to multiple services.
 - Ease the correlation between a SAP and a service request by including a pointer to a reference customer endpoint
 - Define a new identity for interface types
 - Rely upon RFC9181 for service types + define new ones (slice, sdwan, basic connectivity, etc.)
* Clarify that SAPs can be used to expose where a service can be delivered, but all where it is being delivered.   
* Add many examples, including an NNI example

Additional rationale for the changes can be found here: https://github.com/IETF-OPSAWG-WG/lxnm/blob/master/I-D-sap/SAP%20Updates-rev%2010022022.pdf

Comments and suggestions are more than welcome. Also, proposal for service identities that may be benefit from the SAP model are appreciated. 

Chairs, can you please request an early yang review for this version? Thank you.

Cheers,
Med

> -----Message d'origine-----
> De : OPSAWG <[email-masked]> De la part de internet-
> [email-masked]
> Envoyé : vendredi 18 février 2022 14:45
> À : [email-masked]
> Cc : [email-masked]
> Objet : [OPSAWG] I-D Action: draft-ietf-opsawg-sap-01.txt
> 
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.