Subject: [OPSAWG] FW: New Version Notification for draft-tgraf-opsawg-ipfix-srv6-srh-02.txt

From: <[email-masked]>
Date: Sun, 6 Mar 2022 07:46:09 +0000

Dear OPSAWG and SPRING working group,

Based on the feedbacks I received, I updated the document. 

Apart from the small editorial changes, the following points have been addressed

- updated IANA sections according to RFC 8126
- added ipv6SRHSegmentListSection to facilitate immediate export without data flow manipulation
- added Operational Considerations section to described differences between ipv6SRHSegmentBasicList and ipv6SRHSegmentListSection

Looking forward for further reviews and comments.

Based wishes
Thomas

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Sunday, March 6, 2022 8:35 AM
To: Benoit Claise <[email-masked]>; Graf Thomas, INI-NET-TCZ-ZH1 <[email-masked]>
Subject: New Version Notification for draft-tgraf-opsawg-ipfix-srv6-srh-02.txt

A new version of I-D, draft-tgraf-opsawg-ipfix-srv6-srh-02.txt
has been successfully submitted by Thomas Graf and posted to the IETF repository.

Name:		draft-tgraf-opsawg-ipfix-srv6-srh
Revision:	02
Title:		Export of Segment Routing IPv6 Information in IP Flow Information Export (IPFIX)
Document date:	2022-03-06
Group:		Individual Submission
Pages:		12
URL:            https://www.ietf.org/archive/id/draft-tgraf-opsawg-ipfix-srv6-srh-02.txt
Status:         https://datatracker.ietf.org/doc/draft-tgraf-opsawg-ipfix-srv6-srh/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-tgraf-opsawg-ipfix-srv6-srh
Diff:           https://www.ietf.org/rfcdiff?url2=draft-tgraf-opsawg-ipfix-srv6-srh-02

Abstract:
   This document introduces new IP Flow Information Export (IPFIX)
   information elements to identify the SRv6 Segment Routing Header
   dimensions and SRv6 Control Plane Protocol that traffic is being
   forwarded with.

The IETF Secretariat

---

From: <[email-masked]>
Date: Fri, 25 Mar 2022 12:18:27 +0000

Thanks for the feedback on slide 7.

https://datatracker.ietf.org/meeting/113/materials/slides-113-opsawg-export-of-segment-routing-ipv6-information-in-ipfix-01
https://datatracker.ietf.org/doc/html/draft-tgraf-opsawg-ipfix-srv6-srh-03

We understood it does not bring much added value to decompose the C-SID container into Compressed-SID (C-SID) in IPFIX and it does makes sense to add an operational consideration section to describe how an IPFIX data-collection could distinct between a list of IPv6 SID's and a list of C-SID containers.

Regarding the question wherever slide 7 also applies to G-SID defined in https://datatracker.ietf.org/doc/html/draft-cl-spring-generalized-srv6-for-cmpr-04#section-3.1. Yes, in essencence the same alsop applies to G-SID and G-SID Container.

We will update the input in the upcoming -04 version. Further comments and input welcomed.

Regarding implementation status. We intend to release open-source VPP running code by IETF 115 hacktathon. One major network vendor commited on implementation and others showed interest.

Best wishes
Thomas

-----Original Message-----
From: Graf Thomas, INI-NET-TCZ-ZH1 
Sent: Sunday, March 6, 2022 8:46 AM
To: spring <[email-masked]>; opsawg <[email-masked]>
Subject: FW: New Version Notification for draft-tgraf-opsawg-ipfix-srv6-srh-02.txt

Based wishes
Thomas

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Sunday, March 6, 2022 8:35 AM
To: Benoit Claise <[email-masked]>; Graf Thomas, INI-NET-TCZ-ZH1 <[email-masked]>
Subject: New Version Notification for draft-tgraf-opsawg-ipfix-srv6-srh-02.txt

Abstract:

The IETF Secretariat