Subject: Re: [OPSAWG] Specifying protocols in draft-claise-opsawg-collected-data-manifest

From: Benoit Claise <[email-masked]>
Date: Sat, 19 Mar 2022 15:45:48 +0100

Hi Tianran,

Thanks for your feedback.
I have added the required extra justification in the temp version:

    The goal behind this specification is not to expose new information
    via YANG objects but rather to define what needs to be kept as
    metadata (the data manifest) to ensure that the collected data can
    still be interpreted correctly, even if the source device is not
    accesible (from the collection system), or if the device has been
    updated (new operating system or new configuration).

https://github.com/JeanQuilbeufHuawei/draft-collected-data-manifest

Regards, Benoit

On 2/10/2022 2:46 AM, Tianran Zhou wrote:
>
> Thanks Jean and Benoit for your clarification.
>
> I think this manifest information is useful.
>
> One more justification IMO might be useful.
>
> When controller and collector are on separate servers, which is a very 
> common deployment, collector may not have access to the device 
> configuration.
>
> T.
>
> *From:*OPSAWG [mailto:[email-masked]] *On Behalf Of *Benoit 
> Claise
> *Sent:* Wednesday, February 9, 2022 10:42 PM
> *To:* Tianran Zhou <zhoutianran=[email-masked]>; Jean 
> Quilbeuf <jean.quilbeuf=[email-masked]>; opsawg 
> <[email-masked]>
> *Subject:* Re: [OPSAWG] Specifying protocols in 
> draft-claise-opsawg-collected-data-manifest
>
> Hi Tianran,
>
> On 2/9/2022 2:04 PM, Tianran Zhou wrote:
>
>     Hi Jean,
>     I am a little confused about this manifest?
>     Can we just read from the device about the configuration? We can get all the running information.
>
> I'm not sure whether this is a generic question or whether your 
> question relates to the message below.
> Let me answer the generic question. We don't always want to read the 
> devices information from the closed-loop automation systems or the 
> database. Once known ...
>
>    "This data manifest instance file MUST be streamed all with the data
>    and stored along with the collected data.  In case the data are moved
>    to different place (typically a database), the data manifest MUST
>    follow the collected data.  This can render the data unusable if that
>    context is lost, for instance when the data is stored without the
>    relevent information."
>
> Also the context might be lost, so  not available any longer from the 
> device Ex: how was it metered?
>
> This is what we were trying to say with this generic sentence in the 
> charter: "This can render the data unusable if that context is lost, 
> for instance when the data is stored without the relevent information."
>
> There is some more justifications in the introduction (section 2).
>
> Regards, Benoit
>
>     Best,
>     Tianran
>
>
>
>     ------------------------------------------------------------------------
>
>
>     Sent from WeLink
>
>     *发件人：***Jean Quilbeuf<jean.quilbeuf=[email-masked]>
>
>     *收件人：***opsawg<[email-masked]>
>
>     *主题：***[OPSAWG] Specifying protocols in
>     draft-claise-opsawg-collected-data-manifest
>
>     *时间：***2022-02-09 20:33:06
>
>     Dear All,
>     We are wondering whether to add information about protocols in the
>     data manifest draft
>     https://datatracker.ietf.org/doc/draft-claise-opsawg-collected-data-manifest/
>
>
>     Details are here
>     https://github.com/JeanQuilbeufHuawei/draft-collected-data-manifest/issues/9
>     (that git repo contains a pre-01 version of the draft).
>
>     The data manifest should contain the information that a device
>     able to stream telemetry can gather to allow a posteriori
>     understanding of values stored in a time series database for
>     instance. In that context, knowing the protocol would enable to
>     understand whether some metrics can be missed (for instance if UDP
>     push is used) and explain some gaps in the time serie.
>
>     1 - In the model, do we want to encode that fact as a Boolean
>     (such as unreliable_subscription) that would be attached to a
>     particular MDT subscription or do we want to specify the protocol
>     used for subscription and let the consumer of the model draw the
>     conclusion themselves?
>
>     2 - Another point is about the encoding used, do we need to
>     specify it in the data-manifest or do we leave this as a
>     responsibility of the collector/database system?
>
>     For the second question, not that he collector/database system
>     still  has the responsibility to modify the data manifest if that
>     encoding is changed.
>
>     Any suggestions?
>
>     Best,
>     Jean
>     _______________________________________________
>     OPSAWG mailing list
>     [email-masked]
>     https://www.ietf.org/mailman/listinfo/opsawg
>
>
>
>     _______________________________________________
>
>     OPSAWG mailing list
>
>     [email-masked]
>
>     https://www.ietf.org/mailman/listinfo/opsawg
>
>
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: Tianran Zhou <[email-masked]>
Date: Sat, 19 Mar 2022 15:01:28 +0000

Thanks for taking my suggestion.
This revision looks good for me.

Cheers,
Tianran

________________________________

Sent from WeLink
发件人： Benoit Claise<benoit.claise=[email-masked]<mailto:benoit.claise=[email-masked]>>
收件人： Tianran Zhou<zhoutianran=[email-masked]<mailto:zhoutianran=[email-masked]>>;Benoit Claise<benoit.claise=[email-masked]<mailto:benoit.claise=[email-masked]>>;Jean Quilbeuf<jean.quilbeuf=[email-masked]<mailto:jean.quilbeuf=[email-masked]>>;opsawg<[email-masked]<mailto:[email-masked]>>
主题： Re: [OPSAWG] Specifying protocols in draft-claise-opsawg-collected-data-manifest
时间： 2022-03-19 22:47:16

Hi Tianran,

Thanks for your feedback.
I have added the required extra justification in the temp version:
The goal behind this specification is not to expose new information via YANG objects but rather to define what needs to be kept as metadata (the data manifest) to ensure that the collected data can still be interpreted correctly, even if the source device is not accesible (from the collection system), or if the device has been updated (new operating system or new configuration).
https://github.com/JeanQuilbeufHuawei/draft-collected-data-manifest

Regards, Benoit

When controller and collector are on separate servers, which is a very common deployment, collector may not have access to the device configuration.

T.
From: OPSAWG [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Wednesday, February 9, 2022 10:42 PM
To: Tianran Zhou <zhoutianran=[email-masked]><mailto:zhoutianran=[email-masked]>; Jean Quilbeuf <jean.quilbeuf=[email-masked]><mailto:jean.quilbeuf=[email-masked]>; opsawg <[email-masked]><mailto:[email-masked]>
Subject: Re: [OPSAWG] Specifying protocols in draft-claise-opsawg-collected-data-manifest

Hi Tianran,
On 2/9/2022 2:04 PM, Tianran Zhou wrote:
Hi Jean,
I am a little confused about this manifest?
Can we just read from the device about the configuration? We can get all the running information.
I'm not sure whether this is a generic question or whether your question relates to the message below.
Let me answer the generic question. We don't always want to read the devices information from the closed-loop automation systems or the database. Once known ...

   relevent information."
Also the context might be lost, so  not available any longer from the device Ex: how was it metered?

This is what we were trying to say with this generic sentence in the charter: "This can render the data unusable if that context is lost, for instance when the data is stored without the relevent information."

Regards, Benoit

Best,
Tianran

________________________________

Sent from WeLink
发件人： Jean Quilbeuf<jean.quilbeuf=[email-masked]<mailto:jean.quilbeuf=[email-masked]>>
收件人： opsawg<[email-masked]<mailto:[email-masked]>>
主题： [OPSAWG] Specifying protocols in draft-claise-opsawg-collected-data-manifest
时间： 2022-02-09 20:33:06

Dear All,
We are wondering whether to add information about protocols in the data manifest draft https://datatracker.ietf.org/doc/draft-claise-opsawg-collected-data-manifest/

Details are here https://github.com/JeanQuilbeufHuawei/draft-collected-data-manifest/issues/9  (that git repo contains a pre-01 version of the draft).

The data manifest should contain the information that a device able to stream telemetry can gather to allow a posteriori understanding of values stored in a time series database for instance. In that context, knowing the protocol would enable to understand whether some metrics can be missed (for instance if UDP push is used) and explain some gaps in the time serie.

1 - In the model, do we want to encode that fact as a Boolean (such as unreliable_subscription) that would be attached to a particular MDT subscription or do we want to specify the protocol used for subscription and let the consumer of the model draw the conclusion themselves?

2 - Another point is about the encoding used, do we need to specify it in the data-manifest or do we leave this as a responsibility of the collector/database system?

For the second question, not that he collector/database system still  has the responsibility to modify the data manifest if that encoding is changed.

Any suggestions?

Best,
Jean
_______________________________________________
OPSAWG mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/opsawg

OPSAWG mailing list

[email-masked]<mailto:[email-masked]>

_______________________________________________
OPSAWG mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/opsawg

---

From: Benoit Claise <[email-masked]>
Date: Sat, 19 Mar 2022 16:22:45 +0100

Hi Med,

Many thanks for your review.
All your feedback has been inserted.

For the data source PEN, we added the "vendor" object (in the github 
temp version). The YANG model is now aligned with the fields in the 
yangcatalog.org API 
(https://datatracker.ietf.org/doc/html/draft-clacla-netmod-model-catalog).

Regards, Benoit

On 2/14/2022 3:12 PM, [email-masked] wrote:
>
> Hi Benoît, Jean,
>
> FWIW, you may find some comments/suggestions at:
>
>   * pdf:
>     https://github.com/boucadair/IETF-Drafts-Reviews/raw/master/draft-claise-opsawg-collected-data-manifest-00-rev%20Med.pdf
>
>   * doc:
>     https://github.com/boucadair/IETF-Drafts-Reviews/raw/master/draft-claise-opsawg-collected-data-manifest-00-rev%20Med.doc
>     <https://github.com/boucadair/IETF-Drafts-Reviews/raw/master/draft-claise-opsawg-collected-data-manifest-00-rev%20Med.doc>
>
> Some of the context information is not specific to telemetry, but can 
> be applied in other contexts to assess the reliability of collected 
> data. Generalizing the concept would make sense.
>
> Cheers,
>
> Med
>
> *De :* OPSAWG <[email-masked]> *De la part de* Benoit Claise
> *Envoyé :* mercredi 9 février 2022 15:42
> *À :* Tianran Zhou <zhoutianran=[email-masked]>; Jean 
> *Objet :* Re: [OPSAWG] Specifying protocols in 
>     *收件人：*** opsawg<[email-masked]>
>
>     *主**题：***[OPSAWG] Specifying protocols in
> _________________________________________________________________________________________________________________________
>
> Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
> Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
>
> This message and its attachments may contain confidential or privileged information that may be protected by law;
> they should not be distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender and delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
> Thank you.