Subject: Re: [OPSAWG] WG LC: A YANG Model for Network and VPN Service Performance Monitoring

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Wed, 6 Apr 2022 14:16:33 +0000

The WG LC is now closed.  Tom has provided additional comments, and I
still have some outstanding reviews, so I will mark this as pending a
revised I-D.  I noted no strong opposition to this work during the process.

We are in need of a shepherd for this work.  Who is interested?

An IPR poll went out with authors responding that there is no known
IPR.  I have confirmed none has been submitted in Data Tracker.  If
there is any known IPR, it must be disclosed.

Joe

On 3/28/22 09:52, Joe Clarke (jclarke) wrote:
> In preparing for IETF 113, I let the close of this slip, but that turns
> out to be a good thing.
>
> During her presentation, Bo called out the authors made a substantive
> change in the latest revision to introduce a choice for vpn-pm-type. 
> Therefore, we are extending LC for another week to close on Monday,
> April 4, 2022.
>
> Joe
>
> On 2/28/22 18:05, Joe Clarke (jclarke) wrote:
>> Ahead of IETF 113, we'd like to get working group consensus on
>> https://datatracker.ietf.org/doc/draft-ietf-opsawg-yang-vpn-service-pm/.  We
>> are therefore conducting a two-week WG LC on this work.  I have also
>> requested reviews from Yang Docs, Ops, and Routing DIRs.
>>
>> Please share you comments and reviews on list.
>>
>> WG LC will end on March 14, 2022.
>>
>> Thanks.
>>
>> Joe
>>
>

---

From: "Wubo (lana)" <[email-masked]>
Date: Fri, 8 Apr 2022 08:49:02 +0000

Hi Tom,

Thanks for your helpful comments. We have submitted Rev-05 to address your comments: https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-yang-vpn-service-pm-05.
Please see inline for the details.

Thanks,
Bo

-----Original Message-----
From: OPSAWG [mailto:[email-masked]] On Behalf Of tom petch
Sent: Wednesday, March 30, 2022 7:31 PM
To: Joe Clarke (jclarke) <jclarke=[email-masked]>; [email-masked]
Subject: Re: [OPSAWG] WG LC: A YANG Model for Network and VPN Service Performance Monitoring

From: OPSAWG <[email-masked]> on behalf of Joe Clarke (jclarke) <jclarke=[email-masked]>
Sent: 28 March 2022 14:52

In preparing for IETF 113, I let the close of this slip, but that turns out to be a good thing.

<tp>

Now I have lost my excuse for Last Call comments:-(

I do not understand how OWAMP is default.  AFAICT it is 'config false' so I do not understand 'default'
[Bo Wu] Thanks for catching this. We clean up the "default" description in the YANG model and add OWAMP, Y.1731, etc. as references.

YANG module references  11 RFC - two are not in the I-D References AFAICT and three are Informative - latter may be ok, former not
[Bo Wu] We have corrected this, adding two missing ones and move the three to formative.

SLA is not a starred abbreviation
[Bo Wu] Fixed. SLA has been added to the abbreviation.

one way measurement protocol (e.g. OWAMP) what others are there?
[Bo Wu] Y.1731 is also added for Ethernet VPN service.

delay is gauge64, jitter is gauge32; probably ok even if a ratio of 4B to one is unlikely
[Bo Wu] We have changed gauge32 to gauge64.

discards I am told are a sign of congestion which I always wonder about - I notice you do not mention that possibility!
[Bo Wu] Agree this is a common case. We has added this reason.

Overall, I have a disconnect between PM and topology.  Topology is relatively static, you get it or set it and that is that for the time being.  PM for me is not.  It changes every interval and I want the history or I want an alert when some value for an interval exceeds or falls below a threshold.  Adding a single set of values for a single interval seems unrelated to topology and I see nothing in the text related to that.
[Bo Wu] We add some new text to describe this in section 3.1. Collecting Data via Pub/Sub Mechanism. Please see whether it is clear.

Tom Petch

During her presentation, Bo called out the authors made a substantive change in the latest revision to introduce a choice for vpn-pm-type.
Therefore, we are extending LC for another week to close on Monday, April 4, 2022.

Joe

On 2/28/22 18:05, Joe Clarke (jclarke) wrote:
> https://datatracker.ietf.org/doc/draft-ietf-opsawg-yang-vpn-service-pm
> /.  We are therefore conducting a two-week WG LC on this work.  I have 
> also requested reviews from Yang Docs, Ops, and Routing DIRs.
>

_______________________________________________
OPSAWG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/opsawg

_______________________________________________
OPSAWG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/opsawg