Subject: RE: [Ospf-manet] evaluation plan for OSPF MANET

From: "Henderson, Thomas R" <[email-masked]>
Date: Wed, 30 Nov 2005 15:14:01 -0800

There is another issue beyond Hellos vs router-LSAs that needs to be
resolved-- whether flooding can occur over these unsynchronized
adjacencies.  Section 4.4 of the new smart peering draft raises the
question but doesn't answer it.

If flooding is enabled on unsynchronized adjacencies, and there is some
means to get the true 2-hop information (via Hellos or link LSAs), then
it seems that the MPR flooding backbone can be decoupled from the
partial topology technique.  Otherwise, there is a dependency that
Richard mentioned.

Can you clarify whether we should assume flooding on unsynchronized
adjacencies?

Tom

> -----Original Message-----
> From: Abhay Roy [mailto:[email-masked]] 
> Sent: Wednesday, November 30, 2005 2:22 PM
> To: Richard Ogier
> Cc: Henderson, Thomas R; [email-masked]
> Subject: Re: [Ospf-manet] evaluation plan for OSPF MANET
> 
> If it seems valuable to use the 2-hop information from the 
> Hello's (say for partial-topology), I think we can easily 
> adapt ORCAs to use the Hello's v/s Router-LSAs.
> 
> Regards,
> -Roy-
> 
> On 11/28/05-0800 at 3:26pm, Richard Ogier writes:
> 
> > I would like to add one more comment.
> > Since partial-topology LSAs have been shown to reduce overhead 
> > substantially, simulations with partial-topology LSAs should be 
> > performed for both protocols.
> > One cannot simply assume that if a protocol performs well with 
> > full-topology LSAs, then it will perform well with partial-topology 
> > LSAs.  For example, it is not clear how using partial-topology LSAs 
> > will affect MPR selection (which depends on 2-hop neighbor 
> information 
> > obtained from neighbors' LSAs).
> >
> > I don't think Cisco's protocol can use MPRs to create 
> partial-topology 
> > LSAs that provide min-hop paths, since MPRs based on 
> partial-topology 
> > LSAs will generally not provide min-hop paths. (This is one of the 
> > reasons OSPF-MDR uses Hellos to learn 2-hop neighbor info.) 
> However, 
> > Cisco's protocol can use the min-cost LSAs of the OSPF-MDR draft to 
> > provide min-hop paths.
> >
> > Richard
> >
> >
> >
> >
> > _______________________________________________
> > Ospf-manet mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ospf-manet
> >
> 

_______________________________________________
Ospf-manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf-manet

---

From: Abhay Roy <[email-masked]>
Date: Wed, 30 Nov 2005 15:56:31 -0800 (PST)

As a default mode of operation (saving overhead) we suggested that 
the flooding should NOT happen on Unsynchronized Adjacency (UA) 
links. But then we did allow it as an optional enhacement if it 
becomes valuable.

Note that the flooding or no flooding "mode" needs to be consistent 
on all the nodes, since it influences the relay election logic.

So yes, if we can use Hello's for 2-hop discovery, we might be 
able to use some of the partial topology techniques with ORCAs.