Subject: Re: [Ospf-manet] MPR-OSPF GTNetS simulations report

From: Emmanuel Baccelli <[email-masked]>
Date: Tue, 23 Jan 2007 10:45:40 +0100

Dear Richard,

We agree that there is no need to argue. The MPR-OSPF is a consistent
extension of OSPFv3 that uses flooding reduction, topology reduction and
adjacency reduction based on MPR, with a stable specification ready for
experimental status.

You suggest that you could introduce some changes in MDR, taking
advantage of the experimental status. We do not think that it is needed
to introduce the major changes you mentionned (such as including MPR
topology reduction or multicast) since they are already featured in the
MPR-OSPF extension. However, if you think MDR needs major changes, then
MDR is not ready for experimental status.

Emmanuel

_______________________________________________
Ospf-manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf-manet

---

From: Richard Ogier <[email-masked]>
Date: Sun, 28 Jan 2007 15:55:11 -0800

Emmanuel,

Regarding your simulation results, it looks like using
MPR adjacency reduction does not reduce overhead much,
and based on the simulation results I presented recently,
MDR with adjacency reduction has much lower overhead.

I think you would have to make major changes to your draft
before it is competitive with MDR.  For example, you will at
least have to select MPRs (and "path MPRs" for LSAs) to be more
stable, which has not yet been described in your draft.

The MDR draft does not need major changes, but I am making
changes to improve readability, to simplify the BMDR algorithm,
and other minor changes such as improving min-cost LSAs.
This does not change the core methods for flooding and adjacency
reduction, which have been stable for about two years.

My point was that, since MPR adjacency reduction is not scalable,
the main contributions of your draft are MPR LSA reduction
and multicast retransmitted LSAs (the latter of which is not
new and was considered in version 00 of the MDR draft), and
that these two contributions do not by themselves constitute
an OSPF extension, but are techniques that can be applied
to either ORs or MDRs.

I mentioned that I will experiment with multicast retransmitted
LSAs to see if they improve the performance of MDRs in some
scenarios, and if they do they can be included as an option.
This would be a minor change to the MDR draft.

After we have both finalized our drafts, we should continue
our discussion then, and perform a fair simulation comparison.
Until then, I suggest we take a break from this discussion.

Richard