Subject: RE: [Ospf-wireless-design] new material to review and discuss

From: "Henderson, Thomas R" <[email-masked]>
Date: Thu, 4 Nov 2004 15:40:58 -0800

> -----Original Message-----
> From: Joe Macker [mailto:[email-masked]] 
> Sent: Thursday, November 04, 2004 11:31 AM
> To: Madhavi W. Chandra
> Cc: Henderson, Thomas R; [email-masked]
> Subject: Re: [Ospf-wireless-design] new material to review and discuss
> 
> 
> Madhavi W. Chandra wrote:
> >>>
> >>>OSPF requires all nodes to run the same shortest-path algorithm,
> >>>so requiring all nodes to run the same CDS algorithm
> >>>is consistent with OSPF's philosophy.
>  
> Are you assuming by the above, the link state is limited to 
> or only initiated by the relay set nodes?
> 
> Unless I am misinterpreting the context, the CDS selection 
> specifics (whether source specific or not) and the routing 
> algorithm can be orthogonal.

I think that this might be out of context.  The original comment
referred to was from Richard, in reply to an observation
that MPRs have the possible virtue that they allow different
nodes to run different algorithms.  I took Richard's response
to mean that if we decided on an algorithm that was required
to be implemented uniformly in the network, such an approach
would nevertheless be consistent with other aspects of OSPF.

Tom

_______________________________________________
Ospf-wireless-design mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf-wireless-design

---

From: Joe Macker <[email-masked]>
Date: Fri, 05 Nov 2004 12:37:35 -0500

> referred to was from Richard, in reply to an observation

Right..I intended the question for Richard.. sorry Madhavi.

> would nevertheless be consistent with other aspects of OSPF.

O.k....I was reading into this as a SD-CDS argument relating to shortest path consistency.