Subject: [Ospf-wireless-design] Example comparing CDS approach to MPR approach

From: Richard Ogier <[email-masked]>
Date: Wed, 23 Mar 2005 10:24:33 -0800

Here is an example to show one advantage of using (differential)
Hellos to report 2-hop neighbor information, and having routers
select themselves as DRs, versus using LSAs to report 2-hop neighbor
information, and having routers select neighbors as MPRs.
This advantage has been discussed before, but I wanted to
present a clear, simple example.

For fairness (and to avoid additional overhead), I will assume
that no early Hellos are sent.
I will assume that HelloInterval = 2 and that MinLSInterval = 5.
I will look at the worst case under the assumption that
a Hello or LSA is received the first time if the link is good.
In a highly mobile network, a neighbor change can easily occur
every 5 seconds, so I will assume that each router originates
a new LSA every MinLSInterval.

       1
      / \
     /   \
    2 --- 3
     \   /
      \ /
       4

Assume initially that node 3 is a DR (in the CDS approach),
and node 1 has selected node 3 as an MPR (in the MPR approach).
Assume that node 3 detects the loss of neighbor 4 at time 0.

In the CDS approach, node 3 will send a Hello within 2 seconds,
reporting the loss of neighbor 4.
Node 2 will then immediately select itself as a DR at time 2.

In the MPR approach, node 3 will originate a new LSA within 5 seconds,
reporting the loss of neighbor 4.
Node 1 will then immediately select node 2 as an MPR at time 5,
and will report this in a Hello within 2 seconds.
Node 2 will then know it is an MPR at time 7.

(Of course, the CDS approach has several other advantages, as mentioned
before, but I am focusing on one advantage in this message.)
Richard

_______________________________________________
Ospf-wireless-design mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf-wireless-design

---

From: Emmanuel Baccelli <[email-masked]>
Date: Thu, 24 Mar 2005 03:11:32 +0100

Hi Richard,

I don't understand your example very well. With the use of MPRs, why does node 2
have to wait for an LSA from node 3, instead of a Hello from node 3 that will
come at worst at time 2?

Moreover, when node 4 is gone, the network is a fully connected mesh, so the
example becomes much less interesting.

Emmanuel

> before, but I am focusing on one advantage in this message.)

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.

---

From: Richard Ogier <[email-masked]>
Date: Thu, 24 Mar 2005 06:38:28 -0800

Hi Emmanuel,

Node 4 is not gone. Node 3 just loses node 4 as a neighbor,
i.e., the link between node 3 and node 4 breaks.

You are right that it is possible for node 3 to select itself
as an MPR based on a Hello from node 3, if Hellos contain 2-way
neighbor information, and if MPRs are allowed to select themselves.
But I am talking about the method used in
draft-chandra-ospf-manet-ext, which does not do this.

Richard

---

From: "Madhavi W. Chandra" <[email-masked]>
Date: Thu, 24 Mar 2005 10:32:48 -0500

> draft-chandra-ospf-manet-ext, which does not do this.

Hellos can easily be used to obtain 2-hop information, as we did
initially.  Use of our incremental Hellos further mitigates the effect
of sending a long neighbor list in Hellos.  Using LSAs to obtain this
information provides the built-in reliability available in LSA flooding.
We are studying which is the better transport mechanism.  But, either
way is doable.  The backup Overlapping Relays during this transition 
process ensure that control information is not lost.

-Madhavi

---

From: Acee Lindem <[email-masked]>
Date: Thu, 24 Mar 2005 14:21:02 -0500

Richard,
Many vendors have implemented a configurable threshhold for
refreshing LSAs (with a backoff ) so I wouldn't call the hello rate
versus LSA refresh rate an advantage. Also for the first change,
LSAs are sent immediately.

Thanks,
Acee

---

From: Richard Ogier <[email-masked]>
Date: Thu, 24 Mar 2005 12:12:54 -0800

Acee,

Acee Lindem wrote:

> versus LSA refresh rate an advantage.

I am assuming differential Hellos (which are very small)
versus full LSAs, which are much larger.
This allows the Hello interval to be much smaller than
the LSA refresh interval, without adding much overhead.

> Also for the first change,

In a highly mobile network, there will be frequent changes, so
it is possible that an LSA is originated every MinLSInterval.

Madhavi,

>information provides the built-in reliability available in LSA flooding.
Differential Hellos also provide built-in reliability (at least in
my draft, and maybe also in yours), even better because
the Hello interval is usually smaller than RxmtInterval.

>way is doable.

It seems to me that, if you want to have partial topology LSAs
(as has been recommended), then you need to use Hellos to
report 2-hop neighbor information.

Richard