Subject: Re: Doubt on sending hello packets on NBMA networks

From: "Srinivasaragavan Jayaraman - CTD, Chennai" <[email-masked]>
Date: Mon, 9 May 2005 19:43:45 +0530

hi Acee,

	yeah i got it. but just for the sake of curiosity. can you give me
some more scenarious where this can happen?

Thanks
Srini

-----Original Message-----
From: Acee Lindem [mailto:[email-masked]]
Sent: Monday, May 09, 2005 6:40 PM
To: [email-masked]
Subject: Re: Doubt on sending hello packets on NBMA networks

Srinivasa J Ragavan wrote:

>hi All,
>
>I am a newbie to OSPF.
>can anyone help me out.
>this is with reference to the rfc 2328 sec. 9.5.1 whcih says
>"  If the router is eligible to become Designated Router, it
>            must periodically send Hello Packets to all neighbors that
>            are also eligible."
>
>but immediately in the next paragraph it says
>
>" It must also send an Hello Packet in reply to an
>            Hello Packet received from any eligible neighbor (other than
>            the current Designated Router and Backup Designated Router)"
>
>how can a non eligible router get a hello from a eligibe router if the
>eligible router is not going to send(tatz what the first argument says)
>  
>
Srini,
In the NBMA case (which is described in section 9.5.1), a non-eligible 
router
needs to reply to any eligible neighbor since it may not know the current
DR/BDR. There are a number of scenarios where this can happen including
the case where the non-eligible neighbor first comes up and receives a 
hello poll
from the current DR/DBR. The non-eligible neighbor needs to establish
bi-directional connectivity with the potential DR/BDR in order for its
local DR/BDR election to work.

Hope this helps,
Acee

>Am i missing something here??
>
>thanks
>Srini
>
>  
>
DISCLAIMER 
This message and any attachment(s) contained here are information that is confidential, proprietary to HCL Technologies 
and its customers. Contents may be privileged or otherwise protected by law. The information is solely intended for the 
individual or the entity it is addressed to. If you are not the intended recipient of this message, you are not authorized to 
read, forward, print, retain, copy or disseminate this message or any part of it. If you have received this e-mail in error, 
please notify the sender immediately by return e-mail and delete it from your computer

---

From: Kishore Rao <[email-masked]>
Date: Mon, 9 May 2005 10:57:57 -0600

Possible scenarios ?

- Timing difference between dynamically changing the eligibility
configuration/setting interface priority Vs sending of a Hello.
- Mismatch in configuration between interface priority of a router and its
eligibility configuration on other routers.

Kishore

> This message and any attachment(s) contained here are information that is
confidential, proprietary to HCL Technologies
> and its customers. Contents may be privileged or otherwise protected by
law. The information is solely intended for the
> individual or the entity it is addressed to. If you are not the intended
recipient of this message, you are not authorized to
> read, forward, print, retain, copy or disseminate this message or any part
of it. If you have received this e-mail in error,

---

From: Acee Lindem <[email-masked]>
Date: Mon, 9 May 2005 17:16:22 -0400

Kishore Rao wrote:

>Possible scenarios 
Yup - You don't really even need timing differences - any event which 
causes a new DR/BDR to
be elected would cause the new DR/BDR to start polling non-eligible 
neighbors that
hadn't heard from them before.

>eligibility configuration on other routers.
Yes.

>>please notify the sender immediately by return e-mail and delete it from
>>    
>>
>your computer
>
>  
>