Subject: Re: [OSPF] OSPF HMAC Cryptographic Authentication

From: "Rohit Gupta" <[email-masked]>
Date: Mon, 17 Jul 2006 21:37:42 +0530

Hi,

I could not see any new field added in the OSPF message. How do you then make out whether the OSPF router is using HMAC-SHA1 algorithm or the MD5 (the normal OSPF authentication algorithm)?

Thanks,
Rohit

----- Original Message ----
From: Manav Bhatia <[email-masked]>
To: [email-masked]
Sent: Saturday, 15 July, 2006 5:06:45 AM
Subject: [OSPF] OSPF HMAC Cryptographic Authentication

Hi,

We have just posted a draft that describes a mechanism for authenticating OSPF packets by making use of HMAC algorithm in conjunction with the SHA family of cryptographic hash functions. It would be great if the WG can provide some feedback and comments on the same.

http://www.ietf.org/internet-drafts/draft-bhatia-manral-white-ospf-hmac-sha-00.txt

Thanks,
Manav

> ----- Forwarded Message ----
> From: [email-masked]
> To: [email-masked]
> Sent: Saturday, July 15, 2006 1:20:01 AM
> Subject: I-D ACTION:draft-bhatia-manral-white-ospf-hmac-sha-00.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> 
> 
>    Title        : OSPF HMAC Cryptographic Authentication
>    Author(s)    : M. Bhatia, et al.
>    Filename    : draft-bhatia-manral-white-ospf-hmac-sha-00.txt
>    Pages        : 10
>    Date        : 2006-6-14
> 
>   This document describes a mechanism for authenticating OSPF packets
>   by making use of the HMAC algorithm in conjunction with the SHA
>   family of cryptographic hash functions. Because of the way the hash
>   functions are used in HMAC construction, the collision attacks
>   currently known against SHA-1 do not apply.
> 
>   This will be done in addition to the already documented
>   authentication schemes described in the base specification.
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-bhatia-manral-white-ospf-hmac-sha-00.txt
> 
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body of the 
> message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
> 

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

Sign Up for your FREE eWallet at www.wallet365.com

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: "Vishwas Manral" <[email-masked]>
Date: Mon, 17 Jul 2006 21:54:59 +0530

Hi Rohit,

The authors of the OSPF RFC have done it very intelligently. By
allowing the KeyId field which is Opaque, the value of the KeyId
itself defines a seperate security association(channel). IT is the
understanding between the two ends, that a particular KeyId identifies
a key as well as the cryptographic algorithm used.

That is the reason we do not need any new fields.

Thanks,
Vishwas

---

From: Acee Lindem <[email-masked]>
Date: Mon, 17 Jul 2006 12:31:18 -0400

> I could not see any new field added in the OSPF message. How do you then make out whether the OSPF router is using HMAC-SHA1 algorithm or the MD5 (the normal OSPF authentication algorithm)?
Hi Rohit,
As more than one person pointed out to me, AuType 2 doesn't
define the algorithm used for cryptographic authentication. From D.3 in
RFC 2328:

     Key ID
            This field identifies the algorithm and secret key used to
            create the message digest appended to the OSPF packet. Key
            Identifiers are unique per-interface (or equivalently, per-
            subnet).

Hence, no new AuType value is required. However, since the use of MD5
is described FULLY in appendix D, it would be nice to point out the 
similarities
and differences in this draft.

Thanks,
Acee