Subject: [OSPF] SPF calculation in OSPF

From: "Navina Balan" <[email-masked]>
Date: Wed, 30 Aug 2006 10:57:24 +0530

Hi all,

I have a doubt in OSPF.

Can you let me know, if Nbr Change occurs, do SPF calculation needs to done
again.

TIA
Swapna
_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: sujay <[email-masked]>
Date: Wed, 30 Aug 2006 14:08:59 +0530

In brief , if the Router LSA or Network LSA changes
the Intra-SPF must be run. 
 
If your Nbr change is causing a Interface State machine change, 
Intra-SPF should be run as the LSA will be regenerated.
 
See Section 12.4 as to when a  Router LSA or Network LSA will 
be generated/changed.
 
Regds,
Sujay G
My Location;
http://maps.google.com/maps?ll=14.626109,76.959229
<http://maps.google.com/maps?ll=14.626109,76.959229&spn=4.724852,7.525085&t=
h&hl=en> &spn=4.724852,7.525085&t=h&hl=en

This e-mail and attachments contain confidential information from HUAWEI,
which is intended only for the person or entity whose address is listed
above. Any use of the information contained herein in any way (including,
but not limited to, total or partial disclosure, reproduction, or
dissemination) by persons other than the intended recipient's) is
prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it! 

  _____  

From: Navina Balan [mailto:[email-masked]] 
Sent: Wednesday, August 30, 2006 10:57 AM
To: [email-masked]
Subject: [OSPF] SPF calculation in OSPF

Hi all,
 
I have a doubt in OSPF.

TIA
Swapna

---

From: "Santosh Esale" <[email-masked]>
Date: Wed, 30 Aug 2006 15:12:10 +0530

---------- Forwarded message ----------
From: Santosh Esale <[email-masked]>
Date: Aug 30, 2006 11:27 AM
Subject: Re: [OSPF] SPF calculation in OSPF
To: Navina Balan <[email-masked]>

 Full spf calclualtion need to run again if there is any change in the
topology of area. If neighbour changes from Full to any of the lower state
or lower state to full state , Router LSA will be regenerated again for this
as well the neighbouring router and DR will regenerate network lsa(in case
of boradcast link) which will result in topology change.

If summary or external LSAs are withdrawn or added, most of the
implementation runs incremental SPF.

Thanks
Santosh

I have a doubt in OSPF.

TIA
Swapna