Subject: [OSPF] WG LC

From: David Ward <[email-masked]>
Date: Sat, 21 Jun 2008 08:56:40 -0500

All -
	We are starting a 2 week WG (isis) LC on this draft:

http://www.ietf.org/internet-drafts/draft-ietf-isis-genapp-01.txt

I've also bcc'ed the OSPF WG for their comments as well. Please have  
all comments to the list by 1700 PST 2008.07.03

-DWard, CHopps
_______________________________________________
OSPF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ospf

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Sun, 22 Jun 2008 22:30:09 -0700

Sujay -

I assume you wanted to copy the WG lists...have added them to the
thread.
Reply inline.

> -----Original Message-----
> From: sujay gupta [mailto:[email-masked]]
> Sent: Sunday, June 22, 2008 10:16 PM
> To: David Ward
> Cc: Les Ginsberg (ginsberg); Mike Shand (mshand); Stefano Previdi
> (sprevidi); Ross Callon
> Subject: Re: [OSPF] WG LC
> 
> 
> HI David,
> 
> A few questions;
> 
> 
> 
> 
>                                         No. of octets
>               +-----------------------+
>               | Flags                 |     1
>               +-----------------------+
> 
>               | Application ID        |     2
>               +-----------------------+
>               | Application           |
>               | IP Address Info       |     0 to 20
>               +-----------------------+
> 
>               | Additional Application|     0 to (252 -
>               |  Specific Information |     len of IP Address info)
>               +-----------------------+
> 
> 
> 
> 
> Why do we need the Application IP address info, field , although you
> specify it could be a zero size element, I believe it is dependent on
the
> Application ID to utilize this space, as a IP address or anything
else.
> One  concern is it is wasting two bits from the flag.
> Could we not better give a note as to the figure is only one possible
> means of using the Gen_TLV. And split the flag into two parts one as
> mandatory and the other subject to interpretation from the Application
ID.
> 
> This approach would address my second concern, if the App-data is
spread
> across TLV's I would prefer to have some sequence number, end of data
bit
> etc. for ease in processing.

The draft clearly indicates that the presence of IPv4/IPv6 address (or
both) is optional. But, if present it should be placed at the position
indicated. Why? Because, as indicated at the end of this section:

"The Application ID in combination with the Application IPv4/IPv6
   Address Information uniquely identifies the GENINFO Application
   Context (GENINFO-CTX)."

As for the use of application specific flag bits, that may be done in
the additional application specific information. The intent is to keep
the standard header free of application specific information.

  Les

> 
> Thanks,
> -Sujay
> 
> 
> 
> 
> 
> 
> On Sat, Jun 21, 2008 at 7:26 PM, David Ward <[email-masked]> wrote:
> 
> 
> 	All -