Subject: [OSPF] [Technical Errata Reported] RFC2328 (3734)

From: RFC Errata System <[email-masked]>
Date: Mon, 23 Sep 2013 20:53:40 -0700 (PDT)

The following errata report has been submitted for RFC2328,
"OSPF Version 2".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=2328&eid=3734

--------------------------------------
Type: Technical
Reported by: Ramakrishna DTV <[email-masked]>

Section: 8.2

Original Text
-------------
            The AuType specified in the packet must match the AuType
            specified for the associated area.

Corrected Text
--------------
            The AuType specified in the packet must match the AuType
            specified for the associated interface.

Notes
-----
In OSPFv2, authentication is configured per interface and not per area.
    Appendix D clarifies this: "The authentication type is configurable on a per-interface
    (or equivalently, on a per-network/subnet) basis."

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC2328 (no draft string recorded)
--------------------------------------
Title               : OSPF Version 2
Publication Date    : April 1998
Author(s)           : J. Moy
Category            : INTERNET STANDARD
Source              : Open Shortest Path First IGP
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Acee Lindem <[email-masked]>
Date: Fri, 27 Sep 2013 01:18:51 +0000

I concur with this errata and would classify it as "editorial. 
Acee

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 27 Sep 2013 12:39:43 +0200

I don't think it was an editorial error, it is technical error,

AB

On 9/24/13, RFC Errata System <[email-masked]> wrote:
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf
>

---

From: Acee Lindem <[email-masked]>
Date: Fri, 27 Sep 2013 13:56:59 +0000

Since area level authentication has been deprecated since RFC 2178, it
would be impossible for this remnant from pre-RFC2178 OSPFv2 to be
misinterpreted. 
Thanks,
Acee

On 9/27/13 3:39 AM, "Abdussalam Baryun" <[email-masked]> wrote:

>>     Appendix D clarifies this: "The authentication type is configurable
>>on a
>> per-interface