Subject: [OSPF] Poll for WG Adoption of "draft-acee-ospfv3-lsa-extend"

From: Acee Lindem <[email-masked]>
Date: Mon, 16 Sep 2013 12:24:39 +0000

This version includes changes in support of backward compatibility. Speaking as both a WG chair and author, this document is essential to OSPFv3 protocol extension. Please indicate your support or objections by September 30th, 2013. 
Thanks,
Acee 

On Sep 10, 2013, at 5:54 PM, <[email-masked]>
 <[email-masked]> wrote:

> 
> A new version of I-D, draft-acee-ospfv3-lsa-extend-02.txt
> has been successfully submitted by Acee Lindem and posted to the
> IETF repository.
> 
> Filename:	 draft-acee-ospfv3-lsa-extend
> Revision:	 02
> Title:		 OSPFv3 LSA Extendibility
> Creation date:	 2013-09-10
> Group:		 Individual Submission
> Number of pages: 29
> URL:             http://www.ietf.org/internet-drafts/draft-acee-ospfv3-lsa-extend-02.txt
> Status:          http://datatracker.ietf.org/doc/draft-acee-ospfv3-lsa-extend
> Htmlized:        http://tools.ietf.org/html/draft-acee-ospfv3-lsa-extend-02
> Diff:            http://www.ietf.org/rfcdiff?url2=draft-acee-ospfv3-lsa-extend-02
> 
> Abstract:
>   OSPFv3 requires functional extension beyond what can readily be done
>   with the fixed-format Link State Advertisement (LSA) as described in
>   RFC 5340.  Without LSA extension, attributes associated with OSPFv3
>   links and advertised IPv6 prefixes must be advertised in separate
>   LSAs and correlated to the fixed-format LSA.  This document extends
>   the LSA format by allowing the optional inclusion of Type-Length-
>   Value (TLV) tuples in the LSAs.  Backward compatibility mechanisms
>   are also described.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: "Russ White" <[email-masked]>
Date: Mon, 16 Sep 2013 08:32:43 -0400

> This version includes changes in support of backward compatibility.
Speaking
> as both a WG chair and author, this document is essential to OSPFv3
protocol
> extension. Please indicate your support or objections by September 30th,
> 2013.

Have read and support. I think this is an important capability for v3 --too
long coming as it is, in fact.

:-)

Russ

---

From: Peter Psenak <[email-masked]>
Date: Mon, 16 Sep 2013 15:13:00 +0200

Hi Acee,

you have my strong support on this one.

thanks,
Peter

On 9/16/13 14:24 , Acee Lindem wrote:
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf
>

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 16 Sep 2013 17:03:28 +0000

Support!

BR,
Huaimo
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Acee Lindem
Sent: Monday, September 16, 2013 8:25 AM
To: OSPF List
Subject: [OSPF] Poll for WG Adoption of "draft-acee-ospfv3-lsa-extend"

On Sep 10, 2013, at 5:54 PM, <[email-masked]>  <[email-masked]> wrote:

> has been successfully submitted by Acee Lindem and posted to the IETF 
> repository.
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 16 Sep 2013 19:10:35 +0000

Support.

Jeffrey

> From: Acee Lindem [mailto:[email-masked]]
> Speaking as both a WG chair and author, this document is essential to
> OSPFv3 protocol extension. Please indicate your support or objections
> by September 30th, 2013.
> Thanks,
> Acee
> 
> submission

---

From: Glen Kent <[email-masked]>
Date: Tue, 17 Sep 2013 15:18:10 +0530

Support.

This draft blurs yet another line of difference between ISIS and OSPF,
where folks from the former camp claimed that their LSPs were TLV encoded
and thus easily extensible, unlike OSPF which was hard encoded.

Glen

On Mon, Sep 16, 2013 at 5:54 PM, Acee Lindem <[email-masked]>wrote:

> OSPFv3 protocol extension. Please indicate your support or objections by
> September 30th, 2013.
> Thanks,
> Acee
>
> > URL:
> http://www.ietf.org/internet-drafts/draft-acee-ospfv3-lsa-extend-02.txt
> > Status:
> http://datatracker.ietf.org/doc/draft-acee-ospfv3-lsa-extend
> > Htmlized:
> http://tools.ietf.org/html/draft-acee-ospfv3-lsa-extend-02
> > Diff:
> http://www.ietf.org/rfcdiff?url2=draft-acee-ospfv3-lsa-extend-02
> >
> > Abstract:

---

From: Anton Smirnov <[email-masked]>
Date: Tue, 17 Sep 2013 14:48:10 +0200

I strongly support this work.
    IMO we need the same work to be done with OSPFv2. Shall it be part 
of this document or work on its own is a separate question.
    Number of I-Ds submitted against OSPFv2 shows that this version of 
the protocol is still being actively worked on and in medium term many 
extensions will have to be simultaneously proposed for v2 and v3. Having 
Extendable LSAs in both protocol versions would greatly simplify 
standardization and development of such extensions.

    I have a few notes on current draft but I do not want to hijack this 
thread for technical discussion and better send another email.

Thanks,

Anton

---

From: Peter Psenak <[email-masked]>
Date: Wed, 18 Sep 2013 09:56:09 +0200

Anton,

> standardization and development of such extensions.

I have posted a similar comment on the list when I started the SR 
extensions for OSPFv2. The consensus at that time was to take the path 
of the complimentary Opaque LSAs rather then redefining existing LSAs 
types. This has been reflected in the 
draft-psenak-ospf-segment-routing-extensions.

thanks,
Peter

> .