Subject: Re: [OSPF] More Comments on OSPF S-BFD Discriminator

From: Manav Bhatia <[email-masked]>
Date: Fri, 6 Nov 2015 08:05:34 +0530

Hi Acee,

Sorry for the late response.

We will add the following text in the next update

“When multiple S-BFD discriminators are advertised how a given
discriminator is mapped to a specific use case is out of scope for this
document.”

Will address the other minor comments in the next rev.

Cheers, Manav

On Mon, Oct 26, 2015 at 5:37 AM, Acee Lindem (acee) <[email-masked]> wrote:

> I have one major comments and I’ve copied Alvaro since he is reviewing the
> base S-BFD drafts.
>
>   If an OSPF router advertises multiple BFD discriminators, how do the
> other OSPF routers in the OSPF routing domain map the S-BFD discriminators
> to the OSPF router IP endpoints and services?
>
> I also have some minor comments:
>
>   1) This draft should reference the RFC 4970BIS draft as this is in RFC
> EDIT state.
>   2) Section 2.1 - The base RFC 4970BIS draft states that unrecognized
> TLVs are ignored (as stated in section 3). This is not specific to this
> TLV.
>   3) Section 2.2 - This says the Opaque ID must be 0. Note that an OSPF
> router can now originate multiple OSPF RI LSAs instances. I think this TLV
> should be allowed in an OSPF RI LSA subsequent to the first.
>   4) Section 2.2 - I don’t think we should advocate sending an empty OSPF
> Router Information LSA. I’d remove this case.
>
>
> Thanks,
> Acee
>
>
>
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 9 Nov 2015 22:24:14 +0000

Hi Manav,

From: Manav Bhatia <[email-masked]<mailto:[email-masked]>>
Date: Friday, November 6, 2015 at 11:35 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Alvaro Retana (aretana)" <[email-masked]<mailto:[email-masked]>>, OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [OSPF] More Comments on OSPF S-BFD Discriminator

Hi Acee,

“When multiple S-BFD discriminators are advertised how a given discriminator is mapped to a specific use case is out of scope for this document.”

I’m still struggling with the utility of automatic discovery of multiple S-BFD discriminators if one has no way to map them to an endpoint or the corresponding service.

Thanks,
Acee

Cheers, Manav

On Mon, Oct 26, 2015 at 5:37 AM, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:
I have one major comments and I’ve copied Alvaro since he is reviewing the
base S-BFD drafts.

Thanks,
Acee

_______________________________________________
OSPF mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ospf

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 9 Nov 2015 23:16:36 +0000

Acee –

While I can understand your struggle as to how to select one S-BFD discriminator from multiple advertised by a given node, I do not understand why you believe the IGPs have a responsibility to address this issue.

At the time both the OSPF and IS-IS S-BFD drafts were first being written this question was raised – and the response was that this was outside the scope of the IGP drafts. We included the ability to advertise multiple discriminators because it was easy to do and future proofed us against unanticipated requirements.  But this does not obligate the IGPs to address the mapping issue. I think Manav’s proposed text is both appropriate and adequate. (Of course I could be biased since the IS-IS draft says the same thing. ☺ )

Please explain what it is that you believe is required and why it should be addressed by the  IGP drafts.

   Les

From: OSPF [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Monday, November 09, 2015 2:24 PM
To: Manav Bhatia
Cc: [email-masked]; OSPF WG List
Subject: Re: [OSPF] More Comments on OSPF S-BFD Discriminator

Hi Manav,

Hi Acee,

Thanks,
Acee

Cheers, Manav

Thanks,
Acee

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 10 Nov 2015 00:08:03 +0000

Hi Les,

From: "Les Ginsberg (ginsberg)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, November 10, 2015 at 8:16 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, Manav Bhatia <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: RE: [OSPF] More Comments on OSPF S-BFD Discriminator

Acee –

It is hard for me to see the benefit of advertising the S-BFD discriminators and learning them dynamically if you have to map them a specific service outside the protocol anyway. Even if you come up with a scheme of using separate ranges of discriminators per application, you still would have to map them an IP address endpoint if you are using more than one.

Anyway, this is good discussion as the same questions will undoubted come up during IESG review and it is better to address them now.

Thanks,
Acee

   Les

From: OSPF [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Monday, November 09, 2015 2:24 PM
To: Manav Bhatia
Cc: [email-masked]<mailto:[email-masked]>; OSPF WG List
Subject: Re: [OSPF] More Comments on OSPF S-BFD Discriminator

Hi Manav,

Hi Acee,

Thanks,
Acee

Cheers, Manav

Thanks,
Acee

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Tue, 10 Nov 2015 00:38:53 +0000

Acee -

From: Acee Lindem (acee)
Sent: Monday, November 09, 2015 4:08 PM
To: Les Ginsberg (ginsberg); Manav Bhatia
Cc: [email-masked]; OSPF WG List
Subject: Re: [OSPF] More Comments on OSPF S-BFD Discriminator

Hi Les,

Acee –

[Les:] Well, S-BFD discriminator is not necessarily mapped to a single IP endpoint. See  https://www.ietf.org/id/draft-ietf-bfd-seamless-base-05.txt  Section 5:

“Note that incoming S-BFD control packets may be IPv4, IPv6 or MPLS
   based.  How such S-BFD control packets reach an appropriate reflector
   BFD session is also a local matter, and is outside the scope of this
   document.”

I really don’t know why you think this discussion (interesting though it may be) has anything to do w the IGP drafts who are simply advertising values that BFD has asked them to advertise. It might be more appropriate in the review of the S-BFD base draft – but I think it is inappropriate in the review of the IGP drafts.

   Les

Thanks,
Acee

   Les

Hi Manav,

Hi Acee,

Thanks,
Acee

Cheers, Manav

Thanks,
Acee

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 11 Nov 2015 21:16:22 +0000

Hi Les, Manav,

Date: Tuesday, November 10, 2015 at 9:38 AM

Acee -

From: Acee Lindem (acee)

Hi Les,

Acee –

I was more concerned about the consumer of the information than the IGPs. I did look at base S-BFD draft and I agree this unspecified. Let’s go forward than with the proposed text and I will request publication.

Thanks,
Acee

   Les

Thanks,
Acee

   Les

Hi Manav,

Hi Acee,

Thanks,
Acee

Cheers, Manav

Thanks,
Acee