Subject: Re: [OSPF] OSPFv2 SR draft

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 29 Sep 2016 15:50:28 +0000

Speaking as WG Co-Chair:

Hi Chris, Les, Peter,

So, is there anything preventing us from requesting publication of the
OSPFv2 Segment Routing draft?

Thanks,
Acee

On 8/25/16, 11:00 AM, "OSPF on behalf of Chris Bowers"
<[email-masked] on behalf of [email-masked]> wrote:

>Les and Peter,
>
>I have also been pursuing the approach you suggest.
>
>The following request to clarify draft-ietf-spring-segment-routing-09 on
>this topic was sent on  Aug. 3rd.
>
>https://www.ietf.org/mail-archive/web/spring/current/msg02273.html
>
>Hopefully, we can get closure on these clarifications soon.
>
>Thanks,
>Chris
>
>
>-----Original Message-----
>From: Les Ginsberg (ginsberg) [mailto:[email-masked]]
>Sent: Thursday, August 25, 2016 9:32 AM
>To: Peter Psenak (ppsenak) <[email-masked]>; Chris Bowers
><[email-masked]>; OSPF List <[email-masked]>
>Subject: RE: [OSPF] OSPFv2 SR draft
>
>Chris/Peter -
>
>> -----Original Message-----
>> From: OSPF [mailto:[email-masked]] On Behalf Of Peter Psenak
>> (ppsenak)
>> Sent: Thursday, August 25, 2016 1:45 AM
>> To: Chris Bowers; OSPF List
>> Subject: Re: [OSPF] OSPFv2 SR draft
>> 
>> Hi Chris,
>> 
>> On 24/08/16 20:31 , Chris Bowers wrote:
>> > Peter,
>> >
>> > The text that you propose corresponds to part of the text that I
>> > proposed,
>> and it seems good to me.
>> >
>> > However, the last sentence of the text that I proposed in not
>>addressed.
>> > ------
>> > If router B does not advertise the
>> > SR-Algorithm TLV for algorithm X, then other routers should not
>> > forward traffic destined for a prefix-SID for algorithm X advertised
>> > by some router D using a path that would require router B to forward
>> > traffic using algorithm X.
>> > ------
>> > Is this an oversight?
>> 
>> not that I disagree with the statement that you want to add.
>> 
>> The question is whether that belongs to the IGP SR draft, or whether
>> that should be specified in a different draft.
>> 
>> There is already some text regarding the forwarding for a SR algorithm
>> in draft-ietf-spring-segment-routing section 3.2.1., which may not be
>> aligned with what you have in mind:
>> 
>>    "The ingress node of an SR domain validates that the path to a
>>prefix,
>>     advertised with a given algorithm, includes nodes all supporting the
>>     advertised algorithm.  In other words, when computing paths for a
>>     given algorithm, the transit nodes MUST compute the algorithm X on
>>     the IGP topology, regardless of the support of the algorithm X by
>>the
>>     nodes in that topology.  As a consequence, if a node on the path
>>does
>>     not support algorithm X, the IGP-Prefix segment will be interrupted
>>     and will drop packet on that node.  It's the responsibility of the
>>     ingress node using a segment to check that all downstream nodes
>>     support the algorithm of the segment."
>> 
>> Maybe we should add/modify the text in
>> draft-ietf-spring-segment-routing section 3.2.1, rather then adding
>>anything to the OSPF/ISIS SR drafts.
>> 
>[Les:] I strongly agree with this approach. If one wants to understand
>how the MPLS dataplane works with SR then the following documents are
>relevant:
>
>https://www.ietf.org/id/draft-ietf-spring-segment-routing-09.txt
>https://www.ietf.org/id/draft-ietf-spring-segment-routing-mpls-05.txt
>https://www.ietf.org/id/draft-ietf-spring-segment-routing-ldp-interop-04.t
>xt
>
>References to these documents can be included in the IGP drafts - but we
>should not try to repurpose the IGP drafts to cover material which is
>covered far more completely in the above drafts.
>
>If you feel there is something which needs to be added/revised to any of
>the above drafts to more accurately explain algorithm specific forwarding
>please make the comment in the context of one of those drafts.
>
>   Les
>
>> thanks,
>> Peter
>> 
>> >
>> > Thanks,
>> > Chris
>> >
>> >
>> > -----Original Message-----
>> > From: Peter Psenak [mailto:[email-masked]]
>> > Sent: Monday, August 22, 2016 2:32 AM
>> > To: Chris Bowers <[email-masked]>; OSPF List <[email-masked]>
>> > Subject: Re: [OSPF] OSPFv2 SR draft
>> >
>> > Chris,
>> >
>> > what about this to be added in the Section 3.1:
>> >
>> >
>> > "A router receiving a Prefix-SID (defined in section 5) from a
>> > remote node
>> and with an SR algorithm value that such remote node has not
>> advertised in the SR-Algorithm sub-TLV MUST ignore the Prefix-SID
>>sub-TLV."
>> >
>> > thanks,
>> > Peter
>> >
>> >
>> > On 19/08/16 23:33 , Chris Bowers wrote:
>> >> Peter,
>> >>
>> >> Please share the updated text that you plan to use with the WG,
>> >> since this
>> is a reasonably significant clarification.
>> >>
>> >> Thanks,
>> >> Chris
>> >>
>> >> -----Original Message-----
>> >> From: Peter Psenak [mailto:[email-masked]]
>> >> Sent: Tuesday, August 16, 2016 10:02 AM
>> >> To: Chris Bowers <[email-masked]>; OSPF List <[email-masked]>
>> >> Subject: Re: [OSPF] OSPFv2 SR draft
>> >>
>> >> Hi Chris,
>> >>
>> >> I'll update the draft along those lines.
>> >>
>> >> thanks,
>> >> Peter
>> >>
>> >>
>> >> On 16/08/16 16:02 , Chris Bowers wrote:
>> >>> Peter,
>> >>>
>> >>> I suggest changing the paragraph to read as below to make this
>>clearer.
>> >>>
>> >>> =====
>> >>>       The SR-Algorithm Sub-TLV is optional.  It MAY only be
>>advertised once
>> >>>       in the Router Information Opaque LSA.  If the SID/Label Range
>>TLV, as
>> >>>       defined in Section 3.2, is advertised, then the SR-Algorithm
>>TLV MUST
>> >>>       also be advertised.  If a router C advertises a Prefix-SID
>> >>> sub-TLV for
>> algorithm X
>> >>>       but does not advertise the SR-Algorithm Sub-TLV with
>> >>> algorithm X,
>> then
>> >>>       a router receiving that advertisement MUST ignore the
>>Prefix-SID
>> >>>       advertisement from router C.  If router B does not advertise
>>the
>> >>>       SR-Algorithm TLV for algorithm X, then other routers should
>>not
>> >>>       forward traffic destined for a prefix-SID for algorithm X
>>advertised by
>> >>>       some router D using a path that would require router B to
>> >>> forward
>> traffic using
>> >>>       algorithm X.
>> >>> =====
>> >>>
>> >>> Thanks,
>> >>> Chris
>> >>>
>> >>>
>> >>>
>> >>> -----Original Message-----
>> >>> From: Peter Psenak [mailto:[email-masked]]
>> >>> Sent: Monday, August 15, 2016 6:40 AM
>> >>> To: Chris Bowers <[email-masked]>; OSPF List <[email-masked]>
>> >>> Subject: Re: [OSPF] OSPFv2 SR draft
>> >>>
>> >>> Hi Chris,
>> >>>
>> >>> sorry for the delay, I was on PTO during last two weeks.
>> >>> Please see inline:
>> >>>
>> >>> On 03/08/16 16:45 , Chris Bowers wrote:
>> >>>> Peter,
>> >>>>
>> >>>> Taking a looking at the whole paragraph into this sentence was
>> >>>> added, I am not sure how to interpret it.
>> >>>>
>> >>>>        The SR-Algorithm Sub-TLV is optional.  It MAY only be
>> >>>> advertised
>> once
>> >>>>        in the Router Information Opaque LSA.  If the SID/Label
>> >>>> Range TLV,
>> as
>> >>>>        defined in Section 3.2, is advertised, then the
>> >>>> SR-Algorithm TLV
>> MUST
>> >>>>        also be advertised.  If the SR-Algorithm TLV is not
>>advertised by the
>> >>>>        node, such node is considered as not being segment routing
>> capable.
>> >>>>
>> >>>> Is this sentence intended to imply that if a router does not
>> >>>> advertise the SR-Algorithm TLV including algorithm X, then any
>> >>>> prefix-SIDs for algorithm X advertised by that router will be
>> >>>> ignored by
>> other routers?
>> >>>
>> >>> in OSPF we do not have the SR capability TLV. We use SR-Algorithm
>> >>> TLV for that purpose. So if a router does not advertise the
>> >>> SR-Algorithm TLV for algorithm X, other routers should not send
>> >>> any SR traffic using SIDs that were advertised for algorithm X.
>> >>>
>> >>> If the router does not advertise any SR Algorithm TLV, then the
>> >>> node is not SR capable and no SR traffic should be forwarded to
>>such a node.
>> >>>
>> >>> thanks,
>> >>> Peter
>> >>>
>> >>>
>> >>>>
>> >>>> If this is the intention, then it would be better to state is
>> >>>> more
>> explicitly.
>> >>>>
>> >>>> If not, then the intended meaning should be clarified.
>> >>>>
>> >>>> Thanks,
>> >>>> Chris
>> >>>>
>> >>>>
>> >>>> -----Original Message-----
>> >>>> From: OSPF [mailto:[email-masked]] On Behalf Of Peter
>> >>>> Psenak
>> >>>> Sent: Friday, July 22, 2016 3:30 AM
>> >>>> To: OSPF List <[email-masked]>
>> >>>> Subject: [OSPF] OSPFv2 SR draft
>> >>>>
>> >>>> Hi All,
>> >>>>
>> >>>> following text has been added in the latest revision of the
>> >>>> OSPFv2 SR draft, section 3.1.
>> >>>>
>> >>>> "If the SR-Algorithm TLV is not advertised by node, such node is
>> >>>> considered as not being segment routing capable."
>> >>>>
>> >>>> Please let us know if there are any concerns regarding this
>>addition.
>> >>>>
>> >>>> thanks,
>> >>>> Peter
>> >>>>
>> >>>> _______________________________________________
>> >>>> OSPF mailing list
>> >>>> [email-masked]
>> >>>> https://www.ietf.org/mailman/listinfo/ospf
>> >>>> .
>> >>>>
>> >>>
>> >>> .
>> >>>
>> >>
>> >> .
>> >>
>> >
>> > .
>> >
>> 
>> _______________________________________________
>> OSPF mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/ospf
>
>_______________________________________________
>OSPF mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ospf

---

From: Chris Bowers <[email-masked]>
Date: Thu, 29 Sep 2016 16:00:10 +0000

I would like to see actual textual updates in the form of new revisions for the clarifications that have been proposed for both draft-ietf-ospf-segment-routing-extensions and draft-ietf-spring-segment-routing so that we know exactly what text we are agreeing on.

Chris

-----Original Message-----
From: Acee Lindem (acee) [mailto:[email-masked]] 
Sent: Thursday, September 29, 2016 10:50 AM
To: Chris Bowers <[email-masked]>; Les Ginsberg (ginsberg) <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>; OSPF List <[email-masked]>
Subject: Re: [OSPF] OSPFv2 SR draft

Speaking as WG Co-Chair:

Hi Chris, Les, Peter,

Thanks,
Acee

On 8/25/16, 11:00 AM, "OSPF on behalf of Chris Bowers"
<[email-masked] on behalf of [email-masked]> wrote:

>The following request to clarify draft-ietf-spring-segment-routing-09 
>on this topic was sent on  Aug. 3rd.
>
>> > advertised by some router D using a path that would require router 
>> > B to forward traffic using algorithm X.
>> > ------
>> > Is this an oversight?
>> 
>> There is already some text regarding the forwarding for a SR 
>> algorithm in draft-ietf-spring-segment-routing section 3.2.1., which 
>> may not be aligned with what you have in mind:
>> 
>References to these documents can be included in the IGP drafts - but 
>we should not try to repurpose the IGP drafts to cover material which 
>is covered far more completely in the above drafts.
>
>If you feel there is something which needs to be added/revised to any 
>of the above drafts to more accurately explain algorithm specific 
>forwarding please make the comment in the context of one of those drafts.
>
>   Les
>
>> thanks,
>> Peter
>> 
>> >
>> > Thanks,
>> > Chris
>> >
>> >
>> >>> Range
>> >>> SR-Algorithm

---

From: Acee Lindem <[email-masked]>
Date: Thu, 29 Sep 2016 12:04:17 -0400

Aren’t the text changes restricted to draft-ietf-spring-segment-routing? 

Acee 
> On Sep 29, 2016, at 12:00 PM, Chris Bowers <[email-masked]> wrote:
>

---

From: Chris Bowers <[email-masked]>
Date: Thu, 29 Sep 2016 16:29:55 +0000

No. I don’t think that draft-ietf-ospf-segment-routing-extensions-09 represents the most up-to-date text.

draft-ietf-ospf-segment-routing-extensions-09 was published on July 6th.  The changes to draft-ietf-ospf-segment-routing-extensions proposed in the thread below were discussed in late July and August.  

Chris

-----Original Message-----
From: Acee Lindem [mailto:[email-masked]] 
Sent: Thursday, September 29, 2016 11:04 AM
To: Chris Bowers <[email-masked]>
Cc: Acee Lindem (acee) <[email-masked]>; Les Ginsberg (ginsberg) <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>; OSPF List <[email-masked]>
Subject: Re: [OSPF] OSPFv2 SR draft

Acee 
> To: Chris Bowers <[email-masked]>; Les Ginsberg (ginsberg) 
> <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>; OSPF 
> List <[email-masked]>
>> [Les:] I strongly agree with this approach. If one wants to 
>> understand how the MPLS dataplane works with SR then the following 
>> documents are
>> relevant:
>> 
>> https://www.ietf.org/id/draft-ietf-spring-segment-routing-ldp-interop
>> -0
>> 4.t
>> xt
>>