Subject: Re: [p2pi] New version of the problem statement

From: Laird Popkin <[email-masked]>
Date: Mon, 30 Jun 2008 17:00:39 -0400 (EDT)

Responding to

"> 1. The popular metrics used by P2P applications are based on obtained
> goodput, not RTT.  This doesn't ignore bitrate and reliability -- if
> it did, P2P would work much worse than it does today.  It ignores cost
> and desires of the ISP, which is the problem ALTO needs to solve.

Well, I guess you are right.  Here we probably messed up with
coordinate-based systems described in literature, which are sometimes
used before actually starting transmissions.  We will fix this in the
next version."

I think that it's important for ALTO to provide guidance before starting transmissions. In fact, I'd suggest that once transmission is started, the p2p networks won't benefit too much from ALTO, because they will prefer to use the actual measured throughput to optimize p2p transfers rather than guidance.

I think that the biggest "win" for ALSO is in picking good peers from a large potential pool of peers to form the initial connections.

I think of it as a time savings issue. Imagine, for example, that I'm downloading from a swarm with 10,000 peers in it. How long it will take me to connect to the closest peer? If I find out about 50 new peers every minute (i.e. announce, get response, connect to all new peers, move data, measure throughput), it will take me 138 minutes to have a 50% chance of finding the closest peer. But if I have accurate guidance about which peers are near me, I connect to the closest peer on the first announce. So the download is likely to be faster sooner with network guidance than without.

Looking at getting guidance related to the 50 peers that I know about, there's some savings in being told which of the 50 are closest, but it's less dramatic a win because it doesn't take me terribly long to connect to all 50 peers and measure actual throughput.

(Note: I made some simplifying assumptions above. For example, it may not always be the case that the closest peer is the best data source (though it seems to be generally true in the P4P tests, there are obvious exceptions, such as people on a DSL provider who are better off connecting to a fiber provider's customers than other DSL customers). And while most swarms' peer discovery and measurement isn't 50 per minute (so that number is optimistic) I also ignored Peer Exchange, which will help speed things up. But I think that the basic idea stands. :-)

- Laird Popkin, CTO, Pando Networks
  mobile: 646/465-0570
_______________________________________________
p2pi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2pi

---

From: Stanislav Shalunov <[email-masked]>
Date: Mon, 30 Jun 2008 15:08:40 -0700

On Jun 30, 2008, at 2:00 PM, Laird Popkin wrote:
> I think that it's important for ALTO to provide guidance before  
> starting transmissions. In fact, I'd suggest that once transmission  
> is started, the p2p networks won't benefit too much from ALTO,  
> because they will prefer to use the actual measured throughput to  
> optimize p2p transfers rather than guidance.

Good point.

-- 
Stanislav Shalunov
http://shlang.com