Subject: AW: [P2Prg] considerations for mobile peers - GPRS

From: Andersen Frank-Uwe <[email-masked]>
Date: Fri, 11 Jul 2003 13:36:45 +0200

Hi,

I cannot help you very much there, but we (+this group?) would be interested in knowing whether you are planning to run unmodified p2p clients over cellular links or if you plan to use specially adapted software / algorithms.

Btw.: In the proceedings of the "2nd International Conference on Peer-to-Peer Computing (P2P 2002)", there is a contribution named "A Distributed Search Service for Peer-to-Peer File Sharing in Mobile Applications".

Has anyone seen/read this contribution and could rate it?

Regards,

Frank-Uwe Andersen

> -----Ursprungliche Nachricht-----
> Von: Carlos Alberto Kamienski [mailto:[email-masked]]
> Gesendet: Donnerstag, 10. Juli 2003 11:54
> An: Andersen Frank-Uwe
> Cc: [email-masked]'; Djamel Sadok
> Betreff: Re: [P2Prg] considerations for mobile peers - GPRS
> 
> 
> Hi Frank-Uwe (and all),
> 
> Have you (someone) ever worked with p2p applications in 
> mobile stations
> using GPRS? We are just starting to work with p2p+gprs and 
> would be very
> pleased to get hints and pointers to previous experiences.
> 
> Thank you,
> 
> Carlos Kamienski
> 
> 
> > Hi,
> >
> > I am working in a think-tank like department of a mobile 
> network manufacturer. Having worked on the design of e.g. 
> "mobile portals", WAP systems and the like, I recognized the 
> p2p "wave" for quite some time, but we couldn't figure out 
> how this would affect mobile devices using, for example, 
> third generation (or beyond) mobile systems.
> >
> > One of the main obstacle is, in our point of view, the 
> bandwidth consumption for search algorithms that occurs even 
> for passive participants of most p2p networks. To be more 
> precise: running today's p2p clients on mobile phones is just 
> not feasible for several reasons (simple pricing is one of them).
> >
> > This is why we are most interested in modified search 
> algorithms as well as bandwidth limited/optimized distributed 
> storage systems for mobile peers.
> >
> > Hence, may we suggest to the group to bear in mind these 
> special requirements for mobile systems for the upcoming work.
> >
> >
> > Regards,
> >
> > Frank-Uwe Andersen
> >
> > _______________________________________________
> > P2prg mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/p2prg
> >
> 
> 

_______________________________________________
P2prg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2prg

---

From: Jeffrey Altman <[email-masked]>
Date: Fri, 11 Jul 2003 11:25:05 -0400

I personally do not see a pure-P2P application model on mobile phones in 
the near term if only because of the pricing model, bandwidth costs, and 
memory requirements.  However, it seems to me that a P2P proxy model 
does work quite well where the mobile provider supports a proxy for each 
mobile device on the network.  The search algorithms would be performed 
against the proxy not against the mobile device thereby saving the costs 
of bandwidth and reducing the mobile device memory requirements.  Mobile 
proxies would also be 24/7 allowing communications to occur even when 
the mobile device is not immediately accessible.

Jeffrey Altman

---

From: Jeffrey Altman <[email-masked]>
Date: Fri, 11 Jul 2003 11:25:05 -0400

Jeffrey Altman

---

From: Mauricio Arango <[email-masked]>
Date: Fri, 11 Jul 2003 14:24:58 -0400

I think mobile devices and applications could be one of the major
business drivers for P2P technology and therefore support the input
from Frank-Uwe regarding the need to keep in mind the requirements
for mobile systems.

In some cases applications may be running in a mobile device and in
some cases not, both have advantages and disadvantages. In either
case these applications would be peer systems. Jeff's point is well
taken, however I think we need to assume an architecture scenario
where one main reason to care for P2P is that the number of users
and their applications is growing exponentially, independent of whether
they run on a mobile device or a proxy. These applications need to
find each other and exchange information.

Mauricio

Jeffrey Altman wrote:

> I personally do not see a pure-P2P application model on mobile phones
> in the near term if only because of the pricing model, bandwidth
> costs, and memory requirements.  However, it seems to me that a P2P
> proxy model does work quite well where the mobile provider supports a
> proxy for each mobile device on the network.  The search algorithms
> would be performed against the proxy not against the mobile device
> thereby saving the costs of bandwidth and reducing the mobile device
> memory requirements.  Mobile proxies would also be 24/7 allowing
> communications to occur even when the mobile device is not immediately
> accessible.
>
> Jeffrey Altman
>
>
>
>> I cannot help you very much there, but we (+this group?) would be
>> interested in knowing whether you are planning to run unmodified p2p
>> clients over cellular links or if you plan to use specially adapted
>> software / algorithms.
>>
>> Btw.: In the proceedings of the "2nd International Conference on
>> Peer-to-Peer Computing (P2P 2002)", there is a contribution named "A
>> Distributed Search Service for Peer-to-Peer File Sharing in Mobile
>> Applications".
>>

---

From: Mauricio Arango <[email-masked]>
Date: Fri, 11 Jul 2003 14:24:58 -0400

Mauricio

---

From: "C. Wegrzyn" <[email-masked]>
Date: Fri, 11 Jul 2003 17:51:21 -0400

Hi. I can tell you I my secure P2P platform on a Zaurus with OpenZaurus 
and a GPRS card - and I can tell you it works fine. I also use the 
program on a iPAQ with the same setup. While I am careful not to send 
"large files" or receive them I will tell you all this works. Now I am 
not sure I would want to use a phone keypad to do anything useful.  BTW 
I also use SIP to communicate with it!

Chuck

---

From: "C. Wegrzyn" <[email-masked]>
Date: Fri, 11 Jul 2003 17:51:21 -0400

Chuck