Subject: AW: [P2Prg] considerations for mobile peers - GPRS

From: Andersen Frank-Uwe <[email-masked]>
Date: Fri, 11 Jul 2003 13:36:45 +0200

Hi,

I cannot help you very much there, but we (+this group?) would be interested in knowing whether you are planning to run unmodified p2p clients over cellular links or if you plan to use specially adapted software / algorithms.

Btw.: In the proceedings of the "2nd International Conference on Peer-to-Peer Computing (P2P 2002)", there is a contribution named "A Distributed Search Service for Peer-to-Peer File Sharing in Mobile Applications".

Has anyone seen/read this contribution and could rate it?

Regards,

Frank-Uwe Andersen

> -----Ursprungliche Nachricht-----
> Von: Carlos Alberto Kamienski [mailto:[email-masked]]
> Gesendet: Donnerstag, 10. Juli 2003 11:54
> An: Andersen Frank-Uwe
> Cc: [email-masked]'; Djamel Sadok
> Betreff: Re: [P2Prg] considerations for mobile peers - GPRS
> 
> 
> Hi Frank-Uwe (and all),
> 
> Have you (someone) ever worked with p2p applications in 
> mobile stations
> using GPRS? We are just starting to work with p2p+gprs and 
> would be very
> pleased to get hints and pointers to previous experiences.
> 
> Thank you,
> 
> Carlos Kamienski
> 
> 
> > Hi,
> >
> > I am working in a think-tank like department of a mobile 
> network manufacturer. Having worked on the design of e.g. 
> "mobile portals", WAP systems and the like, I recognized the 
> p2p "wave" for quite some time, but we couldn't figure out 
> how this would affect mobile devices using, for example, 
> third generation (or beyond) mobile systems.
> >
> > One of the main obstacle is, in our point of view, the 
> bandwidth consumption for search algorithms that occurs even 
> for passive participants of most p2p networks. To be more 
> precise: running today's p2p clients on mobile phones is just 
> not feasible for several reasons (simple pricing is one of them).
> >
> > This is why we are most interested in modified search 
> algorithms as well as bandwidth limited/optimized distributed 
> storage systems for mobile peers.
> >
> > Hence, may we suggest to the group to bear in mind these 
> special requirements for mobile systems for the upcoming work.
> >
> >
> > Regards,
> >
> > Frank-Uwe Andersen
> >
> > _______________________________________________
> > P2prg mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/p2prg
> >
> 
> 

_______________________________________________
P2prg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2prg

---

From: Andersen Frank-Uwe <[email-masked]>
Date: Mon, 14 Jul 2003 14:15:43 +0200

Hello Chuck,

I appreciate the information you provided on your secure p2p platform / zaurus / gprs combination. For a short moment, it made me think "wow, there seems to be nothing left to research because everything is solved already". However, I would like to make sure that we have the same understanding of the p2p client functionality. I have to admit not to be technically acquainted with your platform, but two questions seem to be justified from my point of view:
- what amount of bandwidth did the (permanent?) p2p resource/information search data stream take in your test setup?
- what amount of bandwidth did the (permanent?) p2p self-organization-related data stream take in your test setup?

The existence of such data streams, as well as the bandwidth that is dedicated to them is, in my personal opinion, a key differentiating factor for p2p systems.

Thank you & regards,

Frank-Uwe

- 

> -----Ursprüngliche Nachricht-----
> Von: C. Wegrzyn [mailto:[email-masked]]
> Gesendet: Freitag, 11. Juli 2003 23:51
> An: [email-masked]'
> Cc: Andersen Frank-Uwe; 'Carlos Alberto Kamienski'
> Betreff: Re: AW: [P2Prg] considerations for mobile peers - GPRS
> 
> 
> Hi. I can tell you I my secure P2P platform on a Zaurus with 
> OpenZaurus 
> and a GPRS card - and I can tell you it works fine. I also use the 
> program on a iPAQ with the same setup. While I am careful not to send 
> "large files" or receive them I will tell you all this works. 
> Now I am 
> not sure I would want to use a phone keypad to do anything 
> useful.  BTW 
> I also use SIP to communicate with it!
> 
> Chuck
> 
> Jeffrey Altman wrote:
> 
> > I personally do not see a pure-P2P application model on 
> mobile phones 
> > in the near term if only because of the pricing model, bandwidth 
> > costs, and memory requirements.  However, it seems to me that a P2P 
> > proxy model does work quite well where the mobile provider 
> supports a 
> > proxy for each mobile device on the network.  The search algorithms 
> > would be performed against the proxy not against the mobile device 
> > thereby saving the costs of bandwidth and reducing the 
> mobile device 
> > memory requirements.  Mobile proxies would also be 24/7 allowing 
> > communications to occur even when the mobile device is not 
> immediately 
> > accessible.
> >
> > Jeffrey Altman
> >
> >
> >
> > Andersen Frank-Uwe wrote:
> >
> >>Hi,
> >>
> >>I cannot help you very much there, but we (+this group?) 
> would be interested in knowing whether you are planning to 
> run unmodified p2p clients over cellular links or if you plan 
> to use specially adapted software / algorithms.
> >>
> >>Btw.: In the proceedings of the "2nd International 
> Conference on Peer-to-Peer Computing (P2P 2002)", there is a 
> contribution named "A Distributed Search Service for 
> Peer-to-Peer File Sharing in Mobile Applications".
> >>