Subject: RE: [P2Prg] RE:MANETS and P2P

From: [email-masked]
Date: Mon, 11 Aug 2003 17:26:12 +0100

I'm not sure that DHTs and MANETS have a very good fit. 

This is because DHTs generally require that every node can address every
other node, in principle. In a MANET direct addressing is only possible
for individuals within broadcast range of each other, which may or may
not be the individuals to whom you need to forward your message for DHT
routing.

Many design problems are in common between the two cases, and perhaps
APIs could converge in some respects. At least in the case of lookup, I
think the implementation details of the two cases force the solutions to
diverge, sorry.

Keen to hear if you've found a way round this, though ;) We could try it
out with  SWAN (our hash-based routing mechanism,  see
http://www.cefn.com/cefn/index.php?inventor), and the MANET simulator we
have.

Cefn
http://www.cefn.com

-----Original Message-----
From: Ayyasamy, Senthilkumar (UMKC-Student) [mailto:[email-masked]] 
Sent: 11 August 2003 10:44
To: Thorsten Strufe; Bill Yeager
Cc: p2prg
Subject: [P2Prg] RE:MANETS and P2P

>The people researching mobile ad-hoc networks (manets)
>actually have done quite some work, which might be of 
>interest.

The people researching peer to peer networks (P2P) actually 
have done quite some work, which might be of interest.

MANETS, in its present form, suffer from scalability problems 
(number of nodes.) Also, don't seem to provide a better open interface
for many server-side applications (like hosting a 
web server etc..)

Since, the assumptions behind P2P and MANET seems closer (like 
node flux, decentralization, auto-configuration), MANETS can 
use DHTs for scaling to large number of nodes and use generic APIs for
creating diverse applications. 

so, what MANETS have to offer for P2P? 

_______________________________________________
P2prg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2prg

_______________________________________________
P2prg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2prg

---

From: "cjwu" <[email-masked]>
Date: Thu, 21 Aug 2003 14:41:34 +0800

I consider that MANETs is a special case is P2P overlay

In the multi-hop MANETs, any node need neighbors to forward the packets.
A node only know the neighbor nodes, not all node in this MANETs.
In peer-to-peer overlay, it is very difficult for a node knows all nodes in
this overlay. (but, a paper assume that it is work [1])
So that a node in p2p routing table is limited...

[1]
One Hop Lookups for Peer-to-Peer Overlays [ pdf | ps ]
Anjali Gupta, Barbara Liskov, Rodrigo Rodrigues.
Workshop on Hot Topics in Operating Systems (HotOS IX), Lihue, Hawai, May
2003.

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>;
<[email-masked]>
Cc: <>
Sent: Tuesday, August 12, 2003 12:26 AM
Subject: RE: [P2Prg] RE:MANETS and P2P

[email-masked]

---

From: "cjwu" <[email-masked]>
Date: Thu, 21 Aug 2003 14:45:10 +0800

I consider that MANETs is a special case is P2P overlay.

In the multi-hop MANETs, any node need neighbors to forward packets.

[1]
"One Hop Lookups for Peer-to-Peer Overlays"
Anjali Gupta, Barbara Liskov, Rodrigo Rodrigues.
Workshop on Hot Topics in Operating Systems (HotOS IX), Lihue, Hawai, May
2003.

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>;
<[email-masked]>
Cc: <>