Subject: [P2Prg] RE:MANETS and P2P

From: "Ayyasamy, Senthilkumar \(UMKC-Student\)" <[email-masked]>
Date: Mon, 11 Aug 2003 04:43:39 -0500

>The people researching mobile ad-hoc networks (manets) 
>actually have done quite some work, which might be of 
>interest.

The people researching peer to peer networks (P2P) actually 
have done quite some work, which might be of interest.

MANETS, in its present form, suffer from scalability problems 
(number of nodes.) Also, don't seem to provide a better open
interface for many server-side applications (like hosting a 
web server etc..)

Since, the assumptions behind P2P and MANET seems closer (like 
node flux, decentralization, auto-configuration), MANETS can 
use DHTs for scaling to large number of nodes and use generic
APIs for creating diverse applications. 

so, what MANETS have to offer for P2P? 

_______________________________________________
P2prg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2prg

---

From: Kuldipsingh Pabla <[email-masked]>
Date: Tue, 12 Aug 2003 15:49:27 -0700

Other reason for MANET to be not highly scalable is that MANET is designed and optimized for the WiFi(or RF) devices. These devices drain more battery power while transmitting messages to other devices. Considering the fact, the MANET algorithms have tried to minimize the transmission of messages while routing packets.

More over, MANET is for pure ad hoc networks.

-Kuldeep

Subject: RE: [P2Prg] RE:MANETS and P2P
From: [email-masked]
To: [email-masked], [email-masked], [email-masked]
Cc: [email-masked]
Date: Mon, 11 Aug 2003 17:26:12 +0100
List-Id: Peer-to-Peer Research Group <p2prg.ietf.org>

I'm not sure that DHTs and MANETS have a very good fit. 

This is because DHTs generally require that every node can address every
other node, in principle. In a MANET direct addressing is only possible
for individuals within broadcast range of each other, which may or may
not be the individuals to whom you need to forward your message for DHT
routing.

Many design problems are in common between the two cases, and perhaps
APIs could converge in some respects. At least in the case of lookup, I
think the implementation details of the two cases force the solutions to
diverge, sorry.

Keen to hear if you've found a way round this, though ;) We could try it
out with  SWAN (our hash-based routing mechanism,  see
http://www.cefn.com/cefn/index.php?inventor), and the MANET simulator we
have.

Cefn
http://www.cefn.com

-----Original Message-----
From: Ayyasamy, Senthilkumar (UMKC-Student) [mailto:[email-masked]] 
Sent: 11 August 2003 10:44
To: Thorsten Strufe; Bill Yeager
Cc: p2prg
Subject: [P2Prg] RE:MANETS and P2P

MANETS, in its present form, suffer from scalability problems 
(number of nodes.) Also, don't seem to provide a better open interface
for many server-side applications (like hosting a 
web server etc..)

Since, the assumptions behind P2P and MANET seems closer (like 
node flux, decentralization, auto-configuration), MANETS can 
use DHTs for scaling to large number of nodes and use generic APIs for
creating diverse applications.

---

From: "Ayyasamy, Senthilkumar \(UMKC-Student\)" <[email-masked]>
Date: Sat, 23 Aug 2003 00:35:59 -0500

>	Now, what makes me wonder is why there's no word
>about LANMAR on MANET WG site - looks like they had it
>in mind at some point to move it into IRTF, but I cannot
>find it in IRTF list, either.
 
 A lot of criteria goes in while standardizing a protocol
in IETF: representative implementations, operational 
consideration, vendor support and relevance to practical 
world. In that aspect, AODV/DSR/OLSR routing protocols 
seems way ahead in MANET WG (although, the WG is bit
slow as no pressurizing market demand.) LANMAR is available
as individual submission. 

>	Which is kinda surprising given the scalability of
>the LANMAR-related approaches - say, maybe it would make
>sense to somehow integrate such MANET research into the
>P2PRG efforts? 

 Their is a sub-group within IRTF-RR (routing research
group) which is currently discussing MANET scalability 
issues.

[email-masked]