Subject: [P2Prg] [mobility-temp]: initial collection and structure of subgroup re search items

From: Andersen Frank-Uwe <[email-masked]>
Date: Wed, 7 Jan 2004 15:34:16 +0100

Dear sub-group,

in order to take a step forward, I collected the results of the initial opinion poll on p2p mobility to compile a very first, tentative structure with suggested research directions (still very high-level). It takes into account and reflects what has been named by our subgroup participants, i.e. their research interests and current/past activities.

It does not look like very much yet, but it should serve the purpose of getting into discussions again and to generate a common viewing angle on the subject. I will be happy to be the moderator. 

I did check with the descriptions of the other subgroups and tried my best to stay clear of too many overlaps. It is evident, however, that we relate to the routing subgroup.

It would be nice if everybody who volunteered for participation in the mobility subgroup could give their comments to the attached small text. Don't hesitate to use the "comment" mechanism in WORD. We may also switch to other forms of collaborative online work, such as writable web mechanisms (e.g. webdav, cvs, etc.).

My understanding is that we are not by all means trying to do a brand new design for a p2p system yet (see the charter). Instead, what we will do is to start by analysis, and then to switch over to find solutions or enhancements eventually. So, if we can agree on this (or a refined, advanced) version of the attached, proposed structure, then our next step _might_ be the collection of mobile device requirements and mobile infrastructure limitations that specifically affect p2p.

btw. a short time ago the IRTF announced the start of a dedicated IP mobility optimizations group http://www.irtf.org/charters/mobopts.html . If we ever come to a point where we need extensions to e.g. mobile-ip for p2p, this might be a place where we can find people to discuss it with.

I wish everybody a successful new year,

Frank-Uwe

p.s. Cheers to Luca for a well-done article in the "p2p journal"!

---

From: "Luca Caviglione" <[email-masked]>
Date: Wed, 7 Jan 2004 17:34:13 +0100

Dear Frank-Uwe and all,
please find attached some taughts about p2p mobility. They are provided in a
separate txt file. They are provided as a "starting point" and maybe they
will be integrated with the document provided by Frank-Uwe. At this stage, I
fully agree with the proposed organization.

[CUT]

Don't hesitate to use the "comment" mechanism in WORD. We may also switch to
other forms of collaborative online work, such as writable web mechanisms
(e.g. webdav, cvs, etc.).

[CUT]

If they are reasonable and interesting I'll update Frank-Uwe's document.

Best regards,

Luca

> p.s. Cheers to Luca for a well-done article in the "p2p journal"!

ehehe, thank you very much! I hope to write some papers with you and the
other members in the future!

---

From: "HyunWook Cha" <[email-masked]>
Date: Thu, 8 Jan 2004 11:13:07 +0900

Hello, Andersen.

I want to modify two categories related to ad-hoc network as following. 
 
.Ad-hoc networks
1. pure ad-hoc : infrastructureless 
2. with internet connectivity (including mobility management with
SIP/MIP)

As you know, MANET itself originally is devised to allow mobile devices
to communication each other without infrastructure(AP etc.). Although
Internet connectivity seems to be accepted as an important
research(engineering) topic in MANET area, the most important design
requirement is that the support of Internet connectivity should be based
on original(basic) purpuse, assumptions(related to glboal addresses),
functionality(mainly routing protocol) of ad hoc networking. 

So, I suggest two items. The first one is "pure ad-hoc network". Under
this, we should question if the state of art architectures of P2P system
can work well or even in tolerable manner unner MANET environment. If
not, we should clearly define the problems which may be due to just
frequent topology changes or routing protocols or P2P system itself. I
suggest P2P routing enhancement under MANET routing protocols and the
support of MANET routing protocols through MANET API. Or we can consider
new architecture which has its own dedicated routing mechanism in order
to work without MANET routing protocol running. Also, co-opration with
reactive/proactive routing protocols should be taken account. 

Second is related to internet connectivity. At this stage, I do not see
any clear goals coupled with P2P. MANET protocols(routing, internet
connecvity) only provide upper layers as well as MIP/SIP with the
transparency of frequent topology changes. In other words, MIP view a
multipop path to a GW as just one link. In this sense, the first item
"cellular environment" seems to be sufficient. Anyway, this is just my
point.   

Thanks,

HyunWook Cha 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Andersen Frank-Uwe
> Sent: Wednesday, January 07, 2004 11:34 PM
> To: [email-masked]'
> Subject: [P2Prg] [mobility-temp]: initial collection and 
> structure of subgroup re search items
> 
> 
> 
> Dear sub-group,
> 
> in order to take a step forward, I collected the results of 
> the initial opinion poll on p2p mobility to compile a very 
> first, tentative structure with suggested research directions 
> (still very high-level). It takes into account and reflects 
> what has been named by our subgroup participants, i.e. their 
> research interests and current/past activities.
> 
> It does not look like very much yet, but it should serve the 
> purpose of getting into discussions again and to generate a 
> common viewing angle on the subject. I will be happy to be 
> the moderator. 
> 
> I did check with the descriptions of the other subgroups and 
> tried my best to stay clear of too many overlaps. It is 
> evident, however, that we relate to the routing subgroup.
> 
> It would be nice if everybody who volunteered for 
> participation in the mobility subgroup could give their 
> comments to the attached small text. Don't hesitate to use 
> the "comment" mechanism in WORD. We may also switch to other 
> forms of collaborative online work, such as writable web 
> mechanisms (e.g. webdav, cvs, etc.).
> 
> My understanding is that we are not by all means trying to do 
> a brand new design for a p2p system yet (see the charter). 
> Instead, what we will do is to start by analysis, and then to 
> switch over to find solutions or enhancements eventually. So, 
> if we can agree on this (or a refined, advanced) version of 
> the attached, proposed structure, then our next step _might_ 
> be the collection of mobile device requirements and mobile 
> infrastructure limitations that specifically affect p2p.
> 
> 
> btw. a short time ago the IRTF announced the start of a 
> dedicated IP mobility optimizations group 
> http://www.irtf.org/charters/mobopts.html . If we ever come 
> to a point where we need extensions to e.g. mobile-ip for 
> p2p, this might be a place where we can find people to 
> discuss it with.
> 
> 

_______________________________________________
P2prg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2prg