Subject: Re: [P2Prg] Simulation tools for p2prg core subgroup

From: [email-masked]
Date: Fri, 27 Jan 2006 13:43:10 -0500

Thanks Alan & Mario,
I have added this to the subgroup's document list at:

http://www.cs.uml.edu/~buford/irtf-p2prg/core.html

John

----- Original Message -----
From: Alan Brown <[email-masked]>
Date: Friday, January 27, 2006 1:06 pm
Subject: [P2Prg] Simulation tools for p2prg core subgroup

> Hi,
> 
> For the core subgroup experimental work item, we have prepared the
> attached draft summarizing existing free network simulation tools.
> 
> If anyone has any comments or contributions they would like to 
> make, they
> are most welcome.
> 
> Thanks.
> 
> -- 
> Alan Brown
> PhD Research Student
> Department of Computing Science and Mathematics
> University of Stirling, FK9 4LA
> Office: 4B49
> Tel: +441786 467449,
> Web: http://www.cs.stir.ac.uk/~abr
> -- 
> The University of Stirling is a university established in Scotland by
> charter at Stirling, FK9 4LA.  Privileged/Confidential Information may
> be contained in this message.  If you are not the addressee indicated
> in this message (or responsible for delivery of the message to such
> person), you may not disclose, copy or deliver this message to anyone
> and any action taken or omitted to be taken in reliance on it, is
> prohibited and may be unlawful.  In such case, you should destroy this
> message and kindly notify the sender by reply email.  Please advise
> immediately if you or your employer do not consent to Internet email
> for messages of this kind.
> 
> 
_______________________________________________
P2prg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2prg
_______________________________________________
P2prg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2prg

---

From: Brian Adamson <[email-masked]>
Date: Fri, 27 Jan 2006 16:27:29 -0500

FYI,

We have done some work in this area at NRL and have extended the ns-2 
network simulator with a construct we call "AgentJ" that lets Java 
application code (with some minor tweaks) to execute in the ns-2 
network simulation environment.

We have been working with Cardiff University in Wales who have a p2p 
implementation entitled "P2PS" (Peer-to-Peer Simplified) that they 
have been using in some Grid Computing and work adapting Web Services 
to peer-to-peer networks.  Using AgentJ, we have ported a version of 
P2PS into ns-2

The framework is still in progress and is being improved (we are 
conducting ongoing work with looking at p2p in MANET environments). 
It may be useful to the community and I can point interested parties 
to where to get the code.

best regards,

Brian Adamson
<[email-masked]>

-- 
Brian

Brian Adamson
<[email-masked]>