Subject: AW: [P2PSIP] RE: [P2Prg] RE: [Sipping] Simple SIP usage scenario

From: "Beck01, Wolfgang" <[email-masked]>
Date: Tue, 10 Apr 2007 09:56:19 +0200

> [discussion about unique nicknames and their registration]
http://www.skyhunter.com/marcs/petnames/IntroPetNames.html
discusses an interesting idea. It goes like this:

- every user has a globally known nickname, which isn't
necessarily unique. 
- To ensure uniqueness, every user has some sort of public key.
It is not memorable (a string of hex), though.
- If I have different users with the same nickname in my address book,
I'd locally assign different 'petnames' to them. 

This scheme has some weaknesses, though. You would have to put
your nickname and key on you business card (and worse, read the
key from a business card and enter it into the client). It doesn't fit
too well into SIP messages either (sip:nickname?[email-masked]?)

I'm not sure if it has been discussed already.

Wolfgang

(sorry about the long sig, EU regulations require it)
--
T-Systems Enterprise Services GmbH
Aufsichtsrat: René Obermann (Vorsitzender)
Executive Committee: Lothar Pauly (Vorsitzender)*, Helmut Binder, Albert Henn, Olaf Heyden*, Katrin Horstmann, Ulrich Kemp, Axel Knobe*,
Wilfried Peters*, Dr. Herbert Schaaff*, Zvezdana Seeger*
Handelsregister: Amtsgericht Frankfurt am Main HRB 55933
Sitz der Gesellschaft: Frankfurt am Main
WEEE-Reg.-Nr. DE87523644
*Geschäftsführer gem. § 35 GmbHG

_______________________________________________
P2prg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2prg

---

From: "Michael Slavitch" <[email-masked]>
Date: Tue, 10 Apr 2007 11:21:01 -0400

"This scheme has some weaknesses, though. You would have to put
 your nickname and key on you business card (and worse, read the 
 key from a business card and enter it into the client). It doesn't fit
 too well into SIP messages either (sip:nickname?[email-masked]?)"

Smartcard-enabled business cards, like hotel room pass keys, solve
this issue and more, and many PC's support smart-card readers.  Other
solutions for this include using a bar code on the back of the card,
bar code readers are cheap too.  Many people use OCR for scanned
business cards already,  which is fraught with errors, scanning and
reading a bar-code is easy.  If the identity is a machine-readable key
use a machine-readable card to solve the problem. They are cheap.

Michael Slavitch              
Lead, Technology Initiatives
[email-masked]

-----Original Message-----
From: Beck01, Wolfgang [mailto:[email-masked]] 
Sent: Tuesday, April 10, 2007 3:56 AM
To: [email-masked]; [email-masked]
Subject: AW: [P2PSIP] RE: [P2Prg] RE: [Sipping] Simple SIP usage scenario

Wolfgang

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

-- 

-----------------------------------------------

This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful. 

Any views, opinions and content presented in this e-mail are solely those of the author and may not represent those of Objectworld Communications Corp.