Subject: [p2p-sip] P2P and 911 (again)

From: Richard.Stastny at oefeg.at (Stastny Richard)
Date: Thu Aug 18 10:20:37 2005

Finally somebody came up with a use case for SIP P2P
Congratulations ;-)

With all these discussions on SIP P2P service providers,
E911 and not to mention CALEA I had basically no idea
what SIP P2P can provide what pure SIP cannot provide

Richard

Richard Stastny
OeFEG
tel:+43 664 420 4100
enum:+43 780 203 211
callto://fordprefect
http://voipandenum.blogspot.com

> -----Original Message-----
> From: Brijesh Kumar [mailto:[email-masked]]
> Sent: Thursday, August 18, 2005 4:17 PM
> To: Stastny Richard; Juha Heinanen; Tschofenig, Hannes
> Cc: [email-masked]
> Subject: Re: [p2p-sip] P2P and 911 (again)
> 
> Hi Guys:
> 
> Isn't all discussion very assumptive as to what P2P SIP
> should be used?
> 
> Yes -  for some people E911 may be a required service, but it
> is n't clear why they would like to use P2P SIP for it rather than
using
> standard SIP. After all providing any kind of service guarantee with
> P2P is nearly impossible unless provider controls all the peer nodes
which
> form the overlay, and their performance. Moreover,  you have issues
> of  trust between peers and all related problems of security in a pure
> p2p environment. Given that all future mobile devices are likely to
have
> GPS location or some other means of getting their own location (i.e.,
BTS
> triangulations), I see psap and location mapping more of logistic
> issue than a technology issue. Any decent DHT implementation can store
any
> kind of  data, replicate it  so that you can get it any time you
search
> for
> it.
> 
> Having said this, I have no idea why some people are thinking P2P SIP
> has to replace SIP. I can see many applications and environment that
> do not require E911, and have nothing to do with any kind of provider
> (including "p2p" provider  - whoever it means).
> 
> All I want to do is use P2P SIP  between my hand-held devices in a PAN
> with no need of any additional baggage of any kind (like E911, legal
> interception and whatever else "dangerous stuff" is there  ...)
> 
> cheers,
> 
> --bk
> 
> 
> 
> 
> 
> 
> ----- Original Message -----
> From: "Stastny Richard" <[email-masked]>
> To: "Juha Heinanen" <[email-masked]>; "Tschofenig, Hannes"
> <[email-masked]>
> Cc: <[email-masked]>
> Sent: Wednesday, August 17, 2005 6:10 PM
> Subject: Re: [p2p-sip] P2P and 911 (again)
> 
> 
> Juha,
> 
> you are at the point. Emergency services in future requires the
> provision of location information to the end-users device by the
> access providers as an obligation. there will be no obligations
> anymore to the application service providers, because in this case
> the device may access the PSAP directly.
> 
> A gsm/3g provider is nothing else than just an access provider
> like a DSL or cable provider, a WiFi hot spot or WiMAX.
> This message has to be conveyed to the regulators, especially
> in Europe.
> 
> so the whole discussion if p2p provider have to provide access
> to emergency services is needless, they will not be they one
> haveing obligations
> 
> -richard
> 
> ________________________________
> 
> Von: [email-masked] im Auftrag von Juha Heinanen
> Gesendet: Mi 17.08.2005 15:37
> An: Tschofenig, Hannes
> Cc: [email-masked]
> Betreff: [p2p-sip] P2P and 911 (again)
> 
> 
> 
> Tschofenig, Hannes writes:
> 
>  > 1) the end host is able to use a mapping protocol to locate the
psap.
>  > the uri of the psap is determined based on the location of the end
>  > host.
> 
> if p2p sip client is in gsm/3g device, it could calculate its own
> location provided that it knows coordinates of available gsm/3g base
> stations.
> 
> i once suggested to authorities in finland that every mobile operator
is
> mandated to publish coordinates of their base stations on the
internet.
> this was rejected due to desire of mobile operators to hide such
> information.
> 
> this is yet another example of the walled garden philosophy of mobile
> operators.  they don't want to give control to intelligent p2p end
> devices.
> 
> perhaps fcc in the u.s., if, as they claim, take emergency calling
> seriously, could publish such ruling as an example to european
> regulators.  if not, the only conclusion one can make, is that all
this
> fuzz about emergency calling is nothing but joke and in the end the
only
> thing that really matters is commercial interests of walled garden
> operators.
> 
> -- juha
> _______________________________________________
> p2p-sip mailing list
> [email-masked]
> http://lists.cs.columbia.edu/mailman/listinfo/p2p-sip
> 
> 
> 
> _______________________________________________
> p2p-sip mailing list
> [email-masked]
> http://lists.cs.columbia.edu/mailman/listinfo/p2p-sip

---

From: slavitch at gmail.com (Michael Slavitch)
Date: Thu Aug 18 10:56:53 2005

What P2P SIP does is move SIP completely to the edge and eliminate the need 
for softswitches, or in fact any infrastructure at all in the core. 
Registration and validation, which being peer-to-peer becomes easily and 
automatically scaleable, redundant and sharable between organizations, and 
there is no 'god' picking winners. In this model you don't need the 
permission of a provider to add a service to a realm, you just need to 
validate yourself as a member and exist and let other endpoints choose.

That is incredibly powerful stuff, in essense an automatic dynamic 
communications network without barriers to entry as different from the 
current PSTN as the web is from, say, television.

M

-- 
Michael Slavitch
Ottawa, Ontario Canada
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20050818/1acf0e9f/attachment.html