Subject: [p2p-sip] P2P and 911 (again)

From: Richard.Stastny at oefeg.at (Stastny Richard)
Date: Wed Aug 17 19:03:36 2005

Phil wrote:

>Remember that many PSAPs will continue with POTS service for some time perhaps for long time depending on their funding.  During the >interim, the p2p provider needs to provide a means of locating the appropriate PSAP and routing P2P VoIP 911 calls to the PSAP via the >PSTN.  So P2P provider access to emergency services will likely be a real issue and for how long no one knows.

If the requirement exists to provide access to emergency services from all Internet devices seriously;
the emergency organisatons need to provide access via emergency service routing proxies (ESRP)
and gateways feeding the emergency calls into the existing national PSTN system and PSAPs.

If I am travelling to the US with my WiFi phone I also expect 911 to work, with or without
my local provider.

The FCC requirement that only "interconnected" VoIP SP need to provide access to emergency
services within the US iwhere E911 is available is very short-sighted. It also requires effort
and investments from certain VoIP providers for a short period of time.

And one last statement. I have no idea why everybode is assuming that the PSAPs
will be on the PSTN for a LONG time. A PSAP is nothing else than a call center and
a call center should be converted to VoIP a soon as possible anyway to save operational cost.

And in the long term we are all dead (Hayek)

-richard

---

From: hannes.tschofenig at siemens.com (Tschofenig, Hannes)
Date: Thu Aug 18 07:42:20 2005

hi patrick 

> Richard,
> 
> Remember that many PSAPs will continue with POTS service for 
> some time perhaps for long time depending on their funding.  
> During the interim, the p2p provider

'p2p provider' sounds like a strange term to me. 

> needs to provide a means 
> of locating the appropriate PSAP

there needs to be a way to determine the psap based on location
information. if the psap is an ip based device then it will be directly
contact by the emergency caller. 

> and routing P2P VoIP 911 
> calls to the PSAP via the PSTN.

the interworking with pstn is certainly an issue for a transition
period. 
there are certainly some interesting issues there that need to be
considered: 
- if you participate in a p2p network and you do not have a connectivity
to the pstn then obviously you cannot route emergency calls to the pstn.
done. 
- if you support pstn interworking then you might route emergency calls
there. here is the difficult part: you need to make this fact available
to the mapping database, i.e., 'here is my sip uri and i am responsible
for this particular geographical area'. in a p2p network every end host
might have the capability to support pstn interworking. two issues
arise: 

   * security problems: someone uses your host to place bogus emergency
calls. how do you convince the policy that it wasn't you. 

   * authorization problems: you cannot arbitrarily add, removed and
update entries in the mapping database

>  So P2P provider access to 
> emergency services will likely be a real issue and for how 
> long no one knows.
> 

ciao
hannes

> Phil
> 
> -----Original Message-----
> From: Stastny Richard [mailto:[email-masked]]
> Sent: Wednesday, August 17, 2005 3:10 PM
> To: Juha Heinanen; Tschofenig, Hannes
> Cc: [email-masked]
> Subject: Re: [p2p-sip] P2P and 911 (again)
> 
> 
> Juha,
>  
> you are at the point. Emergency services in future requires the
> provision of location information to the end-users device by the 
> access providers as an obligation. there will be no obligations
> anymore to the application service providers, because in this case
> the device may access the PSAP directly.
>  
> A gsm/3g provider is nothing else than just an access provider
> like a DSL or cable provider, a WiFi hot spot or WiMAX.
> This message has to be conveyed to the regulators, especially
> in Europe.
>  
> so the whole discussion if p2p provider have to provide access
> to emergency services is needless, they will not be they one 
> haveing obligations
>  
> -richard
> 
> ________________________________
> 
> Von: [email-masked] im Auftrag von Juha Heinanen
> Gesendet: Mi 17.08.2005 15:37
> An: Tschofenig, Hannes
> Cc: [email-masked]
> Betreff: [p2p-sip] P2P and 911 (again)
> 
> 
> 
> Tschofenig, Hannes writes:
> 
>  > 1) the end host is able to use a mapping protocol to 
> locate the psap.
>  > the uri of the psap is determined based on the location of the end
>  > host.
> 
> if p2p sip client is in gsm/3g device, it could calculate its own
> location provided that it knows coordinates of available gsm/3g base
> stations.
> 
> i once suggested to authorities in finland that every mobile 
> operator is
> mandated to publish coordinates of their base stations on the 
> internet.
> this was rejected due to desire of mobile operators to hide such
> information.
> 
> this is yet another example of the walled garden philosophy of mobile
> operators.  they don't want to give control to intelligent p2p end
> devices.
> 
> perhaps fcc in the u.s., if, as they claim, take emergency calling
> seriously, could publish such ruling as an example to european
> regulators.  if not, the only conclusion one can make, is 
> that all this
> fuzz about emergency calling is nothing but joke and in the 
> end the only
> thing that really matters is commercial interests of walled garden
> operators.
> 
> -- juha
> _______________________________________________
> p2p-sip mailing list
> [email-masked]
> http://lists.cs.columbia.edu/mailman/listinfo/p2p-sip
> 
> 
> 
> _______________________________________________
> p2p-sip mailing list
> [email-masked]
> http://lists.cs.columbia.edu/mailman/listinfo/p2p-sip
>

---

From: hannes.tschofenig at siemens.com (Tschofenig, Hannes)
Date: Thu Aug 18 10:56:58 2005

hi brijesh, 

> Hi Guys:
> 
> Isn't all discussion very assumptive as to what P2P SIP
> should be used?
> 
> Yes -  for some people E911 may be a required service, but it
> is n't clear why they would like to use P2P SIP for it rather 
> than using
> standard SIP.

i guess there is a question of how large the difference between p2p sip
and "standard sip" is for you. 

reading your mail you seem to point more to the architectural
differences between p2p as a paradigm and sip as used in the 3gpp, for
example. 

> After all providing any kind of service guarantee with
> P2P is nearly impossible unless provider controls all the 
> peer nodes which
> form the overlay, and their performance.
> Moreover,  you have issues
> of  trust between peers and all related problems of security in a pure
> p2p environment.

you certainly need to be a bit more specific about this statement. 

> Given that all future mobile devices are 
> likely to have
> GPS location or some other means of getting their own 
> location (i.e., BTS
> triangulations),
as i noted in my original mail support for gps might be there and it
might be possible to use it in certain environments. however, it is also
reasonable to think about cases where it does not work or where it is
not available. 

> I see psap and location mapping more of logistic
> issue than a technology issue.

in order for the mapping protocol to be useful there needs to be a
distributed database that stores the location to uri mappings. there are
protocol, security and operational issues that need to be considered. 

> Any decent DHT implementation 
> can store any
> kind of  data, replicate it  so that you can get it any time 
> you search for
> it.
it might be possible to store the mapping there but i see some
difficulties. search capabilities, as far as i know, are pretty limited
with many p2p systems. 

> 
> Having said this, I have no idea why some people are thinking P2P SIP
> has to replace SIP.
i guess nobody said that. 

> I can see many applications and environment that
> do not require E911, and have nothing to do with any kind of provider
> (including "p2p" provider  - whoever it means).
> 
> All I want to do is use P2P SIP  between my hand-held devices in a PAN
> with no need of any additional baggage of any kind (like E911, legal
> interception and whatever else "dangerous stuff" is there  ...)

we started with an attempt to better understand the impact of a p2p sip
alike environment for emergency support. this seems to be an issue many
people worry about. there are certainly some aspects (including security
issues) that deserve a closer look. if you are interested in controlling
light bulbs using sip, for example, then is likely no reason to deal
with emergency cases or lawful interception.

ciao
hannes

> 
> cheers,
> 
> --bk
> 
> 
> 
> 
> 
> 
> ----- Original Message ----- 
> From: "Stastny Richard" <[email-masked]>
> To: "Juha Heinanen" <[email-masked]>; "Tschofenig, Hannes"
> <[email-masked]>
> Cc: <[email-masked]>
> Sent: Wednesday, August 17, 2005 6:10 PM