Subject: [p2p-sip] What are we doing, question 2

From: ksankar at cisco.com (Krishna Sankar (ksankar))
Date: Mon, 5 Jun 2006 17:48:34 -0700

Yep, MANET and IP mobility are different paradigms. And yes, most
probably the underlying connectivity substrate *can* be irrelevant to
us.

BTW, what is so catastrophic about an IP change ? When IP changes,
delete the old record and add a new one. I know that we need to work
thru the various cases and map out the various protocol activities. 

Cheers
<k/>

> -----Original Message-----
> From: Peter Pan [mailto:huang-ming.pan at comcast.net] 
> Sent: Monday, June 05, 2006 4:20 PM
> To: Mike Robinson; Roy, Radhika R.; Krishna Sankar (ksankar)
> Cc: p2p-sip at cs.columbia.edu
> Subject: Re: [p2p-sip] What are we doing, question 2
> 
> Won't mobility be taken care transparently (w/o ip change) by 
> routers supporting 802.11f, rfc 3344 and related standards?  
> IP change sounds chaotic (if not catastrophic) to DHT.
> 
> Are MANET and IP mobility mutual exclusive?
> 
> Peter
> 
> ----- Original Message -----
> From: Mike Robinson
> To: Roy, Radhika R. ; Krishna Sankar (ksankar)
> Cc: p2p-sip at cs.columbia.edu
> Sent: Monday, June 05, 2006 2:39 PM
> Subject: Re: [p2p-sip] What are we doing, question 2
> 
> 
> Radhika Roy wrote:
> 
> >>In fact, we will be working cooperating with them to 
> complete our work:
> >> p2pSIP Application Layer to the MANET Network Layer.
> 
> What is that you refer to "our work"? Whose work are you 
> talking? Did IETF assign you a spokesman for MANET?
> 
> Could you please update us who authorized to speak on behalf 
> of  MANET group?
> 
> By the way, ad-hoc networks have nothing to do with p2p since 
> p2p can run on fixed infrastructure and ad-hoc networks need 
> not use p2p for applications.
> Did it occur to you that one can run client server 
> applications even when network may be based on ad-hoc network 
> routing protocol. Supporting mobility in p2p nodes is quite 
> difficult contrary to what you say in your typical hand 
> waving style (since you would need to do reinsert your mobile 
> nodes in a DHT, reconfigure DHT, and update resource 
> information at all DHT nodes)
> 
> I hope you would try to understand the issues with DHT and 
> mobility before you resume your periodic vacuous comments in 
> support of p2p sip (which almost always are devoid of any 
> technical input whatsoever).
> 
> 
> o mike
> 
> 
> "Roy, Radhika R." <RADHIKA.R.ROY at saic.com> wrote:
> KS:
> 
> To support p2pSIP for mobile nodes (if not mobile devices per 
> se) should not be difficult. IETF Mobile Ad Hoc Network 
> (MANET) WG has already done the most difficult works in this 
> p2p networking environment: Network Routing and QoS support.
> 
> So, it will be rather easy to support the p2pSIP application 
> protocol that will ride over the network layer MANET protocol.
> 
> In fact, we will be working cooperating with them to complete 
> our work:
> p2pSIP Application Layer to the MANET Network Layer.
> 
> Best regards,
> Radhika R. Roy
> 
> -----Original Message-----
> From: p2p-sip-bounces at cs.columbia.edu
> [mailto:p2p-sip-bounces at cs.columbia.edu] On Behalf Of Krishna Sankar
> (ksankar)
> Sent: Monday, June 05, 2006 11:43 AM
> To: David Barrett; p2p-sip at cs.columbia.edu
> Subject: Re: [p2p-sip] What are we doing, question 2
> 
> My view of the P2P-SIP world ...
> 
> > 2) Does P2PSIP work on mobile devices assigned dynamic IP addresses?
> 
> Yep, definitely. Might not be that easy
> 
> 
> _______________________________________________
> p2p-sip mailing list
> p2p-sip at cs.columbia.edu
> https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
> 
> 
> 
> 
> 
> New Yahoo! Messenger with Voice. Call regular phones from 
> your PC and save big.
>

---

From: huang-ming.pan at comcast.net (Peter Pan)
Date: Mon, 5 Jun 2006 19:06:35 -0700

The basic troubles to application, operating system and network caused by a
IP change are described in rfc 3344.

The troubles to P2P SIP at least includes:

* stale DHT fingers or k-buckets (besides those resulted from nodes leaving
network)
* stale SIP registration (nodes need to register)
* stale TURN relay (needs re-discovery) and sessions (needs SDP
re-negotiation)
* no more transparent singaling/media handover (if "L7 handover" had worked
perfectly there would be no rfc 3344)

Please omit unnecessary work when good solution (ip mobility) is there.

Peter

----- Original Message -----
From: "Krishna Sankar (ksankar)" <ksankar at cisco.com>
To: "Peter Pan" <huang-ming.pan at comcast.net>; "Mike Robinson"
<mike_robnson at yahoo.com>; "Roy, Radhika R." <RADHIKA.R.ROY at saic.com>
Cc: <p2p-sip at cs.columbia.edu>
Sent: Monday, June 05, 2006 5:48 PM
Subject: Re: [p2p-sip] What are we doing, question 2