Subject: [p2p-sip] STUN (rfc3489)

From: huang-ming.pan at comcast.net (Peter Pan)
Date: Mon, 12 Jun 2006 10:24:26 -0700

Sorry. I should have asked:

Is it possible to realize a STUN sever defined by
draft-ietf-behave-rfc3489bis-03 on a host with ONLY ONE IP that can discover
the NAT type before a STUN client?

Peter
----- Original Message -----
From: "Peter Pan" <huang-ming.pan at comcast.net>
To: "Cullen Jennings" <fluffy at cisco.com>
Cc: <p2p-sip at cs.columbia.edu>
Sent: Monday, June 12, 2006 10:19 AM
Subject: Re: [p2p-sip] STUN (rfc3489)

> Is it possible to realize a STUN sever defined by
> draft-ietf-behave-rfc3489bis-03 on a host with ONLY ONE IP?
>
> Peter
> ----- Original Message -----
> From: "Cullen Jennings" <fluffy at cisco.com>
> To: "Peter Pan" <huang-ming.pan at comcast.net>
> Cc: <p2p-sip at cs.columbia.edu>
> Sent: Monday, June 12, 2006 10:10 AM
> Subject: Re: [p2p-sip] STUN (rfc3489)
>
>
> >
> > On Jun 12, 2006, at 10:03 AM, Peter Pan wrote:
> >
> > > Is RFC 3489 based on assumption that STUN server is at least "dual-
> > > homed".
> >
> > no but it is based on the idea that the stun server has two IP
> > address - it is recommended that these are both on the same
> > interface. However this changes in the update to it - draft-ietf-
> > behave-rfc3489bis-03 does not require two IP addresses.
>

---

From: fluffy at cisco.com (Cullen Jennings)
Date: Mon, 12 Jun 2006 13:38:08 -0700

> the NAT type before a STUN client?

I have no idea what you mean by NAT type but if what you mean is the  
classification in RFC 3489, then NO. If what you mean is enough to  
detect connectivity such as used by ICE, then YES.

---

From: huang-ming.pan at comcast.net (Peter Pan)
Date: Mon, 12 Jun 2006 15:13:45 -0700

> detect connectivity such as used by ICE, then YES.

By NAT type I meant those terms such as "full-cone", "ip-restricted",
"port-restricted" and "symmetric" that seem widely used in voip industry.
(http://www.voip-info.org/wiki-STUN, or
http://en.wikipedia.org/wiki/Symmetric_NAT)

Never mind it. Sounds like P2PSIP no more needs that info.

---

From: adamfisk at gmail.com (Adam Fisk)
Date: Fri, 30 Jun 2006 23:53:52 -0400

My understanding is that those terms for NATs have been deemed inadequate
for describing NAT behavior in the field.  I'm not up to speed on latest
STUN drafts, but I believe Cullen's link gives the appropriate descriptions
of the newer, more accurate NAT classifications.

-Adam

On 6/12/06, Peter Pan <huang-ming.pan at comcast.net> wrote:
> _______________________________________________
> p2p-sip mailing list
> p2p-sip at cs.columbia.edu
> https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060630/e4df3f35/attachment-0001.html