Subject: [p2p-sip] What are we doing, question 2

From: RADHIKA.R.ROY at saic.com (Roy, Radhika R.)
Date: Mon, 5 Jun 2006 14:39:13 -0400

KS:

To support p2pSIP for mobile nodes (if not mobile devices per se) should
not be difficult. IETF Mobile Ad Hoc Network (MANET) WG has already done
the most difficult works in this p2p networking environment: Network
Routing and QoS support.

So, it will be rather easy to support the p2pSIP application protocol
that will ride over the network layer MANET protocol. 

In fact, we will be working cooperating with them to complete our work:
p2pSIP Application Layer to the MANET Network Layer.

Best regards,
Radhika R. Roy

-----Original Message-----
From: p2p-sip-bounces at cs.columbia.edu
[mailto:p2p-sip-bounces at cs.columbia.edu] On Behalf Of Krishna Sankar
(ksankar)
Sent: Monday, June 05, 2006 11:43 AM
To: David Barrett; p2p-sip at cs.columbia.edu
Subject: Re: [p2p-sip] What are we doing, question 2

My view of the P2P-SIP world ...

> 2) Does P2PSIP work on mobile devices assigned dynamic IP addresses? 
<KS>
	Yep, definitely. Might not be that easy 
</KS>

---

From: mike_robnson at yahoo.com (Mike Robinson)
Date: Mon, 5 Jun 2006 14:39:40 -0700 (PDT)

>> p2pSIP Application Layer to the MANET Network Layer.

What is that you refer to "our work"? Whose work are you talking? Did IETF assign you a spokesman for MANET? 
 
 Could you please update us who authorized to speak on behalf of  MANET group? 
 
 By the way, ad-hoc networks have nothing to do with p2p since p2p can run on fixed infrastructure and ad-hoc networks need not use p2p for applications.  Did it occur to you that one can run client server applications even when network may be based on ad-hoc network routing protocol. Supporting mobility in p2p nodes is quite difficult contrary to what you say in your typical hand waving style (since you would need to do reinsert your mobile nodes in a DHT, reconfigure DHT, and update resource information at all DHT nodes)
 
 I hope you would try to understand the issues with DHT and mobility before you resume your periodic vacuous comments in support of p2p sip (which almost always are devoid of any technical input whatsoever). 

o mike

"Roy, Radhika R." <RADHIKA.R.ROY at saic.com> wrote: KS:

Best regards,
Radhika R. Roy

-----Original Message-----

_______________________________________________
p2p-sip mailing list
p2p-sip at cs.columbia.edu
https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip

---------------------------------
New Yahoo! Messenger with Voice. Call regular phones from your PC and save big.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060605/341b0bd2/attachment-0001.html

---

From: bk9001 at gmail.com (Brijesh Kumar)
Date: Mon, 5 Jun 2006 17:50:34 -0400

On 6/5/06, Roy, Radhika R. <RADHIKA.R.ROY at saic.com> wrote:
> not be difficult.

I beg to differ with above assessment.

Actually, a change in the IP address would result in the change in a node's
identity. Also, a number of DHT configuraion algorithms (specially
hierarchical organization) try to optimize overlay organization on the basis
of a node's geographical location with respect to certain reference points.
That has major implications on a DHT's operation since it may require DHT
reconfiguration as well as affect where a node will be placed in the
overlay.

I haven't seen many papers that have analyzed large scale networks for the
effect of node identity  change due to node mobility in P2P networks so  it
is not clear to me why would you say that it is not "difficult".

--bk

IETF Mobile Ad Hoc Network (MANET) WG has already done
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060605/7041d1f5/attachment.html

---

From: eunsoo at research.panasonic.com (Eunsoo Shim)
Date: Mon, 05 Jun 2006 19:14:40 -0400

As long as the IP address of a node does not change, nothing special
needs to be done for DHT.

In the MANET framework, the IP address of a mobile node does not change.
If a mobile deivce is connected to the global Internet and Mobile IP is
supported, nothing special needs to be done for the mobile node
participating in the DHT, either.

If the IP address of a mobile node changes, that's a different story. We
can put such mobile devices as ordinary nodes (not participating in DHT)
if the P2P network contain both fixed and mobile devices.

In my understanding, no one represents any IETF working group or any
other organization in the mailing list unless she/he claims to do so
explicitly. I don't see anyone claiming to represent MANET or any other
WG during the discussion.

Thanks.

Eunsoo

Mike Robinson wrote:
> ------------------------------------------------------------------------
>

---

From: huang-ming.pan at comcast.net (Peter Pan)
Date: Mon, 5 Jun 2006 16:20:07 -0700

Won't mobility be taken care transparently (w/o ip change) by routers
supporting 802.11f, rfc 3344 and related standards?  IP change sounds
chaotic (if not catastrophic) to DHT.

Are MANET and IP mobility mutual exclusive?

Peter

----- Original Message -----
From: Mike Robinson
To: Roy, Radhika R. ; Krishna Sankar (ksankar)
Cc: p2p-sip at cs.columbia.edu
Sent: Monday, June 05, 2006 2:39 PM
Subject: Re: [p2p-sip] What are we doing, question 2

>> p2pSIP Application Layer to the MANET Network Layer.

What is that you refer to "our work"? Whose work are you talking? Did IETF
assign you a spokesman for MANET?

Could you please update us who authorized to speak on behalf of  MANET
group?

By the way, ad-hoc networks have nothing to do with p2p since p2p can run on
fixed infrastructure and ad-hoc networks need not use p2p for applications.
Did it occur to you that one can run client server applications even when
network may be based on ad-hoc network routing protocol. Supporting mobility
in p2p nodes is quite difficult contrary to what you say in your typical
hand waving style (since you would need to do reinsert your mobile nodes in
a DHT, reconfigure DHT, and update resource information at all DHT nodes)

I hope you would try to understand the issues with DHT and mobility before
you resume your periodic vacuous comments in support of p2p sip (which
almost always are devoid of any technical input whatsoever).

o mike

"Roy, Radhika R." <RADHIKA.R.ROY at saic.com> wrote:
KS:

Best regards,
Radhika R. Roy

-----Original Message-----

New Yahoo! Messenger with Voice. Call regular phones from your PC and save
big.

---

From: mike_robnson at yahoo.com (Mike Robinson)
Date: Mon, 5 Jun 2006 18:01:51 -0700 (PDT)

>> In the MANET framework, the IP address of a mobile node does not change.

This is definitely incorrect to the MANET framework that I am familiar with.

A node may  momentarily leave the network and re-join the network. This will result in address re-assignement (or self configuration with DAD in IPv6). 

Also, two or more networks may merge/split and address reconfiguration may take place.

>> if the P2P network contain both fixed and mobile devices.

How would a node know apriori whether and when it supports mobility or not since  IP mobility support is function of node and network infrastructure? 

Besides, the idea of making p2p sip functionality of a node dependent on mobile-ip presence or absence sounds quite wrong to me.

Unfortunartely, I don't have time to go in lengthy debates, but hopefully I have conveyed that support for mobile nodes is not that simple either as is/was being made.

o mike

Eunsoo Shim <eunsoo at research.panasonic.com> wrote: As long as the IP address of a node does not change, nothing special
needs to be done for DHT.

Thanks.

Eunsoo

Mike Robinson wrote:
> "Roy, Radhika R."  wrote: KS:
> 

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060605/97a3aab2/attachment.html

---

From: mike_robnson at yahoo.com (Mike Robinson)
Date: Mon, 5 Jun 2006 18:05:03 -0700 (PDT)

o mike

Thanks.

Eunsoo

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060605/c8e4ad09/attachment-0001.html

---

From: enrico.marocco at telecomitalia.it (Enrico Marocco)
Date: Tue, 06 Jun 2006 10:08:52 +0200

Mike Robinson wrote:
> Unfortunartely, I don't have time to go in lengthy debates

Sending mails twice won't help much anyway.

Enrico

---

From: eunsoo at research.panasonic.com (Eunsoo Shim)
Date: Tue, 06 Jun 2006 07:25:16 -0400

Mike Robinson wrote:

> A node may  momentarily leave the network and re-join the network.
> This will result in address re-assignement (or self configuration with
> DAD in IPv6).

OK.  This is the same for a fixed node that gets offline and comes back.

> Also, two or more networks may merge/split and address reconfiguration
OK. I guess this won't happen very often.

DHT should be able to hanlde JOIN/LEAVE of nodes. In a simple scheme, IP
address change is equivalent to a LEAVE and a JOIN. As long as it does
not happen too often, many DHTs we know of will be able to handle it.

> How would a node know apriori whether and when it supports mobility or
> not since  IP mobility support is function of node and network
> infrastructure?
>
Initially the software in each device may gather information about the
system like the type of the network interface or the type of device. If
the network interface is wireless, the software can take a conservative
decision to operate only as an ordinary node. I don't mean there is an
easy and precise algorithm for this.
The detailed algorithm is out of scope of our discussion or the
standardization in the IETF.

> Besides, the idea of making p2p sip functionality of a node dependent
> on mobile-ip presence or absence sounds quite wrong to me.
>
I am not saying P2P SIP requires Mobile IP all the time.

> Unfortunartely, I don't have time to go in lengthy debates, but
> hopefully I have conveyed that support for mobile nodes is not that
> simple either as is/was being made.
>
I don't mean supporting mobile nodes is easy always. There are different
cases and we may avoid difficult problems. So we should not be scared
too much about mobile nodes w.r.t. P2P SIP. But I agree with you that we
should not consider the problem in general as a simple one.

Thanks.

Eunsoo

>
>
>
>
> */Eunsoo Shim <eunsoo at research.panasonic.com>/* wrote:
>
>     > What is that you refer to "our work"? Whose work are you
>     talking? Did IETF assign you a spokesman for MANET?
>     >
>     > By the way, ad-hoc networks have nothing to do with p2p since
>     p2p can run on fixed infrastructure and ad-hoc networks need not
>     use p2p for applications. Did it occur to you that one can run
>     client server applications even when network may be based on
>     ad-hoc network routing protocol. Supporting mobility in p2p nodes
>     is quite difficult contrary to what you say in your typical hand
>     waving style (since you would need to do reinsert your mobile
>     nodes in a DHT, reconfigure DHT, and update resource information
>     at all DHT nodes)
>     >
>     > I hope you would try to understand the issues with DHT and
>     mobility before you resume your periodic vacuous comments in
>     support of p2p sip (which almost always are devoid of any
>     technical input whatsoever).
>     >
>     >
>     > o mike
>     >
>     >