Subject: [p2p-sip] IMPORTANT!!! Updated Charter

From: bryan at ethernot.org (David A. Bryan)
Date: Wed, 1 Nov 2006 12:14:28 -0500

Any further comments? I'd like to make the final "pre-BOF" round of
changes, so if there are other issues, lets discuss them now.
Otherwise I am hoping I can iterate this with the small changes below,
and take this version to the BOF.

Currently I plan to fix the following:

1) fix the "opeer" typo

2) Change bullet 3 under "excluded topics" to read:

"3. Locating resources based on something other than URIs. In other
  words, arbitrary search of attributes is out of scope, but locating
  resources based on their URIs is in scope. Using URIs need not imply
  using the DNS or having a record in the DNS for the URI."

3) The third issue raised by Scott, with proposed wording by Eunsoo
and Scott, is a bit trickier. In the very beginning, while explaining
what P2PSIP is, we say:

"The Peer-to-Peer (P2P) Session Initiation Protocol working group
(P2PSIP WG) is chartered to develop protocols and mechanisms for the
use of the Session Initiation Protocol (SIP) in settings where the
service of establishing and managing sessions is principally handled
by a collection of intelligent endpoints, or P2PSIP peers,
rather than centralized servers as in client-server SIP as currently
deployed."

Later we say:

"P2PSIP clients and peers use the resolution
services of the peers as an alternative to the SIP correspondent
discovery process of RFC 3263. Session management, messaging, and
presence functions are performed using traditional SIP."

The intent in the first one is that the end points are the things
doing the work, rather than servers -- it is a very broad statement
(and one I think is true) asserting that we don't need servers for
managing the calls, so I'd like to leave that.

The second is a more specific point, saying that we will reuse SIP as
much possible and that we are really looking at replacing the
resolution portion of SIP. Apparently the wording is a bit confusing
as a consequence.

I would like to propose changing the second sentence under discussion to read:

"P2PSIP clients and peers use the resolution
services of the peers as an alternative to the SIP correspondent
discovery process of RFC 3263. [The remaining aspects of] session
management, messaging, and
presence functions are performed using traditional SIP."

(new text in [])

Scott and Eunsoo: does that fix it?

David

On 10/28/06, Eunsoo Shim <eunsoo at research.panasonic.com> wrote:
> Scott W Brim wrote:
>
> >First, you missed an "o" -- search for "opeer".
> >
> >Second,
> >
> >
> >
> >>service of establishing and managing sessions is principally handled
> >>by a collection of intelligent endpoints, or P2PSIP peers,
> >>
> >>
> >
> >
> >
> Since 'P2PSIP Peer' has a certain meaning, narrower than 'intelligent
> endpoint',
> For example, P2PSIP Clients are also such intelligent endpoints.
> One remedy may be just removing 'or P2PSIP peers' from the sentence.
>
> >I think you want to take "and managing" out of the first line.
> >Compare you have below ...
> >
> >
> >
> >>P2PSIP overlay. P2PSIP clients and peers use the resolution
> >>services of the peers as an alternative to the SIP correspondent
> >>discovery process of RFC 3263. Session management, messaging, and
> >>presence functions are performed using traditional SIP.
> >>
> >>
> >
> >
> >
> Thanks.
>
> Eunsoo
> _______________________________________________
> p2p-sip mailing list
> p2p-sip at cs.columbia.edu
> https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
>

---

From: slavitch at gmail.com (Michael Slavitch)
Date: Wed, 1 Nov 2006 12:47:55 -0500

Looks like soup is almost done.

Good work.

M

---

From: hsinnrei at adobe.com (Henry Sinnreich)
Date: Wed, 1 Nov 2006 11:42:32 -0800

The updated charter is excellent!

Folks: There is only on action item now, to get the P2PSIP WG formed.

We must postpone any technical issues for later, after having the WG
chartered.

Henry

-----Original Message-----
From: p2p-sip-bounces at cs.columbia.edu
[mailto:p2p-sip-bounces at cs.columbia.edu] On Behalf Of David A. Bryan
Sent: Wednesday, November 01, 2006 11:14 AM
To: Eunsoo Shim
Cc: P2P-SIP
Subject: Re: [p2p-sip] IMPORTANT!!! Updated Charter

1) fix the "opeer" typo

Later we say:

I would like to propose changing the second sentence under discussion to
read:

(new text in [])

David

---

From: eunsoo at research.panasonic.com (Eunsoo Shim)
Date: Thu, 02 Nov 2006 11:00:57 -0500

Scott W Brim wrote:

>Excerpts from David A. Bryan on Wed, Nov 01, 2006 12:14:28PM -0500:
>  
>
>I still wonder a little about "and managing sessions" in the first
>paragraph (P2PSIP peers "manage" SIP sessions?) but it's a nit in the
>long run.  We can deal with it in 30 seconds in San Diego.  See you.  
>
>Scott (arriving Saturday 6pm via SFO)
>  
>
I guess Scott and I are talking about the same thing.
Simply dropping 'P2PSIP peers' from the first sentence should work for me.
The current sentence is:

My proposal is:

by a collection of intelligent endpoints,

If necessary, we will be able to discuss and fix this easily in San
Diego as Scott said.
Thanks.

Eunsoo

---

From: swb at employees.org (Scott W Brim)
Date: Thu, 2 Nov 2006 17:10:16 +0100

Excerpts from Eunsoo Shim on Thu, Nov 02, 2006 11:00:57AM -0500:
> I guess Scott and I are talking about the same thing.  Simply
> dropping 'P2PSIP peers' from the first sentence should work for me.
> The current sentence is:
> 
> by a collection of intelligent endpoints, or P2PSIP peers, rather
> than centralized servers as in client-server SIP as currently
> deployed."
> 
> My proposal is:
> 
> by a collection of intelligent endpoints, rather than centralized
> servers as in client-server SIP as currently deployed."

Works well for me.  Thanks.

---

From: bryan at ethernot.org (David A. Bryan)
Date: Thu, 2 Nov 2006 11:29:33 -0500

Good enough for me then. I'll drop it.

Expect an iterated version (the one we will go to BOF with) shortly.

David

---

From: swb at employees.org (Scott W Brim)
Date: Thu, 2 Nov 2006 06:58:52 +0100