Subject: [P2PSIP] Concepts draft and P2PSIP clients

From: Philip Matthews <[email-masked]>
Date: Wed, 28 Feb 2007 14:38:07 -0500

There have been various discussions and proposals
for clients over the past few months.

First of all, there was the original proposal that was put
forth in the -00 version of the Concepts document.
In this version, clients associated with (usually just one) peer,
with the client acting in a way similar to a SIP UA,
and the peer acting in a way similar to a SIP proxy/registrar.
In this proposal, clients did not store data for the overlay,
nor did they participate in message routing.
In this view, clients do not have a "Client ID".

Second, there was a proposal by Eric Rescorla.
As I understand this proposal, clients are fully meshed
into the overlay, but still do not store data for the overlay.
However, presumably they do participate in message routing.
In this view, clients have a "Peer ID", since they are involved
in the DHT. This view has been described as
"a peer with bad memory".

Third, there has been some private  discussion of a model
somewhat similar to the first, but where clients DO store
data. In essence, a peer can elect to store data on one of
its associated clients, rather than in its own memory.
In this view, clients do not have a "Client ID" and do
not participate in the DHT.

I think all three of these views are interesting, albeit contradictory.
So I am proposing to include a section in the next revision
of the Concepts document that describes these three views.
This would mean that the text elsewhere in the document
would become somewhat more vague on what a client's role really is.

Comments?

- Philip

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: "Brian Rosen" <[email-masked]>
Date: Wed, 28 Feb 2007 15:18:22 -0500

Where in this is my model, where clients are all in the overlay, all have an
id, all store data, but some of them need to relay messages through another
peer?

Brian

> -----Original Message-----
> From: Philip Matthews [mailto:[email-masked]]
> Sent: Wednesday, February 28, 2007 2:38 PM
> To: [email-masked]
> Subject: [P2PSIP] Concepts draft and P2PSIP clients
>

---

From: "Bill Mccormick" <[email-masked]>
Date: Wed, 28 Feb 2007 15:22:15 -0500

I believe there are several good SIP clients out there today (x-lite
in particular comes to mind) which should work well in the original
proposal...

It would encourage adoption if people could continue to use their
existing SIP clients with a P2P-SIP infrastructure.    Also I believe
that the client's user function is logically quite separate from the
peer function.

Bill

-- 
Bill McCormick

---

From: "Brian Rosen" <[email-masked]>
Date: Wed, 28 Feb 2007 15:45:25 -0500

To me, this is an "add-on".  You create a new proxy-server like entity that
is a peer with a sip UA interface and off you go.  It has the advantage of
being able to use off-the-shelf SIP UAs.  It has the disadvantage of not
really being peer to peer, it's more like peer domain to peer domain, but so
what, it works.

I think, though, that it's not subject to standardization.  The SIP side is
defined, and what we're working on is the p2p side (or d2d from your point
of view).  Whether the actual multimedia endpoint is inside what we are
defining, or connected via standard sip is an implementation issue.  I
certainly agree that as we define the p2p protocol, we keep this particular
deployment in mind.

I don't think many of us think of the "client" as an off the shelf sip UA
though, or, speaking strictly for myself, my model of a client is a real p2p
client, where there is no proxy server equivalent.  The client is all there
is.  We have to deal with relays to get around NAT issues; fact of life, but
that is the only thing stopping us from building true transparent p2p
clients, as multimedia endpoints on the Internet.

Brian

> From: Bill Mccormick [mailto:[email-masked]]
> Sent: Wednesday, February 28, 2007 3:22 PM
> To: Philip Matthews
> Cc: [email-masked]
> Subject: Re: [P2PSIP] Concepts draft and P2PSIP clients
>

---

From: Philip Matthews <[email-masked]>
Date: Wed, 28 Feb 2007 16:05:29 -0500

Brian:

Your brief description below happens to match exactly the description
of a "peer" in Concepts-03.

What I think you might be referring to is the  super-peer / ordinary- 
peer approach
to NAT Traversal. I will mention this approach in Concepts-04, but it  
is my impression
that we agreed to the alternative approach of treating all peers as  
equal
for NAT Traversal.

- Philip

---

From: 张锦辉 <[email-masked]>
Date: Thu, 01 Mar 2007 11:04:00 +0800

Hi, Brian:
On the issues, my private opinion is same with you.
There are a large number of clients on the internet, if we can use a part of
memories of these clients, we can story more information than we just use
peers’ memories. But on another way, if all of clients participate in
message routing, the routing delay will be a long time. So I think client
should not participate in routing.

-----Original Message-----
From: Brian Rosen [mailto:[email-masked]] 
Sent: Thursday, March 01, 2007 4:18 AM
To: 'Philip Matthews'; [email-masked]
Subject: RE: [P2PSIP] Concepts draft and P2PSIP clients

Brian