Subject: [P2PSIP] Re: [p2p-sip] Concept Draft Open Issue #7: Add concept of "Admittingpeer"?

From: Spencer Dawkins <[email-masked]>
Date: Tue, 20 Feb 2007 10:15:32 -0600

I didn't see any followup onlist for this open issue, and wanted to say that 
I agree with Philip's proposal.

Thanks,

Spencer

> Open Issue #7: David Bryan and Bruce Lowekamp,
> in draft-bryan-sipping-p2p-03, have introduced the concept
> of an "admitting peer" as the peer that helps the "joining peer"
> join the Overlay.
>
> In their scheme, the "joining peer" initially contacts
> a "bootstrap peer". However, the bootstrap peer, rather
> than doing the work to help the joining peer join the overlay,
> instead immediately refers the bootstrap peer to another
> peer which is better suited to help the joining peer
> join the overlay. For example, in their draft, the
> admitting peer is the future successor of the joining peer.
>
> In some work that Eric Cooper and I have been looking at recently,
> we have also seen the advantage of distinguishing between
> the bootstrap peer and the admitting peer.
>
> Note that the bootstrap peer and the admitting peer may be the same node
> in some cases (in David's case, if the bootstrap peer just happens
> to be the future successor of the joining peer).
>
> This also leads to a possible terminology changes.
> First of all, the term "joining peer" as the name for the peer
> that is joining the overlay.
> Second, replacing the current term "peer insertion" with
> "peer admission", to show that the Overlay may reject the
> joining peer, if the joining peer does not have the correct
> credentials to join.
>
> Proposal:  Add the above concepts to the Concepts draft,
> along with the proposed terminology changes.
>
> Comments?
>
> - Philip 

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: Dean Willis <[email-masked]>
Date: Wed, 21 Feb 2007 16:29:10 -0600

I agree with Spencer on this one, making for a transitive agreement  
with Philip's proposals.

--
Dean

On Feb 20, 2007, at 10:15 AM, Spencer Dawkins wrote:

> I didn't see any followup onlist for this open issue, and wanted to  
> say that I agree with Philip's proposal.
>
> Philip said:
>>