Subject: Re: [P2PSIP] Roles

From: "Victor Pascual Ávila" <[email-masked]>
Date: Sat, 14 Apr 2007 11:46:04 +0200

What about the leaving node? When a responsible node for a dht-hash area
performs a planned leave from the overlay it should delegate it's
responsibilities when possible. Is it correct?

Thanks, Victor Pascual

On 27/03/07, zhuxian <[email-masked]> wrote:
>
>  EdPimentl,
>
> These authentication mechanisms are typical used in the C/S model. In the
> P2P model, SAML assertion or identity can be easily replayed, for the peer
> receieved the assertion can replay it. But this may not be happened in the
> C/S model, as we often believed that the server is trusted enough.
>
> So, even we use the SAML assertion, it also need some authentication
> mechanisms to prove the peer sending the SAML assertion is the peer owning
> the SAML assertion.
>
> This is why I believe that peer should authenticate each other at all
> times.
>
>
> Kurt Zhu
>
>  ------------------------------
> *From:* EdPimentl [mailto:[email-masked]]
> *Sent:* Saturday, March 24, 2007 1:44 AM
> *To:* zhuxian
> *Cc:* David A. Bryan; Henning Schulzrinne; Philip Matthews;
> [email-masked]
> *Subject:* Re: [P2PSIP] Roles
>
> As we explore authentication mechanisms.
> It would good to consider one of the following methods for authentication,
> authorizations and entitlements such as:
> http://dev.inames.net/wiki/Tech_FAQs
> http://www.sourceid.org/
> http://www.projectliberty.org/
>
> My .02
> Best,
> -E
>
>
>
> On 3/23/07, zhuxian <[email-masked]> wrote:
> >
> > I fully agree with the following sentence from David:
> >     In a peer-to-peer system, all peers must check all credentials at
> > all
> > times.
> >
> > Even if a centralized authentication server has been deployed in the
> > hybrid-p2p scenario, every peer should also authenticate each other at
> > all
> > times. Otherwise, the peer could not confirm whether another peer is
> > admited
> > by the authentication server, or it just join the overlay through its
> > colluding peer.
> >
> > Kurt  Zhu
> >
> >
>
> --
> Thanks in advance and best regards,
>
> Ed Pimentel
> AgileCO
> Founder
>
> Mail:   edpimentl[at]gmail.com
> sip:    sip:[email-masked]
> IM:     edpimentl [AOL | Jabber | Yahoo | MSN ]
> Voip:   edpimentl [SKype | GoogleTalk ]
>
> Mobile Content Marketing/Management/Digital Delivery
> http://mobilecentral.ws
>
> Mobile ( Relevant, Ambient Intelligence, Location ) based Social Network
> http://TagR.mobi (Alpha)
>
> Mobile Payment - P2P Payment
> http://agilepay.ws
>
> Sponsor of P2PSIP  open source [viasip_ng] project
> Creating a standards base P2PSIP dSIP infrastructure
> https://sourceforge.net/projects/viasip/
> Mailing List [email-masked]
>
>
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/p2psip
>
>

-- 
Victor Pascual Ávila

mail:[email-masked]
sip:[email-masked]
fon user: 223364
_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: "David A. Bryan" <[email-masked]>
Date: Mon, 16 Apr 2007 10:41:10 -0400

Indeed, and use some mechanism to pass off any information it is
responsible for.

On 4/14/07, Victor Pascual Ávila <[email-masked]> wrote:
> > ________________________________
>  From: EdPimentl [mailto:[email-masked]]
> > Sent: Saturday, March 24, 2007 1:44 AM
> > To: zhuxian
> > Cc: David A. Bryan; Henning Schulzrinne; Philip Matthews; [email-masked]
> > Subject: Re: [P2PSIP] Roles
> >
> >
> >

-- 
David A. Bryan
[email-masked]
+1.757.565.0101 x101
+1.757.565.0088 (fax)
www.SIPeerior.com