Subject: RE: [P2PSIP] Peer definition in Concept draft

From: JiangXingFeng <[email-masked]>
Date: Mon, 02 Apr 2007 10:36:01 +0800

Hi, Eunsoo:

I agree with you that Peers and SIP entities are two independent roles in
the VoIP applications. Peers are organized collectively to provide
distributed location service whereas SIP entities use SIP protocol to
establish sessions.

Since nodes who behave as peers in P2P perspective may not speak SIP, I have
two questions arising from it:

1) How do the peers who could not recognize SIP messages use SIP to deliver
P2P message?

2) How do the non-peer nodes put/get resource information into/from the
overlay only by using SIP message if the peers who the non-peer nodes
contact with could not speak SIP? 

Regards!

--
Jiang XingFeng
________________________________________
From: Eunsoo Shim [mailto:[email-masked]] 
Sent: Saturday, March 31, 2007 9:06 PM
To: JiangXingFeng
Cc: Philip Matthews; [email-masked]
Subject: Re: [P2PSIP] Peer definition in Concept draft

A peer may not be coupled to any SIP entity.
If we assume the Peer Protocol is not based on SIP, the above means that a
peer may not have to speak SIP. Actually we should say that it is not the
peer but the SIP entity that speaks SIP. 

A peer MUST be able to speak the Peer Protocol.

Thanks.

Eunsoo
On 3/31/07, JiangXingFeng < [email-masked]> wrote:
Hi, Philips:

I have noticed that there are minor differences between version 03 and 
version 04.  I list them as follows:
Version 3:
Each P2PSIP Peer may or may not (NOT) be coupled to one or more P2PSIP User
Agents.
Version 4:
Each P2PSIP Peer may be coupled to one or more SIP entities. 

By comparing the difference, could we come to a conclusion that all peers
should speak SIP in the version 04?

Regards!
--
Jiang XingFeng

_______________________________________________ 
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: Peili Xu <[email-masked]>
Date: Mon, 02 Apr 2007 11:47:17 +0800

Hi Xingfeng

see inline

-----Original Message-----
From: JiangXingFeng [mailto:[email-masked]] 
Sent: Monday, April 02, 2007 10:36 AM
To: 'Eunsoo Shim'
Cc: 'Philip Matthews'; [email-masked]
Subject: RE: [P2PSIP] Peer definition in Concept draft

Hi, Eunsoo:

I agree with you that Peers and SIP entities are two
independent roles in the VoIP applications. Peers are
organized collectively to provide distributed location
service whereas SIP entities use SIP protocol to
establish sessions.

Since nodes who behave as peers in P2P perspective may
not speak SIP, I have two questions arising from it:

1) How do the peers who could not recognize SIP messages
use SIP to deliver P2P message?

[xpl] there is no assumption that SIP is used to deliver
P2P message.

2) How do the non-peer nodes put/get resource
information into/from the overlay only by using SIP
message if the peers who the non-peer nodes contact with
could not speak SIP? 

[xpl] Not all peer must speak SIP doesn't mean a peer
can not speek SIP. 
In the case u mentioned, the peer who get/put resource
info in to the DHT unbehalf of a non-peer SIP entity can
speak SIP if the interface between non-peer and peer is
only SIP.

[xpl] But, it is still uncertain for interfaces and
protocol requirements for entities before the protocol
selection was made.

Regards!

A peer may not be coupled to any SIP entity.
If we assume the Peer Protocol is not based on SIP, the
above means that a peer may not have to speak SIP.
Actually we should say that it is not the peer but the
SIP entity that speaks SIP. 

Thanks.

Eunsoo

I have noticed that there are minor differences between
version 03 and version 04.  I list them as follows:
Version 3:
Each P2PSIP Peer may or may not (NOT) be coupled to one
or more P2PSIP User Agents.
Version 4:
Each P2PSIP Peer may be coupled to one or more SIP
entities. 

By comparing the difference, could we come to a
conclusion that all peers should speak SIP in the
version 04?

Regards!
--
Jiang XingFeng