Subject: [P2PSIP] An I-D about P2PSIP diagnosis, any comment is appreciated.

From: Zheng Hewen <[email-masked]>
Date: Thu, 13 Dec 2007 15:00:09 +0800

Hi,

    We extended our peer protocol (SEP: Service Extensible P2P Peer Protocol, 
http://tools.ietf.org/wg/p2psip/draft-jiang-p2psip-sep-00.txt) to implement P2PSIP diagnosis 
(http://www.ietf.org/internet-drafts/draft-zheng-p2psip-diagnose-00.txt).
    This document describes a simple and efficient mechanism that can be used to detect and localize failures in P2PSIP 
overlay network.  This document mainly consists of two parts: information carried in a P2PSIP Peer "Echo request" message and 
"Echo response" message for the purpose of fault detection and localization, and mechanisms for processing those messages.
    Any comment is appreciated.

   BTW, this I-D was finished before IETF70 as P2PSIP client protocol 
(http://www.ietf.org/internet-drafts/draft-zheng-p2psip-client-protocol-00.txt), they failed to be submitted due to mail 
server, we have to submit them today through https://datatracker.ietf.org/idst/upload.cgi after only changing creation date 
according to "IETF Internet-Draft Submission tool's requirement".

Best regards,
Hewen

> -----Original Message-----
> From: IETF I-D Submission Tool [mailto:[email-masked]]
> Sent: 2007Äê12ÔÂ13ÈÕ 14:33
> To: [email-masked]
> Cc: [email-masked]
> Subject: New Version Notification for draft-zheng-p2psip-diagnose-00
>
>
> A new version of I-D, draft-zheng-p2psip-diagnose-00.txt has
> been successfuly submitted by Hewen Zhang and posted to the
> IETF repository.
>
> Filename:	 draft-zheng-p2psip-diagnose
> Revision:	 00
> Title:		 Diagnose P2PSIP Overlay Network Failures
> Creation_date:	 2007-12-11
> WG ID:		 Independent Submission
> Number_of_pages: 21
>
> Abstract:
> This document describes a simple and efficient mechanism that
> can be used to detect and localize failures in P2PSIP overlay
> network.  This document mainly consists of two parts:
> information carried in a P2PSIP Peer "Echo request" message
> and "Echo response" message for the purpose of fault
> detection and localization, and mechanisms for processing
> those messages.
>
>
>
>
> The IETF Secretariat.
>
>
>

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: Joakim Koskela <[email-masked]>
Date: Thu, 13 Dec 2007 10:17:38 +0200

Hi,

Maybe I missed something, but how were you planning to use the traceroute 
packet? I mean, it will certainly tell you where the problem is and is good 
for debugging the network, but do you have plans for using the info somehow 
else (e.g. for somehow circumventing problem spots through source routing)?

br ,j

On Thursday 13 December 2007 09:00:09 Zheng Hewen wrote:
> Hi,
>
>     We extended our peer protocol (SEP: Service Extensible P2P Peer
> Protocol, http://tools.ietf.org/wg/p2psip/draft-jiang-p2psip-sep-00.txt) to
> implement P2PSIP diagnosis
> This document describes a simple and efficient mechanism that can be used
> to detect and localize failures in P2PSIP overlay network.  This document
> mainly consists of two parts: information carried in a P2PSIP Peer "Echo
> request" message and "Echo response" message for the purpose of fault
> detection and localization, and mechanisms for processing those messages.
> (http://www.ietf.org/internet-drafts/draft-zheng-p2psip-client-protocol-00.
>txt), they failed to be submitted due to mail server, we have to submit them
> today through https://datatracker.ietf.org/idst/upload.cgi after only
> changing creation date according to "IETF Internet-Draft Submission tool's
> requirement".
>
> Best regards,
> Hewen
>

---

From: Zheng Hewen <[email-masked]>
Date: Thu, 13 Dec 2007 19:25:41 +0800

Hi,

   You are right, this I-D only provides on-demand/periodic P2PSIP diagnosis tool, and it does not describe how to use the 
diagnosis result.
   Certainly, as said in "Security requirements in 
P2PSIP"(http://tools.ietf.org/wg/p2psip/draft-matuszewski-p2psip-security-requirements-02.txt), "Req. 16: It SHOULD be 
possible to limit the impact of badly behaving P2PSIP nodes on the overall system security.  There SHOULD be an option to 
identify malfunctioning or badly behaving nodes, and exclude or reject them from the P2PSIP system."
   This I-D provides tools to identify (i.e., detect and localize) malfunctioning or badly behaving nodes, but how to exclude 
or reject them from the P2PSIP system? Source routing is a good idea, blacklisting is another idea. Essentially those are 
already some implementations about how to use P2P diagnosis result in open papers (there is an index in RFC4981).
    Currently we have no plan to describe how to use the info, but I will be very interested in your plan if possible.

Best regards,
Hewen

> From: Joakim Koskela [mailto:[email-masked]]
> Sent: 2007Äê12ÔÂ13ÈÕ 16:18
> To: [email-masked]
> Cc: Zheng Hewen
> Subject: Re: [P2PSIP] An I-D about P2PSIP diagnosis, any
> comment is appreciated.
>
> Hi,
>
> Maybe I missed something, but how were you planning to use
> the traceroute packet? I mean, it will certainly tell you
> where the problem is and is good for debugging the network,
> but do you have plans for using the info somehow else (e.g.
> for somehow circumventing problem spots through source routing)?
>
> br ,j
>
> > Protocol,
> > This document describes a simple and efficient mechanism
> that can be
> > used to detect and localize failures in P2PSIP overlay
> network.  This
> > document mainly consists of two parts: information carried
> in a P2PSIP
> > Peer "Echo request" message and "Echo response" message for the
> > purpose of fault detection and localization, and mechanisms
> for processing those messages.
> >txt), they failed to be submitted due to mail server, we
> have to submit
> >them  today through
> https://datatracker.ietf.org/idst/upload.cgi after
> >only  changing creation date according to "IETF Internet-Draft
> >Submission tool's  requirement".
> >
> > Best regards,
> > Hewen
> >
> > > Sent: 20071213 14:33
> > > A new version of I-D, draft-zheng-p2psip-diagnose-00.txt has been
> > > successfuly submitted by Hewen Zhang and posted to the IETF
> > > repository.
> > >
> > > This document describes a simple and efficient mechanism
> that can be
> > > used to detect and localize failures in P2PSIP overlay network.
> > > This document mainly consists of two parts:
> > > information carried in a P2PSIP Peer "Echo request" message and
> > > "Echo response" message for the purpose of fault detection and
> > > localization, and mechanisms for processing those messages.
> > >
> > >
> > >
> > >
> > > The IETF Secretariat.
> >

---

From: "Henry Sinnreich" <[email-masked]>
Date: Thu, 13 Dec 2007 07:19:02 -0800

Hewen,

Can you share with us if this is only a concept paper or if you also have tested the concept with running code?

Thanks, Henry

-----Original Message-----
From: Zheng Hewen [mailto:[email-masked]] 
Sent: Thursday, December 13, 2007 1:00 AM
To: 'P2PSIP Mailing List'
Subject: [P2PSIP] An I-D about P2PSIP diagnosis, any comment is appreciated.

Hi,

Best regards,
Hewen

---

From: Zheng Hewen <[email-masked]>
Date: Fri, 14 Dec 2007 09:23:23 +0800

Hi,

   We already implemented Peer protocol proposal (http://tools.ietf.org/wg/p2psip/draft-jiang-p2psip-sep-00.txt) and Client
protocol proposal (http://tools.ietf.org/wg/p2psip/draft-pascual-p2psip-clients-00.txt) in our prototype system, we are
implementing P2PSIP diagnosis proposal (http://tools.ietf.org/wg/p2psip/draft-zheng-p2psip-diagnose-00.txt) in our prototype
system, any comment is welcome.

Thanks,
Hewen

> From: Henry Sinnreich [mailto:[email-masked]]
> Sent: 2007?12?13? 23:19
> To: Zheng Hewen; P2PSIP Mailing List
> Subject: RE: [P2PSIP] An I-D about P2PSIP diagnosis, any
> comment is appreciated.
>
> Hewen,
>
> Can you share with us if this is only a concept paper or if
> you also have tested the concept with running code?
>
> Thanks, Henry
>
> that can be used to detect and localize failures in P2PSIP
> overlay network.  This document mainly consists of two parts:
> (http://www.ietf.org/internet-drafts/draft-zheng-p2psip-client
> -protocol-00.txt), they failed to be submitted due to mail
> server, we have to submit them today through
> https://datatracker.ietf.org/idst/upload.cgi after only
> changing creation date according to "IETF Internet-Draft
> > document mainly consists of two parts:
> and "Echo
> > response" message for the purpose of fault detection and
> localization,
> > and mechanisms for processing those messages.
> >
> >
> >
> >
> > The IETF Secretariat.
> >
> >
> >
>
>
>
>
>