Subject: Re: [P2PSIP] Agenda for the upcoming meeting in Vancouver (existentialist topics)

From: "Jani Hautakorpi (JO/LMF)" <[email-masked]>
Date: Mon, 03 Dec 2007 13:38:42 -0800

Hi Henry,

Please find my answers to your questions below.

Henry Sinnreich wrote:
>> the with-hip mechanisms can be embedded 
>> to the P2PSIP applications.
> 
> This means that on the laptop I am currently using there would be two TCP/IP stacks:

HIP implementations do not require two TCP/IP stacks. It seems to be 
quite common misconception that HIP implementations would require 
changes to the operating system and network stack, which is not the case.

> 1. The native TCP/IP stack of the existing OS (WinXP in my case),
> 
> 2. A 2nd TCP stack in the P2PSIP application. While this would work,
> I  am wondering about the performance and ease of integrating with WinXP
> (in my example).
> 
> 3. I would need to duplicate the expertise put in the existing TCP/IP
> stack that has taken years to develop to where it is now.
> 
> 4. Don't residential routers and other network elements have to
> understand HIP?

No they don't. There is no such functions in HIP which would require 
HIP-aware routers (or other middleboxes).

-- 
Jani

> -----Original Message-----
> From: Jani Hautakorpi (JO/LMF) [mailto:[email-masked]] 
> Sent: Thursday, November 29, 2007 5:43 AM
> To: Henry Sinnreich
> Cc: David A. Bryan; Eric Rescorla; P2PSIP Mailing List
> Subject: Re: [P2PSIP] Agenda for the upcoming meeting in Vancouver (existentialist topics)
> 
> Hi Henry,
> 
> Henry Sinnreich wrote:
>> Both David and EKR make some very good arguments, though I believe the
>> central theme should be the existentialist topics for P2PSIP and have
>> changed the subject title accordingly. Here are some examples:
>>
>> ...
>>
>> 2.2. Solutions based on HIP and other NG Internet technologies.
>>
>> What is the risk assessment they may actually happen and when?
> 
> I didn't quite understand this question. Could you clarify what you 
> meant by this?
> 
> I would like to point out that, for example, the mechanisms in with-hip 
> draft does not require global deployment of HIP-enabled operating 
> systems or anything like that; the with-hip mechanisms can be embedded 
> to the P2PSIP applications.
> 

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: Dean Willis <[email-masked]>
Date: Tue, 4 Dec 2007 01:32:03 -0600

>> ers and other network elements have to
>> understand HIP?
>
> No they don't. There is no such functions in HIP which would  
> require HIP-aware routers (or other middleboxes).
>
>

They do need to be at least HIP tolerant. I think my firewall drops  
protocol 253 into the bit-bucket.

--
Dean

---

From: "Jani Hautakorpi (JO/LMF)" <[email-masked]>
Date: Tue, 04 Dec 2007 09:31:22 -0800

Hi Dean,

> protocol 253 into the bit-bucket.

HIP's extension for NAT traversal makes it possible to use UDP 
encapsulation for HIP control packets. So, intermediary network elements 
does not need to be HIP-aware.

-- 
Jani

---

From: Spencer Dawkins <[email-masked]>
Date: Tue, 04 Dec 2007 10:10:13 -0800

I've said this privately but not onlist - sorry.

I would really love to agree on a protocol stack for these proposals. If 
there's a known answer, that's fine, but I haven't found it yet.

Spencer