Subject: Re: [P2PSIP] Client discussion in Vancouver

From: "Eunsoo Shim" <[email-masked]>
Date: Sat, 1 Dec 2007 00:07:42 -0500

The fundamental difference between Peer and Client?
Peers do something (overlay maintenance and routing)
Clients do not it.
That's why the slides use the analogy of saying Peers are 'routing'
nodes and Clients are 'non-routing' nodes.

Don't look for what Peers do differently from Clients.
Look for what Peers do that Clients do not.

Thanks.

Eunsoo

On Nov 30, 2007 9:29 PM, Dean Willis <[email-masked]> wrote:
>
> On Nov 30, 2007, at 7:21 PM, <[email-masked]>
>
> <[email-masked]> wrote:
>
> >
> > Hi all,
> >
> > Please see a draft version of the presentation about clients. Any
> > comments appreciated!
> > http://netlabathut.googlepages.com/Clients_02.ppt
> >
>
> This still doesn't say a lot about what peers really do differently
> from clients. Perhaps it would be better expressed as a set of use
> cases?
>
> --
> Dean
>
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/p2psip
>

-- 
Eunsoo

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: "Henry Sinnreich" <[email-masked]>
Date: Sat, 1 Dec 2007 06:39:01 -0800

I suggest edits for two items:

*	A device should become a peer whenever possible

This is not always possible or desirable in certain usage scenarios

*	Resource limitations + churn/intermittent connectivity make a
poor peer

Replace "poor " with "undesirable", since the churn on the overlay
outweighs the benefit of having this peer. 

This is the reason why small mobile devices may be undesirable peers.
Some analytical work with numbers would be helpful here.

Henry

________________________________

From: [email-masked] [mailto:[email-masked]]

Sent: Friday, November 30, 2007 7:21 PM
To: [email-masked]
Subject: [P2PSIP] Client discussion in Vancouver

Hi all, 

Please see a draft version of the presentation about clients. Any
comments appreciated! 
http://netlabathut.googlepages.com/Clients_02.ppt
<http://netlabathut.googlepages.com/Clients_02.ppt>  

Marcin

---

From: <[email-masked]>
Date: Sun, 2 Dec 2007 20:07:50 +0200

Hi Henry,
 
Thanks for your comments! Answers inline...

	From: ext Henry Sinnreich [mailto:[email-masked]] 
	Sent: 01 December, 2007 06:39
	To: Matuszewski Marcin (Nokia-NRC/Helsinki); [email-masked]
	Subject: RE: [P2PSIP] Client discussion in Vancouver

	This is not always possible or desirable in certain usage
scenarios

	I agree that it is not always possible or desirable for a device
to become a peer. The idea behind this sentence is that a device should
become a peer, subject to resource constraints, policy, security and a
charging model.   

	*	Resource limitations + churn/intermittent connectivity
make a poor peer 

	Replace "poor " with "undesirable", since the churn on the
overlay outweighs the benefit of having this peer. 

	This is the reason why small mobile devices may be undesirable
peers. Some analytical work with numbers would be helpful here.

	Ok I will modify it.

	Henry

	Marcin

	From: [email-masked]
[mailto:[email-masked]] 
	Sent: Friday, November 30, 2007 7:21 PM
	To: [email-masked]
	Subject: [P2PSIP] Client discussion in Vancouver

	Hi all, 

	Please see a draft version of the presentation about clients.
Any comments appreciated! 
	http://netlabathut.googlepages.com/Clients_02.ppt
<http://netlabathut.googlepages.com/Clients_02.ppt>  

	Marcin

---

From: <[email-masked]>
Date: Sun, 2 Dec 2007 20:32:16 +0200

Hi Dean,

I agree with Eunsoo.

The idea is to decouple the service layer from the overlay layer. As
Eunsoo wrote there is a fundamental difference between clients and peers
on the overlay layer, whereas the difference between peers and clients
on the service layer depends on a use case scenario. We can discuss use
cases forever and do not cover all of them. 

I will show some results of measurements. 

Marcin  

>-----Original Message-----
>From: ext Eunsoo Shim [mailto:[email-masked]] 
>Sent: 30 November, 2007 21:08
>To: Dean Willis
>Cc: Matuszewski Marcin (Nokia-NRC/Helsinki); [email-masked]
>Subject: Re: [P2PSIP] Client discussion in Vancouver
>
>Peers do something (overlay maintenance and routing) Clients do not it.

---

From: Enrico Marocco <[email-masked]>
Date: Sun, 02 Dec 2007 10:49:01 -0800

> I will show some results of measurements. 

It is quite clear what people advocating for clients think the
difference between clients and peers is.  The issue is _why_ do we need
to define clients.  If the only reason is "because clients need to
perform GET operations to find user contacts to send SIP messages to,
without being involved in routing and overlay maintainance", well,
that's probably not enough a reason because, as it has been shown, the
same result is achievable by making non-peer nodes simply acting as pure
SIP UAs.  If you have other use cases in mind, it is probably worth to
discuss them during the live meeting.

-- 
Ciao,
Enrico

---

From: <[email-masked]>
Date: Sun, 2 Dec 2007 21:24:38 +0200

Hi Enrico,

Did you have time to look at the slides about the client node type I
sent on Friday?
The slides 2-3 discuss the differences between a SIP UA and a client.
Please let me know if something is unclear or should be changed. 

Marcin

>From: ext Enrico Marocco [mailto:[email-masked]] 
>Sent: 02 December, 2007 10:49
>To: Matuszewski Marcin (Nokia-NRC/Helsinki)
>Cc: [email-masked]; [email-masked]; [email-masked]
>> Eunsoo wrote there is a fundamental difference between clients and 
>> peers on the overlay layer, whereas the difference between peers and 
>> clients on the service layer depends on a use case scenario. We can 
>> discuss use cases forever and do not cover all of them.
>> 
>difference between clients and peers is.  The issue is _why_ 
>do we need to define clients.  If the only reason is "because 
>clients need to perform GET operations to find user contacts 
>to send SIP messages to, without being involved in routing and 
>overlay maintainance", well, that's probably not enough a 
>reason because, as it has been shown, the same result is 
>achievable by making non-peer nodes simply acting as pure SIP 
>UAs.  If you have other use cases in mind, it is probably 
>worth to discuss them during the live meeting.
>
>--
>Ciao,
>Enrico
>

---

From: Enrico Marocco <[email-masked]>
Date: Sun, 02 Dec 2007 11:36:05 -0800

> Please let me know if something is unclear or should be changed. 

Yes, I did read the slides as well as many of the discussions happened
on the list and during the last five meetings.  It is probably clear to
most of the people in the group what you mean by "client" and what's the
difference between clients, peers and SIP user agents.  What's probably
not so clear, at least to me, is in which cases such a differentiation
is important.  Do you think having clients (other than SIP UAs) is
important to implement overlay-based services such as voice-mail or
certificate/key repository for which SIP is not enough?  It may be
reasonable, but we really need a list of them to base a discussion on.