Subject: Re: Replication - Was Re: [P2PSIP] Merge of ASP and RELOAD - VersionNotification fordraft-bryan-p2psip-reload-02

From: Ingmar Baumgart <[email-masked]>
Date: Mon, 03 Dec 2007 11:35:24 -0800

Song Yongchao wrote:
> That was also my point. Replication handled by either layer, or either the
> source peer or the responsible peer, has its pros and cons. 
> 
> However, for the peer protocol, should only take the replication handled by
> distributed storage layer into account, either by the source peer or the
> responsible peer. For the availability when the source peer is offline, I
> prefer the responsible peer to do it.
> 
> Of course, whether or not to replicate in the overlay is left to the
> decision of the overlay operator. 

Is there an overlay operator? In draft-ietf-p2psip-concepts-01 there is
no such definition.

In my opinion replication is a must, because nodes can always fail.

Regards,
  Ingmar

-- 
Dipl.-Inform. Ingmar Baumgart
Institut für Telematik, Universität Karlsruhe (TH)
Zirkel 2, 76128 Karlsruhe, Germany
Phone: +49 721 608 8281, Fax: +49 721 608 6789

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: Song Yongchao <[email-masked]>
Date: Tue, 04 Dec 2007 09:13:58 +0800

> -----Original Message-----
> From: Ingmar Baumgart [mailto:[email-masked]]
> Sent: Tuesday, December 04, 2007 3:35 AM
> To: Song Yongchao
> Cc: 'Jan Seedorf'; 'Cullen Jennings'; 'P2PSIP WG'
> Subject: Re: Replication - Was Re: [P2PSIP] Merge of ASP and RELOAD
> -VersionNotification fordraft-bryan-p2psip-reload-02
> 
> Song Yongchao wrote:

Maybe I should change "the overlay operator" into "smart implemention".

In a certain application scenario, an ISP may deploy an overlay, in which
all peers are powerful machines provided by the ISP. These peers hardly
fail. Customers get the service of the overlay as clients. The ISP can
determine whether or not to replicate in the overlay, or just introduce a
backup mechanism, by considering the applications running on the overlay or
by his own will.

However, in more scenarios, peers are always involved in churn. Replication
must be adopted in these scenarios.

Best Regards!
Song Yongchao