Subject: [P2PSIP] ask about message routing API in RELOAD protocol

From: [email-masked]
Date: Thu, 17 Jul 2008 10:49:04 +0800

Subject: [P2PSIP] ask about message routing API in RELOAD protocol
From: [email-masked]
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Thu, 17 Jul 2008 10:49:04 +0800

Dear Sir,

I am studying P2PSIP related technologies, including the new draft RELOAD
specification. If I am an RELOAD implementor, what interfaces should I
provide to my user, say Usage layer? Maybe SIP Usage or SIP Application for
telephony service. According to RELOAD specification, the message routing
API is defended. Are there any specific detail specification on this API?
Could someone please instruct me to understand this API further? Thanks in
advance.

BR,
Jeffrey

本信件可能包含工研院機密資訊，非指定之收件者，請勿使用或揭露本信件內容，並請銷毀此信件。
This email may contain confidential information. Please do not use or disclose it in any way and delete it if you are not the intended recipient.

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 20 Jul 2008 12:02:51 -0700

On Jul 16, 2008, at 7:49 PM, [email-masked] wrote:

> Dear Sir,
>
> I am studying P2PSIP related technologies, including the new draft  
> RELOAD specification. If I am an RELOAD implementor, what interfaces  
> should I provide to my user, say Usage layer? Maybe SIP Usage or SIP  
> Application for telephony service. According to RELOAD  
> specification, the message routing API is defended. Are there any  
> specific detail specification on this API? Could someone please  
> instruct me to understand this API further? Thanks in advance.
>
> BR,
> Jeffrey
>

I don't think much work has been done at IETF of trying to define the  
usage layer API - sorry if the RELOAD implies otherwise, we should  
likely fix that.