Subject: [P2PSIP] Bootstrap peer reachability in draft-ietf-p2psip-base-00

From: "Narayanan, Vidya" <[email-masked]>
Date: Fri, 14 Nov 2008 00:46:46 -0800

All,
RELOAD requires that a node have a public IP address in order to serve as a bootstrap peer.  One issue with that is that there is no real way to know for sure that a particular address is globally routable.  Second, there may be overlays where this is not necessary at all (e.g., overlays formed entirely in an enterprise network may not have any peers that are globally reachable).  Third, a bootstrap peer is still useful even if it only helps a few peers get on the overlay.  

Hence, I don't think the requirement for serving as a bootstrap peer is to have a globally routable address.  Rather, it is to be reachable to at least some set of nodes wanting to join the overlay.  

Thoughts? 

- Vidya
_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip

---

From: jiangxingfeng 36340 <[email-masked]>
Date: Fri, 14 Nov 2008 17:00:23 +0800

I agree. "Public" here does not mean a global routable address. IMO, it depends on the scenarios. As you mentioned, in some closed overlay, it does not require bootstrap peer to have a public address. It only requires that the bootstrap peers can be reached by any other peers in the same overlay directly. In relay draft(http://tools.ietf.org/id/draft-jiang-p2psip-relay-00.txt), authors propose a mechanism to determine whether a peer can be a
 "public peer". 

I'd like to add a term in concetp draft to make "public" more clear. 

Regards 

Jiang XingFeng

> All,
> RELOAD requires that a node have a public IP address in order to 
> serve as a bootstrap peer.  One issue with that is that there is 
> no real way to know for sure that a particular address is globally 
> routable.  Second, there may be overlays where this is not 
> necessary at all (e.g., overlays formed entirely in an enterprise 
> network may not have any peers that are globally reachable).  
> Third, a bootstrap peer is still useful even if it only helps a 
> few peers get on the overlay.  
> 
> Hence, I don't think the requirement for serving as a bootstrap 
> peer is to have a globally routable address.  Rather, it is to be 
> reachable to at least some set of nodes wanting to join the 
> overlay.  
> 
> Thoughts? 
> 
> - Vidya

---

From: Dean Willis <[email-masked]>
Date: Sat, 15 Nov 2008 18:17:11 -0600

On Nov 14, 2008, at 3:00 AM, jiangxingfeng 36340 wrote:

> I agree. "Public" here does not mean a global routable address. IMO,  
> it depends on the scenarios. As you mentioned, in some closed  
> overlay, it does not require bootstrap peer to have a public  
> address. It only requires that the bootstrap peers can be reached by  
> any other peers in the same overlay directly. In relay draft(http://tools.ietf.org/id/draft-jiang-p2psip-relay-00.txt 
> ), authors propose a mechanism to determine whether a peer can be a
> "public peer".
>

What term would you like to add?

--
Dean

---

From: jiangxingfeng 36340 <[email-masked]>
Date: Sat, 15 Nov 2008 22:31:19 -0600

Hi,Dean:

Maybe a term named "publicly reachable" should be added. With the new term, we can be clear on the semantics of "public".

I also defined the term in draft-jiang-p2psip-relay-00(http://tools.ietf.org/id/draft-jiang-p2psip-relay-00.txt) as the follows:

  publicly reachable: A node is publicly reachable if it can receive
      unsolicited messages from any other node in the same overlay.
      Note: "publicly" does not mean that the nodes MUST be on the
      public Internet, because RELOAD protocol may be used in a closed
      system.

Hope it is helpful.

Regards
Jiang XingFeng

> > any other peers in the same overlay directly. In relay 
> draft(http://tools.ietf.org/id/draft-jiang-p2psip-relay-00.txt

---

From: "Das, Saumitra" <[email-masked]>
Date: Sun, 16 Nov 2008 00:43:13 -0800

I think we could be a little more flexible than that too. As long as a bootstrap peer can allow some devices to join the overlay and is not reachable by every node in the overlay it can still function as a bootstrap peer. A node behind a NAT at a small office may be a bootstrap peer for nodes in that office since it is part of a larger overlay although it is not reachable by every member of the overlay.

What Jiang suggests is definitely an improvement over the current definition.

Best,
Saumitra

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of jiangxingfeng 36340
Sent: Saturday, November 15, 2008 8:31 PM
To: Dean Willis
Cc: [email-masked]
Subject: [P2PSIP] 回复 :Re: Bootstrap peer reachability in draft-ietf-p2psip-base-00

Hi,Dean:

Hope it is helpful.

Regards
Jiang XingFeng

---

From: jiangxingfeng 36340 <[email-masked]>
Date: Sun, 16 Nov 2008 10:31:54 -0600

Hi, Das:

The term I proposed currently is just for make the meaning of "public" clearer, because it can be used in several situations. For example, when descriping a peer is eligible for a bootstrap peer, relay peer, or turn peer, we need it. 

As for your suggestion, I think it's ok. but my concern is that currently it is hard to determine whether two peers are behind the same NAT or not. The more reliable way is to choose some "publicly reachable" peers to be a bootstrap peer to ensure the success of bootstrap proecedure. In our relay draft, authors also propose a method to discover whether a peer is publicly reachable based on some work in BEHAVE WG. 

So my suggestion is that it is better to make any peer be a bootstrap peer if some mechanism could make other peers' bootstrap process succeed with high probability(if not succeed every time). But it seems it is not easy to achieve that at present. 

Regards

Jiang XingFeng

> I think we could be a little more flexible than that too. As long 
> as a bootstrap peer can allow some devices to join the overlay and 
> is not reachable by every node in the overlay it can still 
> function as a bootstrap peer. A node behind a NAT at a small 
> office may be a bootstrap peer for nodes in that office since it 
> is part of a larger overlay although it is not reachable by every 
> member of the overlay.
> 
> Maybe a term named "publicly reachable" should be added. With the 
> new term, we can be clear on the semantics of "public".
> 
> I also defined the term in draft-jiang-p2psip-relay-
> 00(http://tools.ietf.org/id/draft-jiang-p2psip-relay-00.txt) as 
> the follows:
> 
> > > I agree. "Public" here does not mean a global routable 
> address. 
> > IMO,  
> > > I'd like to add a term in concetp draft to make "public" more 
> clear.> 
> >