Subject: Re: [P2PSIP] draft-ietf-p2psip-base-06; message flow examples, leaving

From: [email-masked]
Date: Fri, 8 Jan 2010 11:17:51 +0800

Hi,
    1.here NP isn't neighbor peer but next peer,to see section 11, last 
two line of page 118
        "To populate its neighbor table, it needs the successor of AP, 
NP."
    2. I agree that the last Attach request is unwanted. Any other 
explaintion for it?

    3. I think the draft runs short of description about peer leaving 
flow. 
        Further, there are two type peer leaving scenarioes, gentlest and 
abrupt. The seconde one should be  considered  emphatically.

Best Regards!
+=======================================+
+  Hu Yongsheng                        +
+  Sys. Arch. ZTE Co.                  +
+  MSN:[email-masked]                + 
+  E-mail:[email-masked]      +
+  Tel:025-52878532                   +
+  Mobile:13912990713                  +
+=======================================+

Some comments:

Section 3.5.2 Joining, Leaving, and Maintenance Overview

  Joining is discussed in depth, Leaving and Maintenance seem to be 
missing.

Section 11, second message flow -- attach to neighbor peer

  Just before the TLS arrow from JP to NP, there's an extra arrow labelled 
'Attach' to the NP. Why is this necessary? Didn't JP already obtain NP's 
ICE candidates in the preceding Attach exchange shown in the diagram?

There's little text about leaving an overlay. Section 9 'Chord Algorithm' 
discusses it (9.8), but the algorithm- independent sections barely mention 
it.

Regards,

Wolfgang Beck

Deutsche Telekom Netzproduktion GmbH
Zentrum Technik Einführung
Wolfgang Beck
Heinrich-Hertz-Straße 3-7, 64295 Darmstadt
+49 6151 628 2832 (Tel.)
www.telekom.com

Erleben, was verbindet.

Deutsche Telekom Netzproduktion GmbH
Aufsichtsrat: Dr. Steffen Roehn (Vorsitzender)
Geschäftsführung: Dr. Bruno Jacobfeuerborn (Vorsitzender), Albert Matheis, 
Klaus Peren
Handelsregister: Amtsgericht Bonn HRB 14190
Sitz der Gesellschaft: Bonn
USt-IdNr. DE 814645262

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Sun Chongwei <[email-masked]>
Date: Wed, 13 Jan 2010 16:19:28 +0800

see the comments incline.

2010/1/8 <[email-masked]>

>
> Hi,
>     1.here NP isn't neighbor peer but next peer,to see section 11, last two
> line of page 118

NP is the successor of AP, Here NP is also the next peer of JP. Am I right?

see the diagram in page 119. there are two peers ,named NNP and PPP
separately.

 The author does not mention these two type peers in the test. Is there
anyone can tell me there meaning and fuction?

>     3. I think the draft runs short of description about peer leaving flow.
>
> +  MSN:[email-masked] <[email-masked]>                +
> +  E-mail:[email-masked] <[email-masked]>
>  +
> +  Tel:025-52878532                   +
> +  Mobile:13912990713                  +
>  Joining is discussed in depth, Leaving and Maintenance seem to be missing.
>
>
> 'Attach' to the NP. Why is this necessary? Didn't JP already obtain NP's ICE
> candidates in the preceding Attach exchange shown in the diagram?
>

-- 
Sun Chongwei
Mobile LIfe and New Media Lab
Beijing University of Posts and Telecommunications