Subject: [P2PSIP] draft-ietf-p2psip-base-06; message flow examples, leaving

From: <[email-masked]>
Date: Wed, 6 Jan 2010 16:14:45 +0100

Some comments:

Section 3.5.2 Joining, Leaving, and Maintenance Overview

  Joining is discussed in depth, Leaving and Maintenance seem to be missing.

Section 11, second message flow -- attach to neighbor peer

  Just before the TLS arrow from JP to NP, there's an extra arrow labelled 'Attach' to the NP. Why is this necessary? Didn't JP already obtain NP's ICE candidates in the preceding Attach exchange shown in the diagram?

There's little text about leaving an overlay. Section 9 'Chord Algorithm' discusses it (9.8), but the algorithm- independent sections barely mention it.

Regards,

Wolfgang Beck

Deutsche Telekom Netzproduktion GmbH
Zentrum Technik Einführung
Wolfgang Beck
Heinrich-Hertz-Straße 3-7, 64295 Darmstadt
+49 6151 628 2832 (Tel.)
www.telekom.com

Erleben, was verbindet.

Deutsche Telekom Netzproduktion GmbH
Aufsichtsrat: Dr. Steffen Roehn (Vorsitzender)
Geschäftsführung: Dr. Bruno Jacobfeuerborn (Vorsitzender), Albert Matheis, Klaus Peren
Handelsregister: Amtsgericht Bonn HRB 14190
Sitz der Gesellschaft: Bonn
USt-IdNr. DE 814645262

---

From: Sun Chongwei <[email-masked]>
Date: Thu, 7 Jan 2010 20:29:38 +0800

What is NP short for? I can not find its full name in the draft

Thank you!

2010/1/6 <[email-masked]>

>  Just before the TLS arrow from JP to NP, there's an extra arrow labelled
> 'Attach' to the NP. Why is this necessary? Didn't JP already obtain NP's ICE
> candidates in the preceding Attach exchange shown in the diagram?
>
> There's little text about leaving an overlay. Section 9 'Chord Algorithm'
> discusses it (9.8), but the algorithm- independent sections barely mention
> it.
>
>
>
> Regards,
>
> Wolfgang Beck
>
>
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip
>

-- 
Sun Chongwei
Mobile LIfe and New Media Lab
Beijing University of Posts and Telecommunications

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 13 Jan 2010 13:05:11 -0700

NP = Next Peer
NNP i= next next peer
JP Joining peer
AP admitting peer
PP previos peer
PPP previos previos peer
BP bootstrap peer