Subject: [P2PSIP] Routing in RELOAD

From: Jaime Jimenez <[email-masked]>
Date: Thu, 4 Nov 2010 17:26:56 +0200

Hi,
Very simple question. In RELOAD, why is the routing like this:

 A         B         X         Z
   -------------------------------

   ---------->
   Dest=Z
            ---------->
            Via=A
            Dest=Z
                      ---------->
                      Via=A, B
                      Dest=Z

                      <----------
                     Dest=X, B, A
            <----------
              Dest=B, A
   <----------
       Dest=A

And not like this?:

 A         B         X         Z
   -------------------------------

   ---------->

   Via=A

   Dest=Z
            ---------->
            Via=A, B
            Dest=Z
                      ---------->
                      Via=A, B, X
                      Dest=Z

                      <----------
                     Dest=X, B, A
            <----------
              Dest=B, A
   <----------
       Dest=A

Best Regards,
Jaime J.

---

From: Michael Chen <[email-masked]>
Date: Mon, 08 Nov 2010 21:00:44 -0800

Jaime,

This was answered quite some time ago (may be more than a year ago).
It is a security measure. When message is traveling from A to Z, A is
added to the destination list by B instead of by A so that A cannot fake
the message's origin or hide itself from the return route.

--Michael

On 11/4/2010 7:26 AM, Jaime Jimenez wrote:
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip