Subject: [P2PSIP] Mandatory extensions in RELOAD

From: Marc Petit-Huguenin <[email-masked]>
Date: Fri, 22 Apr 2011 10:16:50 -0700

As discussed during IETF 80, here's the text that I propose to add to RELOAD to
specify in the configuration that a node should not attempt to join an overlay
if it does not implement a specific set of extensions:

Section 10.1 (in the example):

"<mandatory-extension> urn:ietf:params:xml:ns:p2p:config-ext1
</mandatory-extension>"

Section 10.1 (in the list of elements inside a configuration element):

"mandatory-extension: This element contains the name of an XML namespace that a
node joining the overlay MUST support.  The presence of a mandatory-extension
element does not require the extension to be used in the current configuration
file, but can indicate that it may be used in the future. Note that the
namespace is case-sensitive, as specified in
[http://www.w3.org/TR/REC-xml-names/] section 2.3.  More than one
mandatory-extension element may be present."

Section 10.1.1:

"parameter &= element mandatory-extension { xsd:string }*"

- -- 
Marc Petit-Huguenin
Personal email: [email-masked]
Professional email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 26 Apr 2011 13:09:34 -0600

Add this in -14 of draft. 

On Apr 22, 2011, at 11:16 AM, Marc Petit-Huguenin wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.11 (GNU/Linux)
> 
> iEYEARECAAYFAk2xt/oACgkQ9RoMZyVa61fXcwCfY/2iCIYHF2WdbLw4TNm6x6cg
> 89UAoI93gjUOc3runcidnwXBvTcCEjaU
> =ey3c
> -----END PGP SIGNATURE-----
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip