Subject: [P2PSIP] Java P2PSIP implementation‏‏

From: Galal Nasim <[email-masked]>
Date: Tue, 25 Oct 2011 15:23:57 +0200

Dear All,

I'm a PhD student recruited into a new group intended to do research on
P2PSIP security. One of our initial goals was to look for java P2PSIP
implementations. I'd like to share the result here:

There are 3 main Java implementations:

Open source

   1. University of Parma Kademlia dSIP.

      a. Development seems to be stopped (last updates in 2007).

      b. Based on P2P-over-SIP architecture (not adopted by the working
group).

Closed source

   2. Ericsson Research Nomadiclab P2PSIP prototype.

   3. Rhodes University OverCord.

Does anybody know if there is a plan from Ericsson Research Nomadiclab or
Rhodes University to open source there prototypes? And whether their
implementations are similar to the RELOAD P2P transport protocol currently
being finalized by the WG or not.

Is there any other open source java implementation out there?

Is there anybody working on adding P2PSIP capability to Jitsi (SIP
Communicator)?

Regards,

Galal

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Tue, 25 Oct 2011 06:56:54 -0700

On 10/25/2011 06:23 AM, Galal Nasim wrote:
>  
> 
> Dear All,
> 
>  
> 
> I'm a PhD student recruited into a new group intended to do research on P2PSIP
> security. One of our initial goals was to look for java P2PSIP implementations.
> I'd like to share the result here:
> 
>  
> 
>       b. Based on P2P-over-SIP architecture (not adopted by the working group).
> 
> Closed source
> 
> Does anybody know if there is a plan from Ericsson Research Nomadiclab or Rhodes
> University to open source there prototypes? And whether their implementations
> are similar to the RELOAD P2P transport protocol currently being finalized by
> the WG or not.
> 
>  
> 

My implementation (which is still incomplete) is released under a free software
license.  All the information are on my blog, see the signature below.

> 
>  
> 
> Is there anybody working on adding P2PSIP capability to Jitsi (SIP Communicator)?
> 

You should contact Emil Ivov for that.

I would also recommend subscribing to the reload mailing list, which is the
place to talk about RELOAD implementations:

http://implementers.org/mailman/listinfo/reload

- -- 
Marc Petit-Huguenin
Personal email: [email-masked]
Professional email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org