Subject: Re: [P2PSIP] RELOAD fragmentation

From: Bruce Lowekamp <[email-masked]>
Date: Sun, 30 Oct 2011 11:56:45 -0400

Marc,

How about:

Each
fragment MUST contain a full copy of the via list, destination list,
and ForwardingOptions and
MUST contain at least 256 bytes of the message body. If these elements
cannot fit within the MTU of the underlying datagram protocol, RELOAD
fragmentation is not performed and IP-layer fragmentation is allowed
to occur.

?

Bruce

On Mon, Sep 19, 2011 at 4:58 PM, Marc Petit-Huguenin <[email-masked]> wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> In section 5.7:
>
> "Each fragment MUST contain a full copy of the via and
>  destination list and MUST contain at least 256 bytes of the message
>  body.  If the via and destination list are so large that this is not
>  possible, RELOAD fragmentation is not performed and IP-layer
>  fragmentation is allowed to occur."
>
> I think that the text should say this instead:
>
> "Each fragment MUST contain a full copy of the via list,
>  destination list and options and MUST contain at least 256 bytes of
>  the message body.  If the via list, destination list and options are
>  so large that this is not possible, RELOAD fragmentation is not
>  performed and IP-layer fragmentation is allowed to occur."
>
> - --
> Marc Petit-Huguenin
> Personal email: [email-masked]
> Professional email: [email-masked]
> Blog: http://blog.marc.petit-huguenin.org
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.11 (GNU/Linux)
>
> iEYEARECAAYFAk53rOgACgkQ9RoMZyVa61cN/QCZATAXCAGPN8u5Opw4aBYQmmbX
> 60IAoJRyoBZQIe0XR4vvB4BNxVOY8Obo
> =RDGo
> -----END PGP SIGNATURE-----
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip
>

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Sun, 30 Oct 2011 12:04:52 -0400

> fragmentation is not performed and IP-layer fragmentation is allowed

Your text is unambiguous, so it's fine for me.

- -- 
Marc Petit-Huguenin