Subject: [P2PSIP] FW: New Version Notification for draft-ietf-p2psip-diagnostics-07.txt

From: Songhaibin <[email-masked]>
Date: Wed, 28 Dec 2011 09:45:09 +0000

Hi all,

The diagnostics draft has been updated. The major comments from Marc was solved. Any comments are welcome.

BR,
-Haibin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, December 28, 2011 5:42 PM
> To: Songhaibin
> Cc: [email-masked]; Songhaibin; Johnson Jiang(Xingfeng); Roni even
> Subject: New Version Notification for draft-ietf-p2psip-diagnostics-07.txt
> 
> A new version of I-D, draft-ietf-p2psip-diagnostics-07.txt has been successfully
> submitted by Haibin Song and posted to the IETF repository.
> 
> Filename:	 draft-ietf-p2psip-diagnostics
> Revision:	 07
> Title:		 P2PSIP Overlay Diagnostics
> Creation date:	 2011-12-28
> WG ID:		 p2psip
> Number of pages: 30
> 
> Abstract:
>    This document describes mechanisms for P2PSIP diagnostics.  It
>    defines extensions to the RELOAD P2PSIP base protocol RELOAD
>    [I-D.ietf-p2psip-base] to collect diagnostic information, and details
>    the protocol specifications for these extensions.  Useful diagnostic
>    information for connection and node status monitoring is also
>    defined.  The document also describes the usage scenarios and
>    provides examples of how these methods are used to perform
>    diagnostics in a P2PSIP overlay networks.
> 
> 
> 
> 
> The IETF Secretariat

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Wed, 28 Dec 2011 08:33:39 -0800

Hi,

Thanks for the new version.  I updated the Wireshark dissector accordingly,
please see my post in the RELOAD implementers mailing-list:

http://implementers.org/archives/reload/2011-December/000019.html

Note that there is still some of my previous comments that are not addressed in
this new version:

1.  } DiagnosticExtension

";" is missing at the end

2. DescriptionExtension

The definition of DiagnosticExtension is still not compatible with the data
description language ("<>" and "case > 0").  One definition that is bit
compatible is this:

struct {
  uint64 expiration;
  uint64 timestamp_initiated;
  uint32 length;
  uint64 dMFlags;
  DiagnosticExtension diagnostic_extensions[length];
} DiagnosticsRequest;

Another definition that is simpler but not bit-compatible:

struct {
  uint64 expiration;
  uint64 timestamp_initiated;
  uint64 dMFlags;
  DiagnosticExtension diagnostic_extensions<0..2^32-1>;
} DiagnosticsRequest;

Nits (old and new):
- ----

- - Section 1

s/compliment/complement/

- - Section 3

s/from the overlay ./from the overlay./

- - Section 4.1

s/the RELOAD ping/the RELOAD Ping/

- - Section 4.3

s/-- one/- one/

- - Section 5.1

s/are defined.  DiagnosticRequest/are defined, DiagnosticRequest/

- - Section 5.1.1

s/inSection 9.6/in Section 9.6/

- - Section 5.1.2

s/Section 5.1.1Paragraph 5/Section 5.1.1 Paragraph 5/

- - Section 5.1.3

s/ox00/0x00/
s/ox0F/0x0F/

- - Section 5.3

s/New Reqeust/New Request/

- - Section 5.5.1, first paragraph

s/Ping message or with/Ping message with/

>>    diagnostics in a P2PSIP overlay networks.

- -- 
Marc Petit-Huguenin
Personal email: [email-masked]
Professional email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org