Subject: [P2PSIP] Concepts Draft

From: David Bryan <[email-masked]>
Date: Fri, 13 Jun 2014 15:40:12 -0500

I was recently asked to update the concepts draft and discuss the important
issues. The pass that has been made is largely around normalizing the text
to be compliant with the terminology of RFC 6940, but it certainly will
need an additional pass after a few questions to the group:

To move this draft forward, there are a few open issues/questions:

   MAJOR OPEN ISSUE: The initial wording in the high-level description
   about proving AoR to contact mapping reflects a very long and
   contentious debate about the role of the protocol, and reflected a
   pretense that this was an overlay only for P2PSIP.  That is not
   really true in base anymore (see last paragraph of introduction) and
   the language has been very much genericized in base.  Should we make
   this text more abstract and then use AoR->contact mapping as an
   example of the (original) use?  On a related note, see the last
   paragraph of the Background section -- do we want to reword this?

(my thought would be to make the text more generic, and mention that the
AoR->contact mapping is the most popular usage...)

   OPEN ISSUE: Should we include a section that documents previous
   decisions made, to preserve the historical debate and prevent past
   issues from being raised in the future, or simply rely on the mailing
   list to address these concerns?

(I don't think we want to do this. Huge (and largely unneeded) can of
worms, but it has been in the open issues section for some time and should
be at least asked of the list)

   OPEN ISSUE: Should we include the use cases from
   draft-bryan-p2psip-app-scenarios-00 (now long expired)?  There was
   some interest in doing so in previous versions, but no conclusion was
   reached.

(given the current stage of the group, I would say these aren't likely to
be useful anymore, but again, as it is currently listed as an open issue in
the draft, need to check)

The final open issue is do we want to advance the draft? In discussion with
the chairs and some folks, it seems the answer is yes, there is useful
material and we should push the draft out, but I wanted to discuss.
Assuming there is still interest, I'd also welcome any comments on the
draft...I'm sure I missed a few spots where it no longer aligns with 6940.

David

---

From: "Songhaibin (A)" <[email-masked]>
Date: Mon, 16 Jun 2014 01:20:56 +0000

Hi David,

Best Regards!
-Haibin

From: P2PSIP [mailto:[email-masked]] On Behalf Of David Bryan
Sent: Saturday, June 14, 2014 4:40 AM
To: P2PSIP WG
Subject: [P2PSIP] Concepts Draft

I was recently asked to update the concepts draft and discuss the important issues. The pass that has been made is largely around normalizing the text to be compliant with the terminology of RFC 6940, but it certainly will need an additional pass after a few questions to the group:

(my thought would be to make the text more generic, and mention that the AoR->contact mapping is the most popular usage...)

[Haibin] I agree. And the last paragraph in background section needs rewording where it says DHT is just for a distributed SIP registrar.

(I don't think we want to do this. Huge (and largely unneeded) can of worms, but it has been in the open issues section for some time and should be at least asked of the list)

[Haibin] Is it a normal practice to document that? And for a concept draft? I do not think so.

(given the current stage of the group, I would say these aren't likely to be useful anymore, but again, as it is currently listed as an open issue in the draft, need to check)

[Haibin] It is usually good to have application scenarios, but with regarding to the current status of this group,  it might be better to document those in a independent draft if we really need them.

The final open issue is do we want to advance the draft? In discussion with the chairs and some folks, it seems the answer is yes, there is useful material and we should push the draft out, but I wanted to discuss. Assuming there is still interest, I'd also welcome any comments on the draft...I'm sure I missed a few spots where it no longer aligns with 6940.

[Haibin] IMO, yes.

BR,
-Haibin

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 17 Jun 2014 17:33:06 +0000

On Jun 13, 2014, at 4:40 PM, David Bryan <[email-masked]> wrote:

> (my thought would be to make the text more generic, and mention that the AoR->contact mapping is the most popular usage…)
Agree

> (I don't think we want to do this. Huge (and largely unneeded) can of worms, but it has been in the open issues section for some time and should be at least asked of the list)
No, we don’t need to do this

> (given the current stage of the group, I would say these aren't likely to be useful anymore, but again, as it is currently listed as an open issue in the draft, need to check)
Nah, I don’t think it is necessary, or even that useful at this point

> The final open issue is do we want to advance the draft? In discussion with the chairs and some folks, it seems the answer is yes, there is useful material and we should push the draft out, but I w…
I would like to see this finished.

> 
> David
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip