Subject: [Pals] Fwd: New Version Notification for draft-bryant-pals-ethernet-cw-00.txt

From: Stewart Bryant <[email-masked]>
Date: Thu, 25 May 2017 21:01:29 +0100

At the last IETF a concern was raised by the folks that also attend IEEE 
802 that there
was a problem with PW packets being mistaken for IP packets and 
incorrectly ECMPed.
This has recently been highlighted at a number of operator forums. We 
agree with
our AD that we could write a draft on the problem and recommended solution.

As the draft explains we knew about the problem, but a change of 
Ethernet Address
allocation policy has caused the problem to be more severe than it once was.

Ignas has some more text on operational considerations to add to the 
next version.

We have scheduled a short WG meeting in Prague to discuss, and as both 
chairs
are authors we will be looking for an independent shepherd to manage the
discussion and put the draft through the IETF process.

Best Regards

- Stewart

-------- Forwarded Message --------
Subject: 	New Version Notification for draft-bryant-pals-ethernet-cw-00.txt
Date: 	Thu, 25 May 2017 12:52:57 -0700
From: 	[email-masked]
To: 	Stewart Bryant <[email-masked]>, Ignas Bagdonas 
<[email-masked]>, Andrew Malis <[email-masked]>, Andrew G 
Malis <[email-masked]>

A new version of I-D, draft-bryant-pals-ethernet-cw-00.txt
has been successfully submitted by Stewart Bryant and posted to the
IETF repository.

Name:		draft-bryant-pals-ethernet-cw
Revision:	00
Title:		Use of Ethernet Control Word RECOMMENDED
Document date:	2017-05-25
Group:		Individual Submission
Pages:		8
URL:            https://www.ietf.org/internet-drafts/draft-bryant-pals-ethernet-cw-00.txt
Status:         https://datatracker.ietf.org/doc/draft-bryant-pals-ethernet-cw/
Htmlized:       https://tools.ietf.org/html/draft-bryant-pals-ethernet-cw-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-bryant-pals-ethernet-cw-00

Abstract:
    The pseudowire (PW) encapsulation of Ethernet, as defined in RFC4448,
    specifies that the use of the control word (CW) is optional.  In the
    absence of the CW an Ethernet pseudowire packet can be misidentified
    as an IP packet by a label switching router (LSR).  This in turn may
    lead to the selection of the wrong equal-cost-multi-path (ECMP) path
    for the packet, leading in turn to the mis-ordering of packets.  This
    problem has become more serious due to the deployment of equipment
    with Ethernet MAC addresses that start with 0x4 or 0x6.  The use of
    the Ethernet PW CW addresses this problem.  This document recommends
    the use of the Ethernet pseudowire control word in all but
    exceptional circumstances.

    This document updates RFC4448.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 31 May 2017 16:32:20 +0100

Can I take silence as agreement with this draft :)

Stewart

On 25/05/2017 21:01, Stewart Bryant wrote:
>
>
> At the last IETF a concern was raised by the folks that also attend 
> IEEE 802 that there
> URL:https://www.ietf.org/internet-drafts/draft-bryant-pals-ethernet-cw-00.txt
> Status:https://datatracker.ietf.org/doc/draft-bryant-pals-ethernet-cw/
> Htmlized:https://tools.ietf.org/html/draft-bryant-pals-ethernet-cw-00
> Htmlized:https://datatracker.ietf.org/doc/html/draft-bryant-pals-ethernet-cw-00
>
>
> Abstract:

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 31 May 2017 18:37:51 +0000

Stewart, and all
From my POV this should have been done long ago. But late is definitely better than never!

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

From: Pals [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Wednesday, May 31, 2017 6:32 PM
To: [email-masked]
Cc: Ignas Bagdonas <[email-masked]>; Andrew G. Malis <[email-masked]>
Subject: Re: [Pals] Fwd: New Version Notification for draft-bryant-pals-ethernet-cw-00.txt

Stewart

At the last IETF a concern was raised by the folks that also attend IEEE 802 that there
was a problem with PW packets being mistaken for IP packets and incorrectly ECMPed.
This has recently been highlighted at a number of operator forums. We agree with
our AD that we could write a draft on the problem and recommended solution.

As the draft explains we knew about the problem, but a change of Ethernet Address
allocation policy has caused the problem to be more severe than it once was.

Ignas has some more text on operational considerations to add to the next version.

We have scheduled a short WG meeting in Prague to discuss, and as both chairs
are authors we will be looking for an independent shepherd to manage the
discussion and put the draft through the IETF process.

Best Regards

- Stewart

-------- Forwarded Message --------
Subject:

New Version Notification for draft-bryant-pals-ethernet-cw-00.txt

Date:

Thu, 25 May 2017 12:52:57 -0700

From:

[email-masked]<mailto:[email-masked]>

To:

Stewart Bryant <[email-masked]><mailto:[email-masked]>, Ignas Bagdonas <[email-masked]><mailto:[email-masked]>, Andrew Malis <[email-masked]><mailto:[email-masked]>, Andrew G Malis <[email-masked]><mailto:[email-masked]>

IETF repository.

Revision: 00

Pages:           8

Abstract:

The IETF Secretariat

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________