Subject: [Pals] RtgDir review: draft-ietf-pals-p2mp-pw-02.txt

From: "Patrice Brissette (pbrisset)" <[email-masked]>
Date: Thu, 11 May 2017 00:42:52 +0000

Hello,
I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir<http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir>
Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Document: draft-ietf-pals-p2mp-pw-02.txt
Reviewer: Patrice Brissette
Review Date: May 10, 2017
IETF LC End Date: May 12, 2017
Intended Status: Standard Track
Summary:

·         I have some minor concerns about this document that I think should be resolved before publication.

Comments:

  *   Please supply an overview of the draft quality and readability.
  *   Include anything else that you think will be helpful toward understanding your review.
Major Issues:

  *   "No major issues found."
Minor Issues:

·         Technically, I think the draft is completed. However, it doesn’t flow very well. Information is all over. I suggest the authors to review the layout/flow of the document.

Here are my “detailed” comments:

Abstract — What is the plus value on that draft? No clear

Many Long sentences in the text. very hard to understand and follow. Syntax to be improved.

Introduction
Typo : “A reference model or a P2MP PW is depicted in Figure 1 below”

“In this document, we specify a method of signaling P2MP
   PW using LDP.” —> suggest to move it from intro to abstract

Also, make sure the 3rd person is used. Try to a void “we” usage

May I suggest to have a requirement section. Requirements are all over the document.

“   In case of mLDP, a Leaf-PE can decide to join the P2MP LSP at any
   time; whereas in the case of RSVP-TE, the P2MP LSP is set up by the
   R-PE, generally at the initial service provisioning time. It should
   be noted that local policy can override any decision to join, add or
   prune existing or new L-PE(s) from the tree. In any case, the PW
   setup can ignore these differences, and simply assume that the P2MP
   PSN LSP is available when needed
“
Quite complex to follow. Missing to “why” / explanation.

“The LDP liberal label retention mode is used“
Another requirement… is that a MAY, SHOULD, MUST?

“In this case, a PW status message with status
   code of 0x00000008 (Local PSN-facing PW (ingress) Receive Fault) MUST
   also be sent to the R-PE“
How? The L-PE fails to join the P2MP PSN LSP.

Section 2.2
“   Note that since the LDP label mapping message is only sent by the R-
   PE to all the L-PEs, it is not possible to negotiate any interface
   parameters.“
Why is that note there? Is that already been mentioned previously. Fig.4 must  be moved to proper in the text OR create 2 subsection in 2.2

“As such, PW status negotiation procedure
   described in [RFC4447bis] is not applicable to P2MP PW. A node MUST
   NOT claim to be  P2MP PW capable by sending a LDP P2MP PW Capability
   TLV  if it is not also capable of handling PW status“

Should a node send LDP P2MP PW Capability TLV or not? Not well explain

There is some reference to LSR in the text where the major part use the wording “node”.

Nits:
N/A

Regards,
Patrice Brissette

---

From: "Patrice Brissette (pbrisset)" <[email-masked]>
Date: Thu, 11 May 2017 01:08:05 +0000

Hello,

Comments:
·         Please supply an overview of the draft quality and readability.
·         Include anything else that you think will be helpful toward understanding your review.
Major Issues:
·         "No major issues found."
Minor Issues:

Introduction

Section 2.2

Nits:
N/A

Regards,
Patrice Brissette