Subject: Re: [Pals] Genart last call review of draft-ietf-pals-ethernet-cw-06

From: Stewart Bryant <[email-masked]>
Date: Mon, 2 Jul 2018 11:19:33 +0100

Hi Brian

Thank you for your review comments. Please see inline.

On 12/06/2018 04:30, Brian Carpenter wrote:
> Reviewer: Brian Carpenter
> Review result: Ready with Nits
>
> Gen-ART Last Call review of draft-ietf-pals-ethernet-cw-06
>
> I am the assigned Gen-ART reviewer for this draft. The General Area
> Review Team (Gen-ART) reviews all IETF documents being processed
> by the IESG for the IETF Chair.  Please treat these comments just
> like any other last call comments.
>
> For more information, please see the FAQ at
> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
>
> Document: draft-ietf-pals-ethernet-cw-06.txt
> Reviewer: Brian Carpenter
> Review Date: 2018-06-12
> IETF LC End Date: 2018-06-15
> IESG Telechat date: 2018-06-21
>
> Summary: Ready with nits
> --------
>
> Comments:
> ---------
>
> This (with RFC4928) is a wonderful example of why layer violations are a Bad Thing.
>
> Nits:
> -----
>
>> 1.  Introduction
> ...
>>    This document recommends the use of the Ethernet pseudowire control
>>    word in all but exceptional circumstances.
> That's wrong, it *mandates* this usage with a MUST (first paragraph of section 4).

The text with the MUST is

"This document updates {{RFC4448}} to state that
where both the ingress PE and the egress PE support the Ethernet
pseudowire control word, then the CW MUST be used."

This is conditional on both equipments supporting the feature.

During WG discussion there was a lot of discussion on the degree to
which we would mandate the migration to CW.  The problem is that
the use of the CW has hardware implications. At one stage we went
so far as to recommend the the phasing out of equipment that could
not support the CW, but we got strong pushback from a specialist part
of the vendor community. This led us to a compromise position where
we RECOMMEND the use of the CW, but only  mandate that the CW be
used if it is available in the equipment used at both ends of
the PW.

>> 3.  Background
> ...
>>    A recent posting on the Nanog email list has highlighted this
>>    problem:
>>
>>    https://mailman.nanog.org/pipermail/nanog/2016-December/089395.html
> No, it's no longer recent. How about:
>
>     For example, a posting on the N email list highlighted this
>     problem:

I have changed the text to:

A posting on the NANOG email list highlighted this problem:

>
>> 7.  Operational Considerations
>>
>>    CW presence on the PW is controlled by the configuration and may be
>>    subject to default operational mode of not being enabled.
> That sentence is hard to parse. Try this:
>
>     A configuration switch might determine whether the CW is used on the PW.
>     The default configuration might be to disable use of the CW.
This now says:

In some cases, the inclusion of a CW in the PW is determined by
equipment configuration. Furthermore, it is possible that the default
configuration in such cases is  to disable use of the CW.

- Stewart

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 4 Jul 2018 08:37:05 +1200

Hi Stewart,

> used if it is available in the equipment used at both ends of

Fair enough, but the text doesn't quite say that.

OLD:
This document updates [RFC4448] to state that where both the
ingress PE and the egress PE support the Ethernet pseudowire control
word, then the CW MUST be used.

NEW:
This document updates [RFC4448] to state that both the
ingress PE and the egress PE SHOULD support the Ethernet
pseudowire control word, and that if supported the CW MUST be used.

Regards
    Brian

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 4 Jul 2018 13:48:31 +0100

Hi Brian

That seems to be a useful change which reflects the intent of the document.

Deborah, how do you want to deal with this, a re-spin or an editor's note.

- Stewart

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Wed, 4 Jul 2018 14:18:26 +0000

Since this is the only fix remaining, I can do it as an editor’s note.

Much thanks Brian for your very careful review and Stewart for sorting out and holding the pen!

I’ll approve tomorrow (after our holiday here - need to sort out logistics of hot dogs with lots of toppings currently:-))

Deborah

Sent from my iPhone

> On Jul 4, 2018, at 8:48 AM, Stewart Bryant <[email-masked]> wrote:
> 
> 
>