Subject: Re: [Pals] I-D Action: draft-cheng-pals-p2p-pw-multicast-01.txt

From: Stewart Bryant <[email-masked]>
Date: Thu, 21 Nov 2019 16:06:48 +0800

Hi,

Please can the authors help me understand why this is a PALS draft, or indeed why it is a draft at all?

I don’t think it proposes to extend the PALS technology. It simply uses PWs to carry L2 (presumably Ethernet) across a provider network, something that PWs already do.

Maybe I don’t understand the draft, but this looks like a deployment description that does not need standardisation.

Please can the authors help the WG better understand why this needs to be an IETF specification?

Best regards

Stewart

> On 19 Nov 2019, at 14:55, [email-masked] wrote:
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>        Title           : Efficient Layer 2 Multicast with Point-to-Point Pseudowires
>        Authors         : Weiqiang Cheng
>                          Jie Dong
> 	Filename        : draft-cheng-pals-p2p-pw-multicast-01.txt
> 	Pages           : 6
> 	Date            : 2019-11-18
> 
> Abstract:
>   Multicast services such as Evolved Multimedia Broadcast/Multicast
>   Service (eMBMS) become more and more popular in mobile networks.  In
>   mobile transport network, it is important for the operators to
>   provide efficient transport of multicast services with existing
>   network devices.  This document describes a mechanism of using point-
>   to-point Pseudowires (PW) [RFC3985] to achieve efficient layer 2
>   multicast transportation in mobile transport networks.The document
>   gives a multicast method by utilizing a Point-to-Point (P2P) path
>   between nodes in a packet transport network , according to the
>   destination IP address.  With it, the PTN nodes can replicate and
>   forward the service message, which are received from the multicast
>   server, to the plurality of multicast clients corresponding to the
>   destination IP address.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-cheng-pals-p2p-pw-multicast/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-cheng-pals-p2p-pw-multicast-01
> https://datatracker.ietf.org/doc/html/draft-cheng-pals-p2p-pw-multicast-01
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-cheng-pals-p2p-pw-multicast-01
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: David Sinicrope <[email-masked]>
Date: Thu, 21 Nov 2019 08:28:04 +0000

https://www.broadband-forum.org/technical/download/TR-221_Issue-1.pdf
See Appendix F

And 

https://www.broadband-forum.org/technical/download/TR-224.pdf
Section 13

Not sure these give the detail needed but they seem to address the same topic as the draft.

Dave

> On Nov 21, 2019, at 4:07 PM, Stewart Bryant <[email-masked]> wrote:
> 
> Hi,
> 
> Pals mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pals

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Thu, 21 Nov 2019 16:38:41 +0800

Hi Stewart,
Thank you for your comments.
The 00 version of draft was submitted to the WG about 2 years ago.
We've deployed it in our network and it works well. I updated it because I received some information from someone who met the similar issue.
The solution can provide P2MP services with the p2p PW. It is useful for operators those deployed the P2P PW (hardware only support P2P PW) only but they need to support P2MP services.
It is just for information and experience sharing. 

We updated it and would like to collect comments from group if we can continue the work here. 

B.R.
Weiqiang Cheng

-----邮件原件-----
发件人: Pals [mailto:[email-masked]] 代表 Stewart Bryant
发送时间: 2019年11月21日 16:07
收件人: [email-masked]; [email-masked]
主题: Re: [Pals] I-D Action: draft-cheng-pals-p2p-pw-multicast-01.txt

Hi,

Best regards

Stewart

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 21 Nov 2019 18:48:18 +0800

Normally the IETF does not publish relatively simple applicability RFCs. If we did we would be overloaded.

Whilst not a reference document the draft will be in the archive for ever so could be pointed to in network design advice if needed.

Dave pointed to the BBF which is a organisation.that specialises in deployment considerations.

Speaking entirely as an individual, I am not convinced that we should take this draft any further in the PALS wg.

Best regards

Stewart

> On 21 Nov 2019, at 16:38, Weiqiang Cheng <[email-masked]> wrote:
> 
> Hi Stewart,

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Mon, 25 Nov 2019 15:38:59 +0800

Hi Stewart,
Thanks a lot for your comments.
The current version just gave some description on the application scenario.
In order to deploy the solution to our network, we also develop some new protocol extension especially when we design the protection solution under the application scenario.
We will provide you more information about it further. 

B.R.
Weiqiang Cheng

-----邮件原件-----
发件人: Pals [mailto:[email-masked]] 代表 Stewart Bryant
发送时间: 2019年11月21日 18:48
收件人: Weiqiang Cheng
抄送: [email-masked]; [email-masked]
主题: Re: [Pals] I-D Action: draft-cheng-pals-p2p-pw-multicast-01.txt

Best regards

Stewart

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Mon, 25 Nov 2019 18:35:49 +0800

Hi David,

Thank you very much for your information.

We’ve read the document you provided and the application scenarios and solutions are different from the document.

The solution here is intent to give a multicast solution, the OAM and the protection functions in the network which only support p2p PW. The solution is different from the solution in BBF document. 

B.R.

Weiqiang Cheng

发件人: Pals [mailto:[email-masked]] 代表 David Sinicrope
发送时间: 2019年11月21日 16:28
收件人: Stewart Bryant
抄送: [email-masked]; [email-masked]
主题: Re: [Pals] I-D Action: draft-cheng-pals-p2p-pw-multicast-01.txt

https://www.broadband-forum.org/technical/download/TR-221_Issue-1.pdf <https://www.broadband-forum.org/technical/download/TR-221_Issue-1.pdf#page98> 

See Appendix F

And 

https://www.broadband-forum.org/technical/download/TR-224.pdf <https://www.broadband-forum.org/technical/download/TR-224.pdf#page71> 

Section 13

Dave

Hi,

Best regards

Stewart

 

 

      Authors         : Weiqiang Cheng

                        Jie Dong

   Pages           : 6

   Date            : 2019-11-18

Abstract:

 destination IP address.

 

[email-masked]