Subject: Re: [Pals] I-D Action: draft-cheng-pals-p2p-pw-multicast-01.txt

From: Stewart Bryant <[email-masked]>
Date: Mon, 9 Dec 2019 19:53:47 +0000

Hi Weiqiang Cheng

Please can I suggest exploring with David (who I understand is the editor of that BBF text) revising the BBF document to include your case. 

Best Regards

Stewart

> On 25 Nov 2019, at 10:35, Weiqiang Cheng <[email-masked]> wrote:
> 
> Hi David,
> Thank you very much for your information.
> We’ve read the document you provided and the application scenarios and solutions are different from the document.
> The solution here is intent to give a multicast solution, the OAM and the protection functions in the network which only support p2p PW. The solution is different from the solution in BBF document. 
>  
> B.R.
> Weiqiang Cheng
>  
>  
> 发件人: Pals [mailto:[email-masked]] 代表 David Sinicrope
> 发送时间: 2019年11月21日 16:28
> 收件人: Stewart Bryant
> 抄送: [email-masked]; [email-masked]
> 主题: Re: [Pals] I-D Action: draft-cheng-pals-p2p-pw-multicast-01.txt
>  
> https://www.broadband-forum.org/technical/download/TR-221_Issue-1.pdf <https://www.broadband-forum.org/technical/download/TR-221_Issue-1.pdf#page98>
> See Appendix F
>  
> And 
>  
> https://www.broadband-forum.org/technical/download/TR-224.pdf <https://www.broadband-forum.org/technical/download/TR-224.pdf#page71>
> Section 13
>  
> Not sure these give the detail needed but they seem to address the same topic as the draft.
>  
> Dave
>  
> 
> 
> On Nov 21, 2019, at 4:07 PM, Stewart Bryant <[email-masked]> wrote:
> 
>> Hi,
>> 
>> Please can the authors help me understand why this is a PALS draft, or indeed why it is a draft at all?
>> 
>> I don’t think it proposes to extend the PALS technology. It simply uses PWs to carry L2 (presumably Ethernet) across a provider network, something that PWs already do.
>> 
>> Maybe I don’t understand the draft, but this looks like a deployment description that does not need standardisation.
>> 
>> Please can the authors help the WG better understand why this needs to be an IETF specification?
>> 
>> Best regards
>> 
>> Stewart
>> 
>> 
>> On 19 Nov 2019, at 14:55, [email-masked] wrote:
>>>  
>>>  
>>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>>>  
>>>  
>>>       Title           : Efficient Layer 2 Multicast with Point-to-Point Pseudowires
>>>       Authors         : Weiqiang Cheng
>>>                         Jie Dong
>>>    Filename        : draft-cheng-pals-p2p-pw-multicast-01.txt
>>>    Pages           : 6
>>>    Date            : 2019-11-18
>>>  
>>> Abstract:
>>>  Multicast services such as Evolved Multimedia Broadcast/Multicast
>>>  Service (eMBMS) become more and more popular in mobile networks.  In
>>>  mobile transport network, it is important for the operators to
>>>  provide efficient transport of multicast services with existing
>>>  network devices.  This document describes a mechanism of using point-
>>>  to-point Pseudowires (PW) [RFC3985] to achieve efficient layer 2
>>>  multicast transportation in mobile transport networks.The document
>>>  gives a multicast method by utilizing a Point-to-Point (P2P) path
>>>  between nodes in a packet transport network , according to the
>>>  destination IP address.  With it, the PTN nodes can replicate and
>>>  forward the service message, which are received from the multicast
>>>  server, to the plurality of multicast clients corresponding to the
>>>  destination IP address.
>>>  
>>>  
>>> The IETF datatracker status page for this draft is:
>>> https://datatracker.ietf.org/doc/draft-cheng-pals-p2p-pw-multicast/
>>>  
>>> There are also htmlized versions available at:
>>> https://tools.ietf.org/html/draft-cheng-pals-p2p-pw-multicast-01
>>> https://datatracker.ietf.org/doc/html/draft-cheng-pals-p2p-pw-multicast-01
>>>  
>>> A diff from the previous version is available at:
>>> https://www.ietf.org/rfcdiff?url2=draft-cheng-pals-p2p-pw-multicast-01
>>>  
>>>  
>>> Please note that it may take a couple of minutes from the time of submission
>>> until the htmlized version and diff are available at tools.ietf.org.
>>>  
>>> Internet-Drafts are also available by anonymous FTP at:
>>> ftp://ftp.ietf.org/internet-drafts/
>>>  
>>> _______________________________________________
>>> I-D-Announce mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/i-d-announce
>>> Internet-Draft directories: http://www.ietf.org/shadow.html
>>> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>> 
>> _______________________________________________
>> Pals mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/pals

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 9 Dec 2019 15:14:55 -0500

Weiqiang and Jie,

I would suggest adding references to the BBF documents and limiting this
draft to what's not already covered there, and using the Independent Stream
to publish this as an implementation note for operators. I've copied the
ISE for his comments as well.

Cheers,
Andy

On Mon, Dec 9, 2019 at 2:54 PM Stewart Bryant <[email-masked]>
wrote:

> Hi Weiqiang Cheng
>
> Please can I suggest exploring with David (who I understand is the editor
> of that BBF text) revising the BBF document to include your case.
>
> Best Regards
>
> Stewart
>
>
> We’ve read the document you provided and the application scenarios and
> solutions are different from the document.
> The solution here is intent to give a multicast solution, the OAM and the
> protection functions in the network which only support p2p PW. The solution
> is different from the solution in BBF document.
>
> B.R.
> Weiqiang Cheng
>
>
> *发件人:* Pals [mailto:[email-masked] <[email-masked]>] *代表 *David
> Sinicrope
> *发送时间:* 2019年11月21日 16:28
> *收件人:* Stewart Bryant
> *抄送:* [email-masked]; [email-masked]
> *主题:* Re: [Pals] I-D Action: draft-cheng-pals-p2p-pw-multicast-01.txt
>
> https://www.broadband-forum.org/technical/download/TR-221_Issue-1.pdf
> <https://www.broadband-forum.org/technical/download/TR-221_Issue-1.pdf#page98>
> See Appendix F
>
> And
>
> https://www.broadband-forum.org/technical/download/TR-224.pdf
> <https://www.broadband-forum.org/technical/download/TR-224.pdf#page71>
> Section 13
>
> I don’t think it proposes to extend the PALS technology. It simply uses
> PWs to carry L2 (presumably Ethernet) across a provider network, something
> that PWs already do.
>
> Maybe I don’t understand the draft, but this looks like a deployment
> description that does not need standardisation.
>

---

From: "RFC ISE (Adrian Farrel)" <[email-masked]>
Date: Mon, 9 Dec 2019 13:55:08 -0800

Hi Andy,

Thanks for copying me in.

At this stage I have no opinion on publishing this document outside the
IETF (or at all). If the authors believe the document is ready for
publication on the Independent Stream and have read the note on the RFC
Editor web page, they can approach me to ask about publication.

I would, of course, be straight back to the PALS chairs to check that they
don't want to progress this through the working group (it sounds at this
stage that they don't).

And I would need to be convinced of the merits of publishing as an RFC
rather than as a paper, a web page, a wiki, or not at all.

Thanks,
Adrian

Andrew G. Malis wrote:
>> Please can the authors help the WG better understand why this needs to
>> be
>> an IETF specification?
>>
>> Best regards
>>
>> Stewart
>>
>>

-- 
Adrian Farrel (ISE),
[email-masked]

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Thu, 12 Dec 2019 11:09:28 +0800

Hi Andy and Stewart,

Thank you very much for your suggestion.

We will have some off-line discussion with David and other BBF experts at first, and clarify value of the case and the solution. 

And then we will go back to IETF and discuss the direction.

B.R.

Weiqiang Cheng

发件人: Andrew G. Malis [mailto:[email-masked]] 
发送时间: 2019年12月10日 04:15
收件人: Weiqiang Cheng; Dongjie (Jimmy)
抄送: [email-masked]; [email-masked]; Adrian Farrel; David Sinicrope; Stewart Bryant
主题: Re: [Pals] I-D Action: draft-cheng-pals-p2p-pw-multicast-01.txt

Weiqiang and Jie,

I would suggest adding references to the BBF documents and limiting this draft to what's not already covered there, and using the Independent Stream to publish this as an implementation note for operators. I've copied the ISE for his comments as well.

Cheers,

Andy

On Mon, Dec 9, 2019 at 2:54 PM Stewart Bryant <[email-masked]> wrote:

Hi Weiqiang Cheng

Best Regards

Stewart

Hi David,

B.R.

Weiqiang Cheng

 <https://www.broadband-forum.org/technical/download/TR-221_Issue-1.pdf#page98> https://www.broadband-forum.org/technical/download/TR-221_Issue-1.pdf

See Appendix F

And 

 <https://www.broadband-forum.org/technical/download/TR-224.pdf#page71> https://www.broadband-forum.org/technical/download/TR-224.pdf

Section 13

Dave

Hi,

Best regards

Stewart

 

 

      Authors         : Weiqiang Cheng

                        Jie Dong

   Pages           : 6

   Date            : 2019-11-18

Abstract:

 destination IP address.

 

[email-masked]