Subject: RE: COPS-PR for PAA-EP interface

From: Tschofenig Hannes <[email-masked]>
Date: Thu, 13 Mar 2003 17:04:50 +0100

hi yoshi,

please see my comment inline:

> 
> On Thu, Mar 13, 2003 at 11:18:11AM +0100, Tschofenig Hannes wrote:
> > > 
> > >  
> > > > In some scenarios, some keying material will be passed 
> > > along with the DI to
> > > > the EPs. Would new data types necessary for this, or does 
> > > COPS-PR already
> > > > handle this?
> > 
> > i guess that this is not fully correct. 
> > the ep is a link layer device from the perspective of the 
> pac. hence the pac
> > would not terminate a ipsec tunnel at the ep - that would 
> be done at the
> > paa. 
> 
> In some scenario, the EP is a link layer device, but in other scenario
> the EP can be an IP layer device and IPsec tunnel can be terminated at
> the EP (e.g., "PANA in the Absence of Any Lower-Layer Security"
> scenario in the usage scenarios draft.)  So I think the current EP
> definition in requirements-05 draft is valid.

the ep might be an ip device from a configuration point of view. however,
for the behavior of the pana protocol we said that the paa is on the same
link (i.e. it is the first ip device). this issue goes together with the
topology assumption. if you move the paa deeper into the network then the
topology problems becomes larger. 

hence: 
- paa is the first ip node
- ep is a link layer device (but might be configured as using ip-based
protocols)

ciao
hannes

---

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 13 Mar 2003 11:23:09 -0500

> topology problems becomes larger. 

I'm not talking about the location of PAA here.  (but yes, the PAA and
PaC must be exactly one IP hop away from each other.)

> - ep is a link layer device (but might be configured as using ip-based

In the following example in section A.3 of the requirement draft, EP
is co-located with PAA and AR, which implies that EP can be an IP
device and thus it can be an IPsec tunnel termination point.

        PaC ---------- EP/PAA/AR--+
        [D1]                      |
                                  + -------(AAA)
                                  |
        PaC ---------- EP/PAA/AR--+
        [D2]

        Figure 3: An example of  PANA Model
                  [PAA co-located with EP and AR]

Yoshihiro Ohba