Subject: RE: WG Last Call: draft-ietf-pana-usage-scenarios-04.txt

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Mon, 17 Mar 2003 00:08:52 +0100

Just an attempt to clarify this very complicated
topic.

  > >   Take APN concept in GRPS as an example (I am not 
  > suggesting to do this on
  > > WLAN) but if you were to do it.. one way to do that communication 
  > > request/authorization
  > > between the NAP and the client is do via PANA (I know 
  > this is not the best 
  > > example but
  > > something that came to my mind in a short notice :-)
  > 
  > This example means nothing to me since I have no idea what 
  > APN is and what it
  > does. Do you have a better example which can indicate which types of
  > "services" you are considering?
  > 
  > Also, is this a case where the PaC would dynamically request
  > different "services" over time? Does that imply the ability
  > to be able to "log out" from a service?
  > If the service selection is a static thing (derived from 
  > the entity that 
  > gets authenticated) then presumably the ability to pass 
  > filter specifications 
  > in AAA can be used.

=> The Access Point Name (APN) is a concept introduced
for GPRS. It is hard to give a concrete definition because
it is not consistent for all use cases. But examples of APNs
are : "IMS", which means that the device wishes to use the 
IP multimedia system, "Internet access" means: just give 
me open internet access, "company.com" means I want
access to my corporate network ....etc (there are no standard
names for APNs, these are just examples I made up).
The APN can cause the network to allocate addresses from
different address pools (e.g. company.com has its own address
pool that should be used by the GGSN). Clearly this concept
implies some filtering on outbound traffic based on both
the source and dst addresses. Also, the charging is tied to
that particular APN, e.g. time-based or flat rate ...etc.

I think adding these types of functions to PANA will
significantly (unnecessarily?) complicate matters. It's
a very complicated model and I don't think we need this
level of granularity in PANA. 

Hesham

---

From: Erik Nordmark <[email-masked]>
Date: Mon, 17 Mar 2003 06:18:49 +0100 (CET)

> that particular APN, e.g. time-based or flat rate ...etc.

I assume that in GPRS there is an access controld ecision
to verify that the authenticated principal can in fact use a particular
APN.
Thus the "profile" for the principal needs to list which APNs it is
allowed to use, right?

  Erik