Subject: Re: WG Last Call: draft-ietf-pana-usage-scenarios-04.txt[Correction]

From: "Mohan Parthasarathy" <[email-masked]>
Date: Fri, 7 Mar 2003 09:25:17 -0800

The document looks good except for these minor issues.

1) In section 2, Problem statement

	"Access networks usually require clients to go through an authentication and
       authorization process unless physical security is used as a substitute".

   In section 3.1, PANA with physical layer security,
   
      "In the networks where a certain degree of security is provided at physical
       layer, authenticating the client is still essential since physical layer
       does not provide information on the client..."

   It is not a major thing. But it was a bit confusing to read.

2) In section (2),
 
	    Initial client authentication needs 
          to be bound to subsequent traffic to prevent spoofing and hijacking
          of data packets. 

      What do you mean by hijacking of data packets ? 

		 Therefore, this authentication might be required to
             generate cryptographic keying material unless presence of a secure
             physical or link-layer channel is assured prior to it.

      "assured prior to it" is a bit confusing to me. So, this can be reworded to 

          "Therefore this authentication might be required to generate cryptographic
           keying material unless the link is secure at physical or link layer".

3) In section (2), following 2 sentences are still confusing me.

		PANA is only responsible for carrying EAP and it should not have
            to deal with the keying material.Once the keying material is present

       You talked about the need for generating key material a few lines back.
       Here we are saying PANA will not do it. I think you may want to say, that
       EAP will be used to generate the keying materail (refer that EAP-keying draft).

		The mechanisms that are used to turn keying material produced by
            the initial authentication method into link-layer or network-layer
            ciphers are outside the scope of PANA.

       Is it outside the scope PANA or PANA WG ? The next question someone will ask
       is "how does PANA prevent service theft" ?

4) In section (3.3), towards the end

		A solution like PANA at the network layer may be adequate if it can
            specify appropriate authentication methods that can derive and distribute
            keys for authentication, integrity and confidentiality of data traffic
            either at the link or at the network layer. 

     Again it is not clear what PANA is doing here. And confidentiality can be removed
     i think as per the last ietf meeting.

5) In section 3.6, Limited Free Access,

		On the other hand, access to further services or sites using such local
            networks requires authentication and authorization.  If users want such
            services, the access network can detect that attempt and initiate
            authentication.  This also allows the network to initiate the 
            authentication whenever appropriate.

      I think the last sentence can be modified to "This also allows the network to
      initiate the authentication to authenticate the client whenever appropriate".
      You may ignore this if it is redundant. But when i read it first time, it was
      a bit confusing.

thanks
mohan

> -----Original Message-----
> From: Alper Yegin [mailto:[email-masked]]
> Sent: Tuesday, March 04, 2003 5:23 PM
> To: Mohan Parthasarathy
> Subject: FW: WG Last Call:
> draft-ietf-pana-usage-scenarios-04.txt[Correction]
> 
> 
> Hi Mohan,
> 
> If you have time, can you please take a look at this and 
> provide comments
> for the LC? It's a short and easy reading. It got reviewed by 
> folks before,
> this is the WG last call.. Deadline is March 11th, next Tuesday.
> 
> Thank you.
> 
> alper
> 
> 
> ------ Forwarded Message
> From: <[email-masked]>
> Date: Tue, 25 Feb 2003 17:35:59 -0600
> To: <[email-masked]>
> Cc: <[email-masked]>, <[email-masked]>
> Subject: RE: WG Last Call: draft-ietf-pana-usage-scenarios-04.txt
> [Correction]
> Resent-From: [email-masked]
> Resent-Date: Tue, 25 Feb 2003 18:39:52 -0500 (EST)
> 
> 
> Correction about the date for receiving comments:
> 
> March 11th 2003 is the deadline for receiving comments on this draft.
> 
> -Basavaraj 
> 
> > 
> > Hello,
> > 
> > This is a WG last call for: Problem Space and Usage 
> Scenarios for PANA
> > I-D : draft-ietf-pana-usage-scenarios-04.txt
> > 
> > Status sought : Informational
> > 
> > Please send in your comments by April 11th, 2003 to the WG 
> discussion
>                                   ^^^^^^^^^^^^^^^^
> > list. 
> > 
> > -Chairs
> > 
> > 
> 
> 
> 
> ------ End of Forwarded Message
> 
>

---

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 12 Mar 2003 11:53:02 -0500

Hi Mohan,

Thanks for reviewing the draft and sorry for my delayed response.  
Please see my comments in line.

>    It is not a major thing. But it was a bit confusing to read.

I see.  Perhaps we can remove "unless physical security is used as a
substitute" from the sentense in section 2.

>       What do you mean by hijacking of data packets ? 

It means service theft.  So how about the following?

   Initial client authentication needs to be bound to subsequent
   traffic to prevent spoofing of data packets and resulting service
   theft.

>            keying material unless the link is secure at physical or link layer".

Yes, that would be better.

>        EAP will be used to generate the keying materail (refer that EAP-keying draft).

I think the following already mentions the use of EAP to generate the
keying material:

   "The task of generating and distributing such keying material can be
   accomplished by various authentication methods carried by EAP."

Isn't it enough?

>        is "how does PANA prevent service theft" ?

According to the current charter, defining key distribution, key
agreement or key derivation protocols is out of the scope of PANA.  On
the other hand, the text talks about key derivation mechanisms, not
key derivation protocols, and the mechanisms may be in the sope of PANA...

What do others think?

>      i think as per the last ietf meeting.

I'm not sure which part is not clear in the above text.  Could you
elaborate or provide suggested text?

>       You may ignore this if it is redundant. But when i read it first time, it was

OK.

Thanks,
Yoshihiro Ohba