Subject: RE: question: pana messaging

From: <[email-masked]>
Date: Mon, 14 Apr 2003 13:56:29 -0500

>hi all,
>
>the pana draft describes some messages. these messages have a certain
>semantic and are in most cases directional e.g.
>
>      PANA-Start-Request       <--------
>      PANA-Start-Answer        -------->
>
>      PANA-Auth-Request        <--------
>      PANA-Auth-Answer         -------->
>
>why isn't it possible to use these messages in both directions? 

At least the messages you mention above can be used in either
direction. 

>it would be
>good to have a generic message which can be executed from both entities (pac
>and paa) especially with respect to extensibility.
>
>furthermore, if the pac is preconfigured with the address of the paa then
>there is no need for a discovery message. 

True.

>hence the PANA-Start-Request (or
>better the PANA-Auth-Request) could go from the pac to the paa. currently
>the cookie stuff mandates a certain direction (thank you dan for pointing to
>this issue).
>
>here are my questions:
>a) should we add a message to carry AVPs in both directions?

What kind of AVPs did you have in mind? Also I am still unclear of the
added benefit of having a generic message that is direction
independent. I think the current message set is already sufficient. if
you think there is some functionality mandated by requirements that
cannot be met via these messages, only then we should think of adding
a new message. Otherwise it is better to keep the message set limited.

>c) should we optimize signaling if the pac is already configured with the ip
>address of the paa?

Absolutely.

>
>please read the pana draft and verify that the signaling message handling
>works in all your  scenarios.
>
>ciao
>hannes

-bp

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Wed, 16 Apr 2003 15:20:22 +0200

hi,

please see my comments inline:

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Montag, 14. April 2003 20:56
> To: [email-masked]; [email-masked]
> Subject: RE: question: pana messaging
>
>
>
> >hi all,
> >
> What kind of AVPs did you have in mind?

capability negotiation for example.

 Also I am still unclear of the
ciao
hannes