Subject: RE: Choice of ciphering (was Re: question: pana messaging)

From: "Mohan Parthasarathy" <[email-masked]>
Date: Wed, 23 Apr 2003 15:05:53 -0700

Alper,

> 
> The current pana protocol design is quite rigid with respect 
> to enabling
> data protection after pana: The network mandates use of 
> either L2 or L3
> ciphering, or none. But never both. Client has to accept the 
> choice of the
> network. That's it.
> 
> Now we are thinking if we can flex this a bit, that's fine.
> 
> I think what we are looking at is the ability to provide some optional
> ciphering, or multi-layer protection. Such as:
> 
> - The network can indicate which ciphering it mandates, and 
> which it can
> optionally provide.
> 
> For example, at the end of a successful PANA, PAA can indicate whether
> L2 ciphering is optionally provided or mandated, and similarly for L3
> ciphering. PaC has to use the mandatory one(s), and it can 
> indicate its
> optional choices.
> 
> Here are the combinations... Network provides:
> a- neither L2 nor L3 ciphering.
> b- no L2, but optional L3 ciphering.
> c- no L2, but mandatory L3 ciphering.
> d- optional L2 ciphering, no L3 ciphering.
> e- optional L2 ciphering and optional L3 ciphering.
> f- optional L2 ciphering and mandatory L3 ciphering.
> g- mandatory L2 ciphering, no L3 ciphering.
> h- mandatory L2 ciphering and optional L3 ciphering.
> i- mandatory L2 ciphering and mandatory L3 ciphering.
> 
> Does it make sense to have these scenarios?

I think we should try to keep it simple. Why would someone want both
L2 and L3 ciphering ? Is it because L2 is weak ? Then, why don't you
just use L3 ciphering alone. How does the PAA decide which one of the
above to use ? It is very complex. All you need is whether the network can
support L2 and/or L3 and client chooses one of them. Why isn't this sufficient ? 
> 
> When PAA indicates one of the above configurations, PaC will 
> have to agree
> with the mandatory ones, not request the unsupported ones, 
> and decide on the
> optional ones. So that, at the end of the PANA, the network 
> knows which ones
> need to be enabled. Of course the order of execution matters.
> 
> Could this be what we are talking about here?
> 
> Alper
> 
-mohan

---

From: Yoshihiro Ohba <[email-masked]>
Date: Tue, 22 Apr 2003 23:21:03 -0700

Hi Mohan,

Please see my comment below.

> support L2 and/or L3 and client chooses one of them. Why isn't this sufficient ? 

L3 ciphering does not protect MAC address spoofing, so a DoS attack
such as ARP spoofing is still possible in the case of IPv4.  On the
other hand, L2 ciphering does not protect IP address spoofing.  So I
think using both L2 and L3 ciphering (at least per-packet integrity
check) at the same time makes sense for the network where a
higher-level of security is required.  But I agree that doing
per-packet encryption at both layers might not make sense and thus
either L2 encryption or L3 encryption might be enough.

Yoshihiro Ohba

---

From: Alper Yegin <[email-masked]>
Date: Fri, 25 Apr 2003 14:57:15 -0700

> just use L3 ciphering alone.

These are fair questions, which I don't have good answers. I'm just the
messenger :)

> How does the PAA decide which one of the
> above to use?

PAA's configuration indicates which one of these is applicable. Note: This
config is per PAA, not per PaC.

>  It is very complex.

I'm not sure if it is really that complex. At the end of PANA, both the PaC
and PAA knows which ciphering needs to be turned on. Basically PAA indicated
which one(s) are mandatory, and PaC additionally chose optional one(s).
If L2 ciphers is included in this final list, it needs to be turned on. This
is just like what would have happened if only L2 ciphers were used.
If L3 ciphers is included, it'll be turned on next. This is independent of
whether L2 ciphering is on or off. Am I missing something?

> All you need is whether the network can

I think you meant to say "L2 or L3 but not both", right?
Doing both L2 and L3 is what you are questioning earlier.
Some clients doing L2 while some other doing L3 is complex.

Alper