Subject: RE: session-id

From: "Mohan Parthasarathy" <[email-masked]>
Date: Fri, 18 Apr 2003 11:04:19 -0700

Yoshihiro,

> > > 
> > > These observation might boil down to the following 
> functionalities 
> > > for
> > > PANA:
> > > 
> > > -  Ability to update device identifier, perhaps based on 
> add/delete
> > >    operation.
> > > 
> > > -  Ability to identify a PANA session based on a session 
> identifier, 
> > >    which is more stable identifier than device identifier.
> > > 
> > I think it would make sense to separate these two 
> identifiers. Device 
> > identifier is used for access control and it should just be 
> that. As 
> > there could be multiple of them in use at the same time, it 
> might make 
> > sense to use a separate identifier for session.
> 
> Are there any other scenarios where session-id is useful?
> 
I am not sure I understand the question. I thought the session id
is used for identifying the session related stuff of a given PaC.
But this leads to the problem of unique session ids. It might
be easy if the PAA allocates a session ID (like SPI allocated by
the receiver) to make it unique across all the PaCs.

-mohan

> Yoshihiro Ohba
> > -mohan
> > > Comments?
> > > Yoshihiro Ohba

---

From: Alper Yegin <[email-masked]>
Date: Fri, 18 Apr 2003 16:57:10 -0700

> the receiver) to make it unique across all the PaCs.

This makes sense. It might even make sense to have an NAI-like session id,
e.g., [email-masked], if we care about global identification for
any reason.

Alper